Ir ao conteúdo
  • Cadastre-se
João Vitor Lopes Alves

Portugol Algoritmo sobre a soma dos algarismos

Posts recomendados

Faça uma função que receba um número N e retorne a soma dos
algarismos de N!. Ex: se N = 4, N! = 24. Logo, a soma de seus algarismos é 2 + 4 = 6. Salve no
Portugol Studio com o nome “ 25_soma_algarismos.por ”.

Pelo o que eu entendi:

N = 4
N! = 24 (4*3*2*1), do numero vezes o seu antecessor até o número 1
SOMA ALGARISMOS É 2+4 = 6

Gostaria de entender como separar os algarismos!

programa
{
	
funcao nNumeros(inteiro numero){
		inteiro result = 0, n, soma = 0
		n = numero - 1
		enquanto(n >= 1){
		result = numero * n
		soma = soma + result
		n = n -1
	}
	escreva(soma)
	}
	
	funcao inicio()
	{
		inteiro numero
		escreva("Insira um número N: \n")
		leia(numero)
		nNumeros(numero)
	}
}

 

adicionado 42 minutos depois

Galera já consegui fazer, vou deixar aqui caso alguém também precise:

programa
{
	
funcao nNumeros(inteiro numero){
		inteiro result = 0, n, soma = 0, soma2 = 0, resultSoma = 0
		n = numero - 1
		enquanto(n >= 1){
		result = numero * n
		soma = soma + result
		n = n -1
	}
	escreva("N!:"+soma+"\n")
	faca{
		soma2 = soma %10
		soma = soma/ 10
		resultSoma = resultSoma + soma2
	}enquanto(soma > 0)
	escreva("A soma dos algarismos é: "+resultSoma)
	}

	
	funcao inicio()
	{
		inteiro numero
		escreva("Insira um número N: \n")
		leia(numero)
		limpa()
		escreva("N:"+numero+"\n")
		nNumeros(numero)
	}
}

 

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar agora





Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×
×
  • Criar novo...

GRÁTIS: minicurso “Como ganhar dinheiro montando computadores”

Gabriel TorresGabriel Torres, fundador e editor executivo do Clube do Hardware, acaba de lançar um minicurso totalmente gratuito: "Como ganhar dinheiro montando computadores".

Você aprenderá sobre o quanto pode ganhar, como cobrar, como lidar com a concorrência, como se tornar um profissional altamente qualificado e muito mais!

Inscreva-se agora!