Ir ao conteúdo
  • Cadastre-se
Visitante

Excel Substituir Texto Especifico - DATAS

Posts recomendados

Visitante

Bom dia, 

 

Tenho o seguinte texto em planilha: image.png.15a0de45ed318156b807599df3d4d285.png

 

Eu preciso reescrever : 18-03-09, sendo: 09-03-2018. 

Com a terceira linha que já esta: 2018-08-24, eu consigo reescrever usando a formula: =TEXT(RIGHT(B11;10);"dd-mm-aaaa") = 24-08-2018

 

O maior problema é a outra linha esta escrita o ano com duas casas.

 

Já tentei localizar e substituir CNTRL+F , porém quando coloco substituir: 18- para 2018- ele substitui até os que estão corretos.

 

Poderia me ajudar?

Compartilhar este post


Link para o post
Compartilhar em outros sites

Bom dia amigo,

 

Não sei se a solução abaixo é a mais indicada pro seu caso, mas testei aqui e funcionou:

 

=TEXT(RIGHT(CONCATENATE("20";B11);10);"dd-mm-aaaa")

 

P.S: Coloquei as funções em inglês porque parece que você usa o Excel assim... embora o formato da data esteja em português, o que é estranho.

Compartilhar este post


Link para o post
Compartilhar em outros sites

Já que o ano vem antes, uma sugestão seria:

=TEXTO(TEXTO(DIREITA(A1;8);"aa-mm-dd");"dd-mm-aaaa") (Português)

=TEXT(TEXT(RIGHT(A1,8),"yy-mm-dd"),"dd-mm-yyyy") (Inglês)

Ou ainda, formatando depois a célula para exibir a data corretamente:

=DATA.VALOR(TEXTO(DIREITA(A1;8);"aa-mm-dd"))  (Português)

=DATEVALUE(TEXT(RIGHT(A1,8),"yy-mm-dd"))      (Inglês)

 

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar agora





Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×
×
  • Criar novo...

Aprenda_a_Ler_Resistores_e_Capacitores-capa-3d-newsletter.jpg

ebook grátis "Aprenda a ler resistores e capacitores", de Gabriel Torres

GRÁTIS! BAIXE AGORA MESMO!