Ir ao conteúdo
  • Cadastre-se
Vollkana

Maior e menor nota

Recommended Posts

O professor passou um trabalho e está quase pronto, só estou quebrando a cabeça nessa parte, bem, o trabalho pede:

...informe ao usuário qual foi a maior e a menor média BIMESTRAL do aluno, durante o ano letivo;

Se fosse 2 notas, eu até conseguiria,

Se n1 > n2 então

Escreva "Maior nota bimestral:"

Escreva n1

Escreva "Menor nota bimestral:"

Escreva n2

Senao

Escreva "Maior nota bimestral:"

Escreva n2

Escreva "Menor nota bimestral:"

Escreva n1

Mas são quatro notas, (n1,n2,n3 e n4), então, alguém consegue ajudar a resolver?

Obg.

Compartilhar este post


Link para o post
Compartilhar em outros sites

Resolvi o seu problema da seguinte forma:

var
n1,n2,n3,n4:inteiro
inicio
escreval ("Digite a nota 1: ")
leia (n1)
escreval ("Digite a nota 2: ")
leia (n2)
escreval ("Digite a nota 3: ")
leia (n3)
escreval ("Digite a nota 4: ")
leia (n4)
se (n1>n2) e (n1>n3) e (n1>n4) então
escreval ("A maior nota do bimestre é: ",n1)
fimse
se (n2>n1) e (n2>n3) e (n2>n4) então
escreval ("A maior nota do bimestre é: ",n2)
fimse
se (n3>n1) e (n3>n2) e (n3>n4) então
escreval ("A maior nota do bimestre é: ",n3)
fimse
se (n4>n1) e (n4>n2) e (n4>n3) então
escreval ("A maior nota do bimestre é: ",n4)
fimse
se (n1=n2) e (n1=n3) e (n1=n4) e (n2=n3) e (n3=n4) então
escreval ("Os números são iguais!")
fimse

fimalgoritmo

Obs: O problema desse algoritmo é que ele aceita números maiores que 10.

Espero que ajude.;)

Compartilhar este post


Link para o post
Compartilhar em outros sites

Uma outra opção seria declarar mais duas variáveis para guardar a menor e a maior média.


var
n1, n2, n3, n4, menor, maior : inteiro
inicio
leia(n1, n2, n3, n4)

// consideremos que não exista nota "1000" nem nota "-1000"

menor <- 1000

// calcula a menor nota
se (n1 < menor) então
menor <- n1
fimse
se (n2 < menor) então
menor <- n2
fimse
se (n3 < menor) então
menor <- n3
fimse
se (n4 < menor) então
menor <- n4
fimse

maior <- -1000
// calcula a maior nota
se (n1 > maior) então
maior <- n1
fimse
se (n2 > maior) então
maior <- n2
fimse
se (n3 > maior) então
maior <- n3
fimse
se (n4 > maior) então
maior <- n4
fimse

// imprime
escreva(menor, maior)

fimalgoritmo

Aqui removi as mensagens do tipo escreva("Informe algo..."), para simplificar.

Compartilhar este post


Link para o post
Compartilhar em outros sites

Agora que estou vendo, esquece de agradecer, rs, obrigado aos dois, o primeiro funcionou, eu coloquei no projeto, o do PauloDougllasS, mas, jcmarques, se eu declarar uma variavel menor, e atribuir a ela o valor 1000, depois eu vou testar se, por exemplo, o n1 é menor que 1000, mas se o n2,n3 e n4 também for menor que 1000? não entendi isso, vishi.

@EDIT

Outro problema agora, eu ultilizei o primeiro código, e o programa ficou mais ou menos assim (vou pegar o exemplo que o PauloDougllasS usou):

Se (mediaanual > 5) então

Escreva "Aprovado"

Fim_se

Se (mediaanual > 5 .e. < 6) então

Escreva "Exame"

Fim_se

Se (medianual < 5) então

Escreva "Reprovado"

escreval ("Digite a nota 1: ")

leia (n1)

escreval ("Digite a nota 2: ")

leia (n2)

escreval ("Digite a nota 3: ")

leia (n3)

escreval ("Digite a nota 4: ")

leia (n4)

se (n1>n2) e (n1>n3) e (n1>n4) então

escreval ("A maior nota do bimestre é: ",n1)

fimse

se (n2>n1) e (n2>n3) e (n2>n4) então

escreval ("A maior nota do bimestre é: ",n2)

fimse

se (n3>n1) e (n3>n2) e (n3>n4) então

escreval ("A maior nota do bimestre é: ",n3)

fimse

se (n4>n1) e (n4>n2) e (n4>n3) então

escreval ("A maior nota do bimestre é: ",n4)

fimse

se (n1=n2) e (n1=n3) e (n1=n4) e (n2=n3) e (n3=n4) então

escreval ("Os números são iguais!")

fimse

O problema é que eu quero (na verdade, o professor) que apareça a maior e a menor nota do aluno independente se ele passou, reprovou ou ficou de exame, e o programa não está fazendo isso, alguém tem alguma solução?

@EDIT2

Ah, ja solucionei os dois problemas/duvidas, muito obrigado, podem fechar o tópico. ^^

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar agora





Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×