Ir ao conteúdo
  • Cadastre-se
Leonardo pinheiro

VisualG Algoritmo no VisualG para verificar se tem 18 ou mais !

Posts recomendados

Olá gostaria de uma ajuda pra desenvolver este problema ,não estou conseguindo montar o procedimento para mostrar se ele tem direito ou não, para poder tirar a habilitação.

Receba a idade do usuário e verifique se ele tem 18 anos ou mais. Se a resposta for positiva escrever

“maior de idade”, senão “menor de idade”. Se o usuário tiver idade maior igual a 18, escreva que pode tirar a habilitação, senão, deve indicar quantos anos que faltam para ele tirar a habilitação.

Compartilhar este post


Link para o post
Compartilhar em outros sites
Em 06/07/2020 às 21:50, Simon Viegas disse:

@Leonardo pinheiro, poste o que já conseguiu fazer e em qual parte está com dúvidas.

 

var
   idade : inteiro

inicio
   escreval("Informe sua idade")
   leia(idade)
   se(idade >= 18) então
      escreval("você pode tirar sua Habilitação")
   senao
      escreval("você não pode tirar sua Habilitação")
   fimse
fimalgoritmo

Consigo montar pra dizer se maior ou menor de idade preciso, que no final diga uma msg dizendo quantos anos falta para ele poder tirar a habilitação, senão, escreva que pode tirar a habilitação 

Compartilhar este post


Link para o post
Compartilhar em outros sites

@Leonardo pinheiro, basicamente precisaria entender o enunciado e fazer o que está pedindo. Exemplo:

 

 

Em 06/07/2020 às 21:37, Leonardo pinheiro disse:

Receba a idade do usuário [...]

algoritmo "Exercício 01"
var
   idade : inteiro

inicio
   escreval("Informe tua idade")
   leia(idade)

fimAlgoritmo

 

 

 

Em 06/07/2020 às 21:37, Leonardo pinheiro disse:

[...] verifique se ele tem 18 anos ou mais. Se a resposta for positiva escrever “maior de idade” [...]

algoritmo "Exercício 01"
var
   idade : inteiro

inicio
   escreval("Informe tua idade")
   leia(idade)
   se (idade >= 18) entao
      escreval("Maior de idade")
   fimSe
   
fimAlgoritmo

 

 

 

Em 06/07/2020 às 21:37, Leonardo pinheiro disse:

[...] senão “menor de idade”. [...]

algoritmo "Exercício 01"
var
   idade : inteiro

inicio
   escreval("Informe tua idade")
   leia(idade)
   se (idade >= 18) entao
      escreval("Maior de idade")
   senao
      escreval("Menor de idade")
   fimSe
   
fimAlgoritmo

 

 

 

Em 06/07/2020 às 21:37, Leonardo pinheiro disse:

[...] Se o usuário tiver idade maior igual a 18, escreva que pode tirar a habilitação [...]

algoritmo "Exercício 01"
var
   idade : inteiro

inicio
   escreval("Informe tua idade")
   leia(idade)
   se (idade >= 18) entao
      escreval("Maior de idade")
      escreval("Pode tirar a habilitação")
   senao
      escreval("Menor de idade")
   fimSe
   
fimAlgoritmo

 

 

 

Por fim:

Em 06/07/2020 às 21:37, Leonardo pinheiro disse:

[...] senão, deve indicar quantos anos que faltam para ele tirar a habilitação.

//Receba a idade do usuário e verifique se ele tem 18 anos ou mais. Se a
//resposta for positiva escrever “maior de idade”, senão “menor de idade”.
//Se o usuário tiver idade maior igual a 18, escreva que pode tirar a
//habilitação, senão, deve indicar quantos anos que faltam para ele tirar a
//habilitação.
algoritmo "Exercício 01"
var
   idade : inteiro

inicio
   escreval("Informe tua idade")
   leia(idade)
   se (idade >= 18) entao
      escreval("Maior de idade")
      escreval("Pode tirar a habilitação")
   senao
      escreval("Menor de idade")
      escreval("Faltam", (18 - idade), " para poder tirar habilitação")
   fimSe
   
fimAlgoritmo

 

adicionado 2 minutos depois

Caso entendam-se que são duas verificações separadas, só separá-las. Exemplo:

 

//Receba a idade do usuário e verifique se ele tem 18 anos ou mais. Se a
//resposta for positiva escrever “maior de idade”, senão “menor de idade”.
//Se o usuário tiver idade maior igual a 18, escreva que pode tirar a
//habilitação, senão, deve indicar quantos anos que faltam para ele tirar a
//habilitação.
algoritmo "Exercício 01"
var
   idade : inteiro

inicio
   escreval("Informe tua idade")
   leia(idade)

   se (idade >= 18) entao
      escreval("Maior de idade")
   senao
      escreval("Menor de idade")
   fimSe

   se (idade >= 18) entao
      escreval("Pode tirar a habilitação")
   senao
      escreval("Faltam", (18 - idade), " para poder tirar habilitação")
   fimSe
fimAlgoritmo

 

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar agora





Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas comunidades sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×
×
  • Criar novo...

Aprenda a ler resistores e capacitores

EBOOK GRÁTIS!

CLIQUE AQUI E BAIXE AGORA MESMO!