Ir ao conteúdo
  • Cadastre-se
Alice Braga

VisualG Fazer um programa para uma loja

Posts recomendados

Var
   // Seção de Declarações das variáveis
   nome:caractere
   prestacao:real
   atraso,x:inteiro
   quantidade:real
   total,juros:real
   mediafinal:real
funcao ValorPagamento(parprestacao,paratraso:real):real

inicio //inicio da funcao
   se (paratraso=0) entao  //calcular juros sem atraso
      parprestacao<-prestacao
      paratraso<-0
      juros<-paratraso
      total<-parprestacao
   fimse

   se (paratraso>=1) entao //calcular juros com atraso
      paratraso<-atraso
      parprestacao<-(prestacao*0.04)*(paratraso*10)
      juros<-parprestacao
      total<-prestacao+juros
   fimse
   retorne total
fimfuncao



Inicio //inicio principal
   // Seção de Comandos, procedimento, funções, operadores, etc...

   enquanto x<20 faca
      escreval("==============================")
      escreval("LOJA DO TIO BENÉ")
      escreval("")
      escreva("Seja bem vindo(a)! Digite o seu nome:")
      leia(nome)
      escreval("")
      escreva(nome,", qual é o valor da sua prestação:")
      leia(prestacao)
      se (prestacao=0) entao  //encerramento precoce
         escreval("encerrando o registro de dados...")
         escreval("pessoas registradas:",x)
         escreval("arrecadamento:",mediafinal)
         interrompa
      fimse
      escreval("")
      escreva("Quantos dias a sua prestação está em atraso:")
      leia(atraso)
      //chamando funcao
      quantidade<-ValorPagamento(prestacao,atraso)

      x<-x+1 //contador

      mediafinal<-mediafinal+total

      se atraso=0 entao
         escreval(nome," sua prestacao é de:",total)
      fimse
      se atraso>=1 entao
         escreval(nome," sua prestação é de:",prestacao)
         escreval("com:",juros," de juros")
         escreval("valor total:",total)
      fimse
   fimenquanto

Está certo??

prova logica oq e p fzr.PNG

  • Curtir 2

Compartilhar este post


Link para o post
Compartilhar em outros sites

Inicialmente se atente aos princípios básicos.

  • Faltou o comando algoritmo no topo do código;
  • Faltou o comando fimAlgoritmo no fim do código;
  • A função chama-se valorPagamento, e não ValorPagamento;
  • Dentro da função só utilize o que veio por parâmetro ou foi declarado dentro da função. O programa não deve utilizar dentro da função as variáveis globais (externas à função). Se precisar de novas variáveis, declare-as dentro da função;
  • O que mediafinal tem a ver com o contexto do programa?
  • O resultado deve ser informado no momento do encerramento, ou seja: após inserir 0 para o número de prestações.

 

@Alice Braga, sugiro recomeçar. Deixe esse programa guardado e faça um novo. Foque primeiramente apenas na função. Se ela não funcionar, nada adianta. Exemplo de base:

 

algoritmo "Cálculo de valor de pagamento"
var
   //nomeCliente: caractere
   valorPrestacao: real
   diasAtraso: inteiro

funcao valorPagamento(parPrestacao:real; parAtraso:inteiro):real
var
   total: real
inicio
   total <- 0

   //calcular sem atraso
   se (parAtraso = 0) entao
      total <- parPrestacao
   fimSe

   //calcular juros e multa para atraso
   se (parAtraso >= 1) entao





   fimSe

   retorne total
fimFuncao


inicio
   //TESTES DE RETORNOS DA FUNÇÃO valorPagamento()

   escreval("Valaro 1000 / Atraso 0:", valorPagamento(1000, 0))
   //deve aparecer 1000

   escreval("Valaro 500 / Atraso 2:", valorPagamento(500, 2))
   //deve aparecer xxxx

   escreval("Valaro 360 / Atraso 6:", valorPagamento(360, 6))
   //deve aparecer yyyy
   

   
fimAlgoritmo

Veja... Nesse primeiro momento apenas testar os resultados da função... O item 2.3.1.1 já implementei. Implemente agora o item 2.3.1.2. Lembre-se: você NÃO pode utilizar nada externo à função. As únicas coisas que ela precisa já estão sendo passadas pelo parâmetro. Se precisar de alguma variável, declare-a dentro da própria função.

 

Tente fazer apenas isso e poste o código completo aqui. Qualquer dúvida é só perguntar.

 

 

No aguardo

 

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar agora





Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas comunidades sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×
×
  • Criar novo...

Aprenda a ler resistores e capacitores

EBOOK GRÁTIS!

CLIQUE AQUI E BAIXE AGORA MESMO!