Ir ao conteúdo
  • Cadastre-se

VisualG algoritmo que permita entrar com o salário bruto e o valor da prestação


Posts recomendados

Exercício no VisualG, fiz um código, mas não esta funcionando. Alguém pode me ajudar a solucionar o erro? Vou deixar o código que fiz.

 

Var
// Seção de Declarações das variáveis 
    valor, prestacao: real

Inicio
// Seção de Comandos, procedimento, funções, operadores, etc... 

    escreval ("Digite o valor do salário:")
    leia (valor)
    escreva ("Valor da prestação:")
    leia (prestacao)
    se(valor * 0,3 <- prestacao)
então escreval( "Emprestimo Concedido!")
senão escreval ("Emprestimo Negado!")
fimse
Fimalgoritmo

 

A prefeitura de Contagem abriu uma linha de crédito para os funcionários estatutários. O valor máximo da prestação não poderá ultrapassar 30% do salário bruto. Fazer um algoritmo que permita entrar com o salário bruto e o valor da prestação, e informar se o empréstimo pode ou não ser concedido.

  • Curtir 1
Link para o post
Compartilhar em outros sites

A linha do condicional parece com erro. Na comparação você usa esses 3 símbolos < >  =. Então esse traço aí não deveria existir. Ou usa somente < (menor) ou usa a igualdade <= (menor ou igual).

O símbolo <- é de atribuição, quando você quer que determinada variável assuma um valor.

  • Curtir 1
Link para o post
Compartilhar em outros sites
  • DiF alterou o título para algoritmo que permita entrar com o salário bruto e o valor da prestação
  • Moderador
16 horas atrás, Guilherme candido disse:

Exercício no VisualG, fiz um código, mas não esta funcionando. Alguém pode me ajudar a solucionar o erro? Vou deixar o código que fiz.

 

Antes de qualquer coisa: que erro? Perceba que você apenas informou que "não está funcionando". Seria necessário informar o quê está ocorrendo aí.. :)

 

@Guilherme candido, temos alguns problemas no teu código... assim como o VisualG tem os seus próprios problemas. Além do uso do incorreto do "<-" (você tentou inserir um "<=" ?), temos outros errinhos... Então, para simplificar um pouco, segue um resumo:

  • a separação da casa decimal no código é representada por um ".", não por uma ",". Obs.: quando o programa está rodando, tanto faz usar "." (ex.: 1350.60), quanto "," (ex.: 1350,60). Mas no código tem que ser ".".
  • prefira nomenclatura de variáveis mais sugestíveis;
  • o VisualG não permite que o entao fique na linha abaixo do se, nem que os comandos venham depois do entao e do senao. Tem que ficar na ordem certa. Mais a baixo demonstro.

Segue um esboço:

 

algoritmo "Validação para empréstimos"
//A prefeitura de Contagem abriu uma linha de crédito para os funcionários
//estatutários. O valor máximo da prestação não poderá ultrapassar 30% do
//salário bruto. Fazer um algoritmo que permita entrar com o salário bruto
//e o valor da prestação, e informar se o empréstimo pode ou não ser concedido.

var
   salarioBruto, valorPrestacao: real

inicio
   escreva ("Digite o valor do salário : R$")
   leia(salarioBruto)
   escreva ("Valor da prestação: R$")
   leia(valorPrestacao)
   
   //apenas para ter uma rerefência (pois não foi pedido no enunciado)
   escreval("")
   escreval("Valor máximo para prestação: R$", salarioBruto * 0.30:1:2)
   escreval("")
   
   se valorPrestacao <= salarioBruto * 0.30 entao
      escreval( "Emprestimo Concedido!")
   senao
      escreval ("Emprestimo Negado!")
   fimSe
fimAlgoritmo

 

Adendo: a ordem dos tratores não alteram o viaduto... poderia ser assim também:

 

salarioBruto * 0.30 entao >= se valorPrestacao

 

São expressões equivalentes. (Tem o mesmo valor lógico.)

 

Qualquer dúvida ou comentário é só postar.

 

  • Curtir 1
Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar agora

Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas comunidades sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×
×
  • Criar novo...

Aprenda a ler resistores e capacitores

EBOOK GRÁTIS!

CLIQUE AQUI E BAIXE AGORA MESMO!