Ir ao conteúdo
  • Cadastre-se

Outro Reprogramar microcontrolador de micro system


Posts recomendados

boa noite , sou formado em eletrônica e estou tentando resolver um problema em um aparelho de som japones que tenho já algum tempo, pois ele estava parado e agora quando fui mexer nele, percebi que esta com problemas no controle de volume do som, pois quando vou girando  o potenciometrio ele nao altera o volume, somente quando esta na posição de aprox 1/3 dele é que o som vai aumentar, porém ele vai para o volume maximo, e nao altera e quando volto ele quase zera o volume,   gostaria de uma ajuda para tentar resolver este problema;

pois verifiquei  pelo esquema elétrico, que  chega uma tensão de 5v no potenciometro, e quando  ele é acionado controla a saida de tensão de 0v até 5v e esta tensão de saida vai para o um  microcontrolador marca  mitsubishi (m38173m6-227fp) , que posterior transforma  em  dados seriais e envia  este sinal para um  ci de controle de volume eletrônico (lc7536)  que por fim controla o volume dos alto falantes. gostaria de saber se alguem ja teve algo parecido com estes microcontroladores e controles de volume eletrônico que possa me dar ajuda , segue abaixo esquema 

 

1348210169_sansuiax-950(1).pdf

1556600912_microcontroladorsansui.pdf

controlador eletronico volume.PNG

Link para o post
Compartilhar em outros sites
  • Membro VIP
7 horas atrás, ailton759 disse:

quando esta na posição de aprox 1/3 dele é que o som vai aumentar, porém ele vai para o volume maximo, e nao altera e quando volto ele quase zera o volume

Tal pot é comum - analógico? Já chegou a cogitar problema com ele?

  • Curtir 1
Link para o post
Compartilhar em outros sites
  • BCP alterou o título para Reprogramar microcontrolador de micro system

Deu trabalho achar no esquema, pois na verdade não é um potenciômetro. 

Trata-se de um encoder. 

 

Pelo que relatou ele está sujo, nada a ver com o microcontrolador. 

 

Tem uma graxa dentro dele que seca e dá mal contato, você pode desmontar e limpar. 

  • Curtir 1
  • Obrigado 1
Link para o post
Compartilhar em outros sites
5 horas atrás, .if disse:

Tal pot é comum - analógico? Já chegou a cogitar problema com ele?

Potenciômetro comum , porém ele tem 4 terminais que um terminal é Loudnes , já testei e toquei ele coloquei novo e que mudou é que ele aumenta sim para máximo antes de 1/3 de volta mais fica mesmo jeito ele manda tensão normal de 0 a 5v para o microcontrolador  quando giro ele porém da esse pulo som 

2 horas atrás, Renato.88 disse:

Deu trabalho achar no esquema, pois na verdade não é um potenciômetro. 

Trata-se de um encoder. 

 

Pelo que relatou ele está sujo, nada a ver com o microcontrolador. 

 

Tem uma graxa dentro dele que seca e dá mal contato, você pode desmontar e limpar. 

Então Renato ele potenciômetro comum com fímbria não é encoder, e ele está medindo normal testei multímetro e entra 5 v e quando vou girando ele tem saúde 0 v e vai subindo gradativo quando giro vai até 5v, a única diferença é que ele é motorizado mais isto não interfere em nada 

64287C91-4BF0-4F27-B837-145BD28C423F.png

Link para o post
Compartilhar em outros sites

Ah tá, agora achei. 

Tem uns resistores lá, já testou eles? 

Se tiverem ruins o volume só vai chegar até o pino do meio. 

Quando o sinal é Analógico se usa esse pino de loudness, no caso ali não está sendo usado pra isso. 

Os resistores ali estão servindo apenas pra mudar a curva de resistência. 

Ali é usado somente uma placa do potenciômetro, se estiver ruim talvez dê pra usar a outra que está parada. 

Link para o post
Compartilhar em outros sites
55 minutos atrás, Renato.88 disse:

Ah tá, agora achei. 

Tem uns resistores lá, já testou eles? 

Se tiverem ruins o volume só vai chegar até o pino do meio. 

Quando o sinal é Analógico se usa esse pino de loudness, no caso ali não está sendo usado pra isso. 

Os resistores ali estão servindo apenas pra mudar a curva de resistência. 

Ali é usado somente uma placa do potenciômetro, se estiver ruim talvez dê pra usar a outra que está parada. 

Já testei estão todos bons , e está saindo tensão normal do potenciômetro, que vai para microcontrolador, a tensão entra variada no microcontrolador que altera o sinal do pulso que manda para Ci o que controla o volume , problema está entre o microcontrolador e ci lc7536 que não está controlando volume corretamente 

6 minutos atrás, ailton759 disse:

Já testei estão todos bons , e está saindo tensão normal do potenciômetro, que vai para microcontrolador, a tensão entra variada no microcontrolador que altera o sinal do pulso que manda para Ci o que controla o volume , problema está entre o microcontrolador e ci lc7536 que não está controlando volume corretamente 

 

C1C4A901-2C2D-41D3-80F1-096A274D55D1.jpeg

Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisa ser um usuário para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar agora

Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas comunidades sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×
×
  • Criar novo...

Aprenda a ler resistores e capacitores

EBOOK GRÁTIS!

CLIQUE AQUI E BAIXE AGORA MESMO!