×
Ir ao conteúdo
  • Cadastre-se

Display lcd com PIC


Martins_eng

Posts recomendados

Galera estou com um problema no display apos algum tempo ligado e fica como se ficasse sem comunicação simplesmente ele não aparece nada escrito.

Fiz um codigo so com duas linhas para tentar achar o problema vejas o codigo abaixo

#include<16f877A.h>	
#use delay(clock=20000000)
#fuses HS,NOLVP,NOWDT,NOBROWNOUT,NOPUT,NODEBUG,NOPROTECT,NOWRT,NOCPD,
#include<mod_lcd_Pitot.c>
void main()
{


lcd_ini();
delay_ms(20);

while(1)
{

printf(lcd_escreve"TESTE LCD\n");
printf(lcd_escreve"NOVA LINHA");
delay_ms(2000);
lcd_escreve('\f');
}
}

Se puderem me ajudar agradeço

Link para o comentário
Compartilhar em outros sites

mais fica aceso?

E ai jorgeletronico, beleza

Galera me desculpem mas o erro foi meu o display ficava acesso e como se não houve comunicação mas estou usando um protoboard antigo da epoca do senai ..... faz tempo, não me conformei com a falha no display pois e um circuito que ja funcionava, dai fui medir o sinal de alimentação do pic e do display ambos ok com 5V mas o pino 1 "reset" estava com 1,25V fui ver que a trilha do protoboard esta danificada da coloquei o sinal direto em cima do pino e esta funiconando perfeitamente.

Obrigado e me desculpem !!!

Valeu

Pode fechar o topico esta Resolvido

Link para o comentário
Compartilhar em outros sites

  • 4 meses depois...
Visitante
Este tópico está impedido de receber novos posts.

Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas comunidades sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×
×
  • Criar novo...

Curso de Hacker Ético

LANÇAMENTO!

CLIQUE AQUI E CONFIRA!

* Este curso não é ministrado pela equipe do Clube do Hardware.