Ir ao conteúdo
  • Comunicados

    • Gabriel Torres

      Seja um moderador do Clube do Hardware!   12-02-2016

      Prezados membros do Clube do Hardware, Está aberto o processo de seleção de novos moderadores para diversos setores ou áreas do Clube do Hardware. Os requisitos são:   Pelo menos 500 posts e um ano de cadastro; Boa frequência de participação; Ser respeitoso, cordial e educado com os demais membros; Ter bom nível de português; Ter razoável conhecimento da área em que pretende atuar; Saber trabalhar em equipe (com os moderadores, coordenadores e administradores).   Os interessados deverão enviar uma mensagem privada para o usuário @Equipe Clube do Hardware com o título "Candidato a moderador". A mensagem deverá conter respostas às perguntas abaixo:   Qual o seu nome completo? Qual sua data de nascimento? Qual sua formação/profissão? Já atuou como moderador em algo outro fórum, se sim, qual? De forma sucinta, explique o porquê de querer ser moderador do fórum e conte-nos um pouco sobre você.   OBS: Não se trata de função remunerada. Todos que fazem parte do staff são voluntários.
    • DiF

      Poste seus códigos corretamente!   21-05-2016

      Prezados membros do Fórum do Clube do Hardware, O Fórum oferece um recurso chamado CODE, onde o ícone no painel do editor é  <>     O uso deste recurso é  imprescindível para uma melhor leitura, manter a organização, diferenciar de texto comum e principalmente evitar que os compiladores e IDEs acusem erro ao colar um código copiado daqui. Portanto convido-lhes para ler as instruções de como usar este recurso CODE neste tópico:  
humanas

Visualg como pesquisar valores na matriz

Recommended Posts

Entrei recente na materia, não sei direito o q eu to fazendo, mas td bem.

Ler uma matriz C com 7 linhas e 7 colunas (utilize randi(30)). Apresente a matriz na tela Pergunte um valor para ser pesquisado Informe a linha e a coluna da matriz cada vez que o elemento pesquisado for encontrado – utilize uma pesquisa sequencial.

Eu fiz desse jeito no visualg, porém, n ta dando certo, alguem da um help aqui?

Var
// Seção de Declarações das variáveis 
c: vetor [1..7,1..7] de inteiro
i,j,x: inteiro
ahc: caractere

Inicio
// Seção de Comandos, procedimento, funções, operadores, etc... 
para i de 1 ate 7 faca
para j de 1 ate 7 faca
c[i,j]<- randi (10)
fimpara
fimpara
escreval ("numero")
leia (x)
para i de 1 ate 7 faca
para j de 1 ate 7 faca
escreva (c[i,j])
fimpara
escreval ()
fimpara

i<-1
j<-1
enquanto (i<=7) e (j<=7) e (ahc <> "ok") faca
se (c[i,j]=x) então
ahc<-"ok"
senao
i<-i+1
j<-j+1
fimse
fimenquanto

se (ahc="ok")então
escreval (x, "localizado na linha", i,"e coluna", j)
senao
escreval(x, "n localizado")
fimse
Fimalgoritmo

 

Editado por dif
Usar a tag CODE

Compartilhar este post


Link para o post
Compartilhar em outros sites

Tópico movido de Internet - programas para Iniciantes

Compartilhar este post


Link para o post
Compartilhar em outros sites

humanas
   seu código está bom, mas esse enquanto nao ficou muito bem não, acredito que
seja melhor com para, então delete esse enquanto e coloque outros dois loops 
iguais a estes que você já colocou, e dentro deles faça a busca pelo numero igual
a que você fez, mas quando encontrar o numero, já apresente ele, e continue a 
busca para ver se tem mais números iguais a este.  E coloque mais uma variável 
por exemplo ahb tipo caractere.   então dentro dos dois loops coloque assim:

se c[i,j] = x então
      escreval (x, " localizado na linha ", i," e coluna ", j)
      ahb:="nao"
fimse
ahc:=""

e depois dos dois loops coloque também:

 se ahb="" então
  escreval(x, " não localizado")
 fimse

 

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário






Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×