Ir ao conteúdo
  • Comunicados

    • Gabriel Torres

      Seja um moderador do Clube do Hardware!   12-02-2016

      Prezados membros do Clube do Hardware, Está aberto o processo de seleção de novos moderadores para diversos setores ou áreas do Clube do Hardware. Os requisitos são:   Pelo menos 500 posts e um ano de cadastro; Boa frequência de participação; Ser respeitoso, cordial e educado com os demais membros; Ter bom nível de português; Ter razoável conhecimento da área em que pretende atuar; Saber trabalhar em equipe (com os moderadores, coordenadores e administradores).   Os interessados deverão enviar uma mensagem privada para o usuário @Equipe Clube do Hardware com o título "Candidato a moderador". A mensagem deverá conter respostas às perguntas abaixo:   Qual o seu nome completo? Qual sua data de nascimento? Qual sua formação/profissão? Já atuou como moderador em algo outro fórum, se sim, qual? De forma sucinta, explique o porquê de querer ser moderador do fórum e conte-nos um pouco sobre você.   OBS: Não se trata de função remunerada. Todos que fazem parte do staff são voluntários.
    • DiF

      Poste seus códigos corretamente!   21-05-2016

      Prezados membros do Fórum do Clube do Hardware, O Fórum oferece um recurso chamado CODE, onde o ícone no painel do editor é  <>     O uso deste recurso é  imprescindível para uma melhor leitura, manter a organização, diferenciar de texto comum e principalmente evitar que os compiladores e IDEs acusem erro ao colar um código copiado daqui. Portanto convido-lhes para ler as instruções de como usar este recurso CODE neste tópico:  
Entre para seguir isso  
vinifla81

Java Preciso passar para java

Recommended Posts

vinifla81    1
 algoritmo "semnome"
// Autor : eu
// Data : 12/09/2017
var
vet_nome:vetor[1..8] de caracter
vet_poltrona:vetor[1..8] de inteiro
nome:caracter
opcao,poltrona,i,confirma:inteiro

inicio
enquanto opcao<>5 faca
escreval ("===================================================================")
escreval ("||  OLÁ, SEJA BEM VINDO(A) AO SISTEMA DE AGENDAMENTO DA N.A.S.A  ||")
escreval ("===================================================================")
escreval("")
escreval("")
escreval("# 1 - Realizar reservas de sala #")
escreval("# 2 - Verificar disponibilidade de salas #")
escreval("# 3 - Liberar sala escolhida #")
escreval("# 4 - Finalizar o programa #")
escreval
escreval("Digite a opção")
leia(opcao)
escolha opcao
caso 1
escreval("Qual o seu nome?")
leia(nome)
escreval("Qual a sala desejada?")
leia(poltrona)
se vet_poltrona[poltrona]=0 então
vet_nome[poltrona]<-nome
vet_poltrona[poltrona]<-1
escreval("Reserva de sala feita com sucesso.")
senao
escreval("Desculpe, esta sala já está ocupada.")
fimse
caso 2
para i de 1 ate 8 faca
se vet_poltrona[i]=0 então
escreval("A sala",i," está desocupada.")
fimse
fimpara
caso 3
escreval("Qual reserva de sala você deseja excluir?")
leia(poltrona)
se vet_poltrona[poltrona]=1 então
escreval("Tem certeza de que deseja excluir esta reserva? SIM = 1 NAO = 0")
leia(confirma)
se confirma=1 então
vet_poltrona[poltrona]<-0
vet_nome[poltrona]<-" "
escreval("Reserva de sala excluida com sucesso.")
senao
escreval("Reserva de sala não alterada")
fimse
senao
escreval("Esta sala já está desocupada.")
fimse
caso 4
escreval("Programa finalizado com sucesso.")
outrocaso
escreval("Código invalido.")
fimescolha
fimenquanto
fimalgoritmo

Alguém poderia passar esse código que esta no visual G para o java para mim, por favor?

Compartilhar este post


Link para o post
Compartilhar em outros sites
TwistedSoul    50

@vinifla81 Bom dia.

 

Ninguém vai fazer o código pra você aqui no fórum. Tente fazer e poste aqui as suas dúvidas que vamos te auxiliando até conseguir.

Compartilhar este post


Link para o post
Compartilhar em outros sites
vinifla81    1
  • Autor do tópico
  • Ok, como passo isso para java 

    vet_nome[poltrona]<-nome
    vet_poltrona[poltrona]<-1

     

    adicionado 0 minutos depois

    Essa parte tambem nao sei 

    Citação
    
    para i de 1 ate 8 faca
    se vet_poltrona[i]=0 então

     

     

    Compartilhar este post


    Link para o post
    Compartilhar em outros sites
    AntonyBR    7

    Isso são, obviamente, vetores. 

     

    "poltrona" é uma variável que está fazendo a função de índice, por exemplo, se eu atribuir "2" para variável "poltrona", ao índice de número 2 do vetor "nome" eu irei atribuir o meu nome ( que eu informo acima) e irei atribuir "1" ao vetor "poltrona" nessa mesma posição, que significa que o mesmo já está ocupado por "alguém".

     

    A segunda menção que você fez é um for que está procurando uma sala vazia, a qual deve ser igual à "0" que significa desocupada.

     

    espero ter ajudado.

    Compartilhar este post


    Link para o post
    Compartilhar em outros sites

    Crie uma conta ou entre para comentar

    Você precisar ser um membro para fazer um comentário

    Entre para seguir isso  





    Sobre o Clube do Hardware

    No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

    Direitos autorais

    Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

    ×