Ir ao conteúdo
  • Comunicados

    • Gabriel Torres

      Seja um moderador do Clube do Hardware!   12-02-2016

      Prezados membros do Clube do Hardware, Está aberto o processo de seleção de novos moderadores para diversos setores ou áreas do Clube do Hardware. Os requisitos são:   Pelo menos 500 posts e um ano de cadastro; Boa frequência de participação; Ser respeitoso, cordial e educado com os demais membros; Ter bom nível de português; Ter razoável conhecimento da área em que pretende atuar; Saber trabalhar em equipe (com os moderadores, coordenadores e administradores).   Os interessados deverão enviar uma mensagem privada para o usuário @Equipe Clube do Hardware com o título "Candidato a moderador". A mensagem deverá conter respostas às perguntas abaixo:   Qual o seu nome completo? Qual sua data de nascimento? Qual sua formação/profissão? Já atuou como moderador em algo outro fórum, se sim, qual? De forma sucinta, explique o porquê de querer ser moderador do fórum e conte-nos um pouco sobre você.   OBS: Não se trata de função remunerada. Todos que fazem parte do staff são voluntários.
    • DiF

      Poste seus códigos corretamente!   21-05-2016

      Prezados membros do Fórum do Clube do Hardware, O Fórum oferece um recurso chamado CODE, onde o ícone no painel do editor é  <>     O uso deste recurso é  imprescindível para uma melhor leitura, manter a organização, diferenciar de texto comum e principalmente evitar que os compiladores e IDEs acusem erro ao colar um código copiado daqui. Portanto convido-lhes para ler as instruções de como usar este recurso CODE neste tópico:  
Sergio.Anjos

Dúvida em utilizar Entity com WCF..

Recommended Posts

Olá!

Estou tentando fazer um projeto (C# Web + MVC + Entity Framework + WCF), no entanto, não consigo fazer com que a view “enxergue” o Modelo gerado pelo Entity na cama WCF. Alguém de vocês poderia me passar o caminho das pedras ou me passar o link de algum material?

Já fucei a NET em busca de conteúdo a este respeito e não encontrei nada que resolvesse o meu problema. Já segui vários tutoriais que fui encontrando, e nada. Nem mesmo o tutorial do Macoratti foi suficiente.

Se eu mapeio as tabelas na camada Web, a camada WCF não consegue “enxergar” o modelo, já se eu fizer o contrário, criar o modelo Entity na camada WCF, é a camada Web que não consegue “enxergar”. E quando mapeio o modelo Entity nas 2 camadas, também não dá certo.

Ou seja, já cansei de fazer tentativas!

Att.,

Sérgio

Compartilhar este post


Link para o post
Compartilhar em outros sites

Tente fazer uma camada só de "dados", uma camada repositório por exemplo.

Uma dll que vai conter as entidades mapeadas e o DbContext, assim você poderá referenciar esta camada em ambos os projetos e ainda centralizará o seu acesso a dados.

ATT,

LBarcelosM

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário






Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×