Ir ao conteúdo
  • Cadastre-se
Nino Ed

Calculando Valor de Horas No Excel

Recommended Posts

Olá, vejam se podem me ajudar...

 

Trabalho em um estacionamento e sempre o sistema da problemas...

 

o que eu gostaria de saber é como posso utilizar o Excel para calcular as horas de estacionamento dos clientes...

 

Eu  sei calcular o tempo de permanência do cliente mas não sei como calcular o valor do estacionamento...

 

Exemplo:

 

 Coluna B = Hr entrada  B1 = 12:36

 

 Coluna C = Hr Saída  C1 =14:18

 

 Coluna D = Permanência D1  = 1:42

 

  Coluna F = Valor Total F1 = ?

 

H1 = Valor por  hora = R$ 6,00

 

 

 

Qual fórmula devo usar na Célula F1 para calcular  o valor do estacionamento?

 

Tem mais um detalhe, eu preciso que antes de o sistema calcular o valor, eu preciso que antes ele arredonde a hora para "+" caso o tempo de permanência tenha mais de 15 Min. excedido da hora, e arredonde a hora para "-", caso o resultado não ultrapassasse os 15Min., ou seja, no exemplo mostrado acima eu precisaria que o sistema me retornasse na coluna E na Célula E1 como sendo 2:00 e dessa hora calcular o valor do estacionamento.

 

Coluna E = Arredondamento E1 = 2:00

Qual fórmula devo usar na Célula E1 para fazer o arredondamento da hora?

 

Espero que tenham entendido, e que possam me ajudar, pois isso me pouparia horas de estresse, ou até mesmo dias, porque as vezes o levam dias para consertarem o sistema.

 

Desde já agradeço e um forte abraço a todos

Compartilhar este post


Link para o post
Compartilhar em outros sites

COluna D (tempo total) = C5-B5

 

Coluna E (tempo arredondado) =SE(MINUTO(MOD(D5;0,041667))>15;(HORA(D5)+1)*0,041667;HORA(D5)*0,041667)

 

Coluna F (valor a pagar) = (E5/0,041667)*6

  • Curtir 2

Compartilhar este post


Link para o post
Compartilhar em outros sites

Com a nova regra de fracionamento que, após a primeira hora, a cobrança deve ser realizada proporcionalmente ao fracionamento da hora a cada 15 minutos. Isto é, se o veículo permaneceu por 2:35h, neste caso, ele pagaria 6,00 pela primeira hora, mais 6,00 pela segunda hora e mais 4,50 pelos 35 minutos (1,50 a cada 15 minutos). Como ficaria a fórmula neste caso?

  • Confuso 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar agora





Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×