Ir ao conteúdo
  • Cadastre-se
higor.so

RESOLVIDO Função somase

Recommended Posts

Olá estou tentando utilizar a função "SOMASE" na minha planilha, mas estou tendo um problema.

A ideia é somar os valores dos gastos de estacionamento, somente sábado e domingo.

Eu usei a formula da seguinte forma:

 

=SOMASES(D2:D7;B2:B7;"estacionamento";C2:C7;"sábado";C2:C7;"Domingo")

 

Mas, ele retorna zero.

 

Alguém poderia me ajudar???

Se tive alguma sugestão fazendo macro também pode ser

 

Valeu

Pasta1.xlsx

Compartilhar este post


Link para o post
Compartilhar em outros sites

Boa tarde Igor

 

Experimente:

 

=SOMASES(D2:D7;B2:B7;"estacionamento";C2:C7;"sábado")+SOMASES(D2:D7;B2:B7;"estacionamento";C2:C7;"Domingo")

 

Outra opção usando SOMARPRODUTO:

 

=SOMARPRODUTO((B2:B7="ESTACIONAMENTO")*((C2:C7="sábado")+(C2:C7="DOMINGO"))*(D2:D7))

 

Dê retorno.

 

Se a resposta foi útil, clique em Curtir.

 

[]s

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

Essa função substituí com vantagens as funções de contar CONT.SE e CONT.SES e de somar SOMASE e SOMASES.

A função SOMARPRODUTO por essência já é uma função matricial, por isso em vez de considerar os dados, ela considera os vetores, por isso a necessidade de se usar *.

Temos várias formas de montá-las.Por se tratar de uma função bem complexa, segue abaixo um link com um ótimo tutorial.

 

http://www.ambienteoffice.com.br/excel/SOMARPRODUTO/

 

[]s

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar agora





Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×