Ir ao conteúdo
  • Cadastre-se
Pedro Henrique_758189

Ajuda com vetores VisualG

Recommended Posts

Boa noite, preciso fazer um programa, aonde o usuário digite o número de notas que deseja inserir para cálculo de média, em seguida ele peça as notas e como saída, apresente a média dessas notas.

 

Estou tentando fazer, mas juro que não sei o que estou fazendo errado,acredito que seja o cálculo de média que eu usei. Segue o código:

algoritmo "teste"vari,quant:inteironota,media:realq: vetor[1..50]de realinicioescreva("Digite a quantidade de notas a serem calculadas: ")leia(quant)para i de 1 ate quant passo 1 faca   escreva("Digite a nota",i)   leia (q[i])   media<-(q[i]/quant)*quantfimparaescreva(media)fimalgoritmo

Compartilhar este post


Link para o post
Compartilhar em outros sites

A média é calculada dividindo o valor total pelo número de notas...

 

Você não precisa armazenar os valores de cada nota numa matriz... Só precisa obter o valor total, para poder calcular a média, para isso basta uma única variável que armazenará o valor da nota atual, e então somar seu valor ao valor total (total <- total + nota), a cada execução do ciclo para.

 

(Não esqueça de atribuir o valor zero (0) ao total antes de começar a contabilizar o valor das notas, ou seja, antes do ciclo para começar.)

 

E aí você pode calcular a média no final, quando o valor total tiver sido contabilizado, ou seja, depois que sair do ciclo para.

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

Obg, eu consegui fazer ontem, no caso o código final ficou assim:

      repita         limpatela         escreva("Digite o nome do aluno: ")         leia(aluno)         escreva("Digite a quantidade de notas a serem calculadas: ")         leia(quant)         para t de 1 ate quant passo 1 faca            escreva("Digite a nota ",t,": ")            leia (q[t])            soma<-soma+q[t]         fimpara         limpatela         escreva("A média do aluno ",aluno," é: ",soma/quant,".")         se (soma/quant)>=5 entao            escreval(" Situação: APROVADO")         senao            escreval(" Situação: REPROVADO")            escreval         fimse         soma<-0         escreval("_____________________________________________________")         escreval         escreval         escreval("Deseja calcular novamente?[Y]Sim/[N]Não")         escreval         escreva("-->  ")         leia (resposta)      ate resposta = "n"      fimrepita      se resposta = "y" entao         limpatela      fimse      se resposta = "n" entao         limpatela         escreval("O que deseja fazer agora? [1]Sair/[2]Voltar ao menu")         leia(depois)         se depois = "1" entao            limpatela            escreva("============================")            escreva("Obrigado por usar o programa")            escreva("============================")            escreval            escreval         fimse         se depois = "2" entao            limpatela         fimse      fimse   fimseate depois = "1"fimrepita

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar agora





Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×