Ir ao conteúdo
  • Cadastre-se
GabrielLima18

Estrutura de repetição algoritmo visualg

Recommended Posts

Olá, tenho que entregar uma lista de exercícios ate amanhã, e um dos exercícios é o seguinte:

 

Faça um algoritmo que leia informações de alunos (Matricula, Nota1, Nota2, Nota3) com o fim das informações indicado por Matricula = 9999 . Para cada aluno deve ser calculada a média final de acordo com a seguinte fórmula:

 

Média final = [(2 * Nota1) +(3* Nota2) +(5* Nota 3)] / 10

 

Se a média final for igual ou superior a 5, o algoritmo deve mostrar Matrícula, Média Final e a mensagem "APROVADO"; se a média final for inferior a 5, o algoritmo deve mostrar Matricula, Média Final e a mensagem "REPROVADO". Ao final devem ser mostrados o total de aprovados, o total de alunos da turma e o total de reprovados.

 


Eu consegui fazer tudo, só que eu não estou conseguindo mostrar o total de aprovados, o total e alunos da turma e o total de reprovados. Até agora eu fiz isso:

var
matricula: inteiro
nota1,nota2,nota3, media: real
continuar: caracter

inicio
continuar <- "S"
enquanto continuar <> "N" faca
Escreva ("Matricula: ")
Leia (matricula)
Escreva ("Nota 1: ")
Leia (nota1)
Escreva ("Nota 2: ")
Leia (nota2)
Escreva ("Nota 3: ")
Leia (nota3)

media <- 2*nota1 + 3*nota2 + 5*nota3 / 10

Se media >= 5 então
Escreval ("-----------------------------------")
Escreval ("              APROVADO!            ")
Escreval ("-----------------------------------")
Escreval ("Matricula: ",matricula)
Escreval ("Media Final: ", media)
fimse

Se media <= 5 então
Escreval ("-----------------------------------")
Escreval ("              REPROVADO!           ")
Escreval ("-----------------------------------")
Escreval ("Matricula: ",matricula)
Escreval ("Media Final: ", media)
fimse

Escreva("Deseja continuar? [S/N]")
Leia (continuar)
fimenquanto
fimalgoritmo

 

 

Compartilhar este post


Link para o post
Compartilhar em outros sites

Boa tarde,

 

acho que deve trocar esses pontos no códigos

 

media <- 2*nota1 + 3*nota2 + 5*nota3 / 10

por

media <- (2*nota1 + 3*nota2 + 5*nota3) / 10

 

e

 

15 horas atrás, GabrielLima18 disse:

Se media <= 5 então

 

por

Se media < 5 então

 

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar agora





Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×