Ir ao conteúdo
  • Cadastre-se
ZdebugginG

Visualg e cálculo de bhaskara

Recommended Posts

Eu estou tentando fazer um algoritmo que consiga resolver uma equação de Bhaskara, mas está dando alguns erros, valores nulos e diferentes. Está ai o código!!

var
valora:real
valorb:real
valorc:real
delta:real
valorx:real
valorx2:real
inicio
escreval("                  Escreva o valor de A:")
leia(valora)
escreval("                  Escreva o valor de B:")
leia(valorb)
escreva("                   Escreva o valor de C: ")
leia(valorc)

delta<-valorb*valorb*-4*valora*valorc
raizq(delta)
  caso delta=0 escreval("Não há raiz")
    valorx<- -valorb+delta/2*valora
    valorx2<- -valorb-delta/2*valora

escreval("    Resultado X1:", valorx)
escreval("    Resultado X2:", valorx2)

 

Compartilhar este post


Link para o post
Compartilhar em outros sites

@ZdebugginG Seu algoritmo está errado.

O calculo de X1 e 2 está errado.

 

var
 a, b, c: real
 delta, valorx, valorx2: real
 
 
inicio
// Seção de Comandos 
escreva("Valor de A:")
leia(a)
escreva("Valor de B:")
leia(b)
escreva("Valor de C:")
leia(c)

delta <- exp(b,2) - 4 * a * c
se (delta > 0) então
   valorx <- (-b + RaizQ(delta)) / (2 * a)
   valorx <- (-b - RaizQ(delta)) / (2 * a)
   escreval("    Resultado X1:", valorx)
   escreval("    Resultado X2:", valorx2)
senao
     se (delta = 0) então
          valorx <- -b / (2*a)
          escreva("A equaçao possui uma raiz real")
          escreva("X1: ", valorx)
     senao
          escreva("A equação não possui raizes reais")
     fimse

fimse

 

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar agora





Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×