Ir ao conteúdo
  • Cadastre-se
Entre para seguir isso  
rogeriocal

Problemas Na Inicialização Do Kurumin 3.01

Recommended Posts

Olá a todos,

Sou iniciante do Linux e preciso muito da ajuda de vocês. Apesar de ter vontade há muito tempo de usar o Linux, só me decidi recentemente aproveitando o fato de que estou com dois HDs e assim não teria risco de perda de dados na instalação. Escolhi o Kurumin por ser mais fácil para o iniciante (segundo algumas publicações e dicas). Concentrei todos os dados no HD que está ligado no primário como master, deixando completamente livre o HD que está ligado no secundário como master para receber o Kurumin. Apesar de saber que posso rodar o Kurumin direto no CD preferi instalá-lo direto porque tenho a intenção de substituir o Windows por completo. Particionei o HD em 3 partições da seguinte forma: 10GB para o sistema, 500MB para swap e 9,85GB para o /home. Feita a instalação, como eu não consegui fazer o LILO funcionar de jeito nenhum (o Windows entrava direto) segui uma dica para fazer o dual boot pelo próprio gerenciador do Windows XP.

Entrei no terminal como root e dei o seguinte comando:

dd if=/dev/hdc1 of=/bootsect.lnx bs=512 count=1

Esse comando, segundo a dica, gera um arquivo com os dados necessários para a inicialização do Kurumin.

Copiei o arquivo para o diretório c:\ do Windows e modifiquei o arquivo boot.ini do Windows acrescentando a seguinte linha no final:

c:\BOOTSECT.LNX="Kurumin".

Agora o gerenciador aparece oferecendo as duas opções de boot. Só que escolhendo Windows o sistema entra normalmente, mas escolhendo o Kurumin a tela fica toda em preto com um cursor piscando no canto superior esquerdo e nada mais acontece. Não sai disso.

O que pode estar acontecendo?

Qualquer ajuda é válida. Quero muito deixar o Windows de lado, mas não conseguir nem deixar o sistema funcionando em dual boot desanima muito.

Ah, sim. Ia me esquecendo. Inicializando pelo disquete de boot o Kurumin carrega normalmente.

Compartilhar este post


Link para o post
Compartilhar em outros sites

rogeriocal, quanto a esse gerenciador, não sei como ele é, pois nunca usei Windows XP. Não sei quais problemas você passou com o Lilo, mas me parece que ele não foi gravado corretamente no mbr (pois entra direto no Windows). Se quiser testa-lo novamente, é só postar as dúvidas aqui e a gente te ajuda.

Em todo o caso, seque algumas sugestões:

use o man para saber se você utilizou corretamente o comando dd if=/dev/hdc1 ...

Verifique também se realmente é só isso que você deve acrescentar ao arquivo boot.ini, ou se precisa de algum outro dado.

Lamento não poder ajudar muito, mas não desanime só por isso. As melhores coisas na vida a gente consegue através de muito esforço B)

Boa sorte

:bye:

Compartilhar este post


Link para o post
Compartilhar em outros sites

Obrigado pelas dicas.

Porém, várias pessoas seguiram a dica digitando o comando exatamente como descrito e acrescentando apenas aquilo ao boot.ini e funcionou sem problemas. Mas houve outros casos com o mesmo problema que o meu. Essa é um dica de um fórum específico do Kurumin e ninguém até agora sugeriu uma solução para o meu problema.

Os meus problemas com o Lilo devem ser mesmo porque não foi gravado no MBR porém não tenho ideia das causas. Durante a instalação do Kurumin fica aparecendo o tempo todo uma janela denominada Root onde aparecem várias mensagens durante o processo. Durante a instalação aparece várias outras janelas de diálogo também. Em uma delas aparece a pergunta se quero instalar o Lilo no MBR. Respondo sim. Depois aparece se quero revisar o Lilo.conf e também respondo sim. Aí descomento as linhas para habilitar o Windows e o Kurumin, que fica assim:

other=/dev/hda1

label=Windows

other=/dev/hdc1

label=Kurumin

Salvo e fecho o KEdit. Aí a instalação continua e aparece a seguinte mensagem na janela Root.

Fatal: First sector of /dev/hdc1 doesnt't have a valid boot signature

Mutex destroy failure: Device or resource busy

O que pode estar acontecendo? Como não é válido para boot? O HD está completamente vazio e foi particionado para a instalação do sistema no hdc1. O hdc2 para swap e hdc3 para o /home.

Compartilhar este post


Link para o post
Compartilhar em outros sites

Bom, ainda não tive a oportunidade de usar o Kurumin (o que pretendo mudar em breve) mas acho que o lilo.conf tem que ser assim (usuários do Kurumin, por favor puxem minha orelha se eu estiver enganada):

label=Kurumin

read-only

root=/dev/hdc1

Nota: sempre execute o comando lilo após fazer alguma alteração no arquivo lilo.conf.

Boa sorte

:bye:

Compartilhar este post


Link para o post
Compartilhar em outros sites

alem disso dito pela alys, você terá q colocar o nome da imagem do kernel q terá q subir, creio eu ;)

#especifica o arquivo que contém a primeira imagem (tem q ver qual é o seu)

image=/vmlinuz

#partição onde a imagem acima esta localizada

root=/dev/hdc1

#identificação da imagem de disco

label=Kurumin

#monta inicialmente como somente leitura

read-only

Obrigado

Compartilhar este post


Link para o post
Compartilhar em outros sites

Obrigado pelas dicas Alys e douglasgm,

mas o lilo.conf tem muito mais coisas do que eu coloquei. Só coloquei aquelas linhas porque eu achei que era onde poderia estar o problema, mas tem muito mais, inclusive o que você colocaram nas dicas.

Vou colocar mais coisas que tem lá. Ainda não é tudo, mas acho que o problema deve estar em algum lugar desses. O arquivo é todo comentado e, na medida do possível para um iniciante, bem explicado.

Para começar o lilo.conf é aberto no KEdit e o título da janela é o seguinte:

/mnt/target/etc/lilo.conf

Também tem as seguintes linhas, que segundo os comentários, indica onde o Lilo será instalado:

boot=/dev/hdc

bitmap=/boot/kurumin.bmp

bmp-colors=9,0,,0,9

bmp-table=61,15,1,12

bmp-timer=73,29,0,9

Eu estranhei o hdc da primeira linha. Não deveria ser hdc1. Bom, tentei mudar para hdc1 e hda1. Nenhum funcionou.

Depois tem as seguintes linhas com o aviso.

"Não altere as linhas abaixo!" (com exclamação mesmo)

image=/boot/vmlinuz-2.4.25-klg

label=Kurumin

root=/dev/hdc1

read-only

init=/boot/initrd.gz

E por fim as linhas que eu coloquei na primeira mensagem:

"Habilita o Windows"

other=dev/hda1

label=Windows

"Habilita outros sistemas"

other=dev/hda2

label=hda2

e essas linhas repetem com hda3, hda4, hda5... Obviamente tudo comentado com as instruções de que basta descomentar a opção correta. Eu então descomento as duas primeiras linhas trocando hda2 por hdc1 e o label para Kurumin.

E não funciona. Nem sinal de vida do Lilo!!

Compartilhar este post


Link para o post
Compartilhar em outros sites

não funciona porque tá errado..., tem q ficar hdaX, sendo X a partição do windows, com o label windows... não mexe em nada q tá tudo certinho, unica coisa q tá estranha é o lilo.conf tá em /mnt, ele deve estar em /etc.... tem certeza q você está editando o arquivo correto...

depois da alteração, digite lilo no terminal e boa

Obrigado

Compartilhar este post


Link para o post
Compartilhar em outros sites
não funciona porque tá errado..., tem q ficar hdaX, sendo X a partição do windows, com o label windows... não mexe em nada q tá tudo certinho, unica coisa q tá estranha é o lilo.conf tá em /mnt, ele deve estar em /etc.... tem certeza q você está editando o arquivo correto...

Desculpe, não entendi direito. Afinal está certo ou errado. O que devo alterar exatamente?

depois da alteração, digite lilo no terminal e boa

Essas alterações eu faço durante a instalação do Kurumin. Salvo, fecho a janela e a instalação continua, como expliquei em mensagens anteriores.

Estive muito ocupado e não pude mexer mais no Kurumin, mas agora vou retomar as tentativas.

Compartilhar este post


Link para o post
Compartilhar em outros sites
Postado Originalmente por rogeriocal@03 ago 2004, 01:10

c:\BOOTSECT.LNX="Kurumin".

ué... usei essa dica no começo... funcionava normal e muito bem diga-se de passagem... mas estava tudo no mesmo hd...

Compartilhar este post


Link para o post
Compartilhar em outros sites

Quanto ao gerenciador do XP: o Roger_2 disse que também funciounou com ele, mas com só um hd. rogeriocal, você verificou se é a mesma coisa para dois hds? você disse que isso só funcionou com algumas pessoas e que outras tiveram problemas como o seu, de repente é por isso (é só uma sugestão, sei lá se o problema é esse mesmo).

*** Edit ***

Obviamente tudo comentado com as instruções de que basta descomentar a opção correta. Eu então descomento as duas primeiras linhas trocando hda2 por hdc1 e o label para Kurumin.

Esquece o que eu tinha dito antes, essa parte aí passou despercebida :( desculpem...

Cara, não é para você descomentar essas linhas, a parte que tem que valer é:

"Não altere as linhas abaixo!"
image=/boot/vmlinuz-2.4.25-klg
label=Kurumin
root=/dev/hdc1
read-only
init=/boot/initrd.gz

"Habilita o Windows"
other=dev/hda1
label=Windows

Se você descomentar essa parte:


"Habilita outros sistemas"
other=dev/hda2
label=hda2

E colocar label=Kurumin e dev/hdc1, vai dar errado mesmo. Essas partes você só vai descomentar (e fazer as alterações necessárias) caso instale mais algum SO (um terceiro). Caso contrário, é para deixar comentado mesmo.

Boa sorte

:bye:

Compartilhar este post


Link para o post
Compartilhar em outros sites
E colocar label=Kurumin e dev/hdc1, vai dar errado mesmo. Essas partes você só vai descomentar (e fazer as alterações necessárias) caso instale mais algum SO (um terceiro). Caso contrário, é para deixar comentado mesmo.

Funcionou!!!!!! :palmas: :palmas:

Muito obrigado Alys!!! Um brinde a você!! :-BEER

Acho que isso nunca me passaria pela cabeça. Eu ia sempre ficar achando que tinha que habilitar o Kurumin por aquelas linhas.

Finalmente vou começar a usar o Kurumin porque até agora só fiquei tentando fazer o dual boot. Com certeza vou acabar postando outras dúvidas aqui a medida que for usando, mas só depois de tentar sozinho e pesquisar muito.

Obrigado também a todos que postaram!

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar agora
Entre para seguir isso  





Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×