Ir ao conteúdo
  • Cadastre-se
Edu Timm

Excel. duvido alguém saber. comparar células com valores repetidos em colunas.

Recommended Posts

Tenho duas colunas que medem relações entre pessoas, que são identificadas por números. São mais de 400 linhas, cada linha identifica uma relação entre as pessoas (quem conhece quem). Desejo verificar se essas relações são recíprocas, exemplo: Número 6 citou o 12 e o Número 12 também citou o 6, ou seja, é verdadeiro. Gostaria de identificar se isso é verdadeiro para as demais linhas. Como devo proceder? Creio que deveria criar mais uma coluna (pra inserir fórmulas) e saber se as relações repetidas ocorrem ou não (verdadeiro ou falso), mas qual formula utilizar? Se possível, uma fórmula travada para que eu possa arrastar para as linhas abaixo.

 

Coluna A - Pessoas entrevistadas
6
6
12
20
13

Coluna B - Quem elas conhecem
5
12
6
13

Editado por Edu Timm

Compartilhar este post


Link para o post
Compartilhar em outros sites

Olá Décio. Creio que seja isso mesmo, na verdade onde aparece em vermelho nas duas colunas, seriam as conexões que são duplas, certo? Ou seja, citou e é citado. (muito obrigado MESMO!)

 

Só mais uma dúvida, você poderia me explicar um pouco a fórmula ou  dizer por que >1?

 

Fórmula: 

=SOMA(CONT.SE($E$5:$E$9;$G5)+CONT.SE($G$5:$G$9;$G5))>1

 

Editado por DiF

Compartilhar este post


Link para o post
Compartilhar em outros sites

@Edu Timm , Bom DIa

 

È resultado da soma de dois CONT.SE tem que estar nas duas colunas então maior do que 1 , o resultado pode ser 2 ou mair.

 

Quero lembrar também que no Excel tudo é possível, não duvida.

 

Décio

 

Editado por deciog

Compartilhar este post


Link para o post
Compartilhar em outros sites

Decio, tentei manter a mesma formatação condicional para as células que eu pretendia e não obtive resultado satisfatório. Pode dar uma olhada?

A ideia é que, quando as conexões forem recíprocas (6 | 5) ou (5 | 6), quando essa ocorrência for verdadeira na planilha inteira, a coluna Weight ganhe o valor 5, e nos demais, valor 1.

 

Fiz manualmente, observando conexão por conexão, mas sei se está 100% correto. preferiria uma fórmula. pode olhar?

edges.csv

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar agora





Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×