Ir ao conteúdo
  • Comunicados

    • Gabriel Torres

      Seja um moderador do Clube do Hardware!   12-02-2016

      Prezados membros do Clube do Hardware, Está aberto o processo de seleção de novos moderadores para diversos setores ou áreas do Clube do Hardware. Os requisitos são:   Pelo menos 500 posts e um ano de cadastro; Boa frequência de participação; Ser respeitoso, cordial e educado com os demais membros; Ter bom nível de português; Ter razoável conhecimento da área em que pretende atuar; Saber trabalhar em equipe (com os moderadores, coordenadores e administradores).   Os interessados deverão enviar uma mensagem privada para o usuário @Equipe Clube do Hardware com o título "Candidato a moderador". A mensagem deverá conter respostas às perguntas abaixo:   Qual o seu nome completo? Qual sua data de nascimento? Qual sua formação/profissão? Já atuou como moderador em algo outro fórum, se sim, qual? De forma sucinta, explique o porquê de querer ser moderador do fórum e conte-nos um pouco sobre você.   OBS: Não se trata de função remunerada. Todos que fazem parte do staff são voluntários.
    • DiF

      Poste seus códigos corretamente!   21-05-2016

      Prezados membros do Fórum do Clube do Hardware, O Fórum oferece um recurso chamado CODE, onde o ícone no painel do editor é  <>     O uso deste recurso é  imprescindível para uma melhor leitura, manter a organização, diferenciar de texto comum e principalmente evitar que os compiladores e IDEs acusem erro ao colar um código copiado daqui. Portanto convido-lhes para ler as instruções de como usar este recurso CODE neste tópico:  
Paulo Koreia

Visualg - vetor e procedimento

Recommended Posts

Boa noite, alguém poderia me ajudar a desenvolver esse algoritmo?

O algoritmo deve possuir um menu que permita o usuário interagir com ele e
escolher qual ação executar em cada momento: Inserir novo cliente, imprimir os dados de
apenas um cliente e imprimir os dados de todos os clientes;
- Sempre que a opção escolhida for inserir novo cliente, o programa deve ler os
seguintes dados: CPF, nome, endereço, bairro, cep, cidade, estado, telefone e celular;
(DICA: todos os campos serão do tipo caractere e vocês devem criar um vetor para cada
campo desses acima citado.)
- O programa deve ter o limite de inserção de 50 clientes apenas, caso já tenha
inserido os 50 clientes, sempre que pedir para adicionar mais um, deve ser informado ao
usuário que a base de dados já está cheia;
- Sempre que pedir para imprimir os dados de apenas um cliente, o programa
deve pedir que seja digitado o número do CPF, daí com esse número digitado, o sistema
deverá buscar nos seus dados o registro que tiver aquele número de CPF e imprimir na
tela todos os dados daquele usuário, caso o usuário não seja encontrado, escrever na tela
que o usuário não existe na base de dados;
- Sempre que pedir para imprimir os dados de todos os clientes, o programa deve
escrever na tela os dados de todos os clientes já cadastrados, caso não exista nenhum
cliente, o programa deve informar que a base de dados está vazia.

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

Prezado,

 

Seja bem-vindo ao Fórum do Clube do Hardware; obrigado por sua participação! :)

 

Quanto à sua dúvida, para podermos lhe ajudar, nós precisamos de mais alguns detalhes, tais como:

 

  • parte do código que já foi feito;
  • caso não tenha um código feito, qual o algoritmo que você pretende usar para resolver o problema;
  • você tem experiência com esta linguagem de programação?

 

Por favor, não leve para o lado pessoal, mas o nosso objetivo principal aqui é ajudar você a resolver o problema, se simplesmente postássemos um código já pronto, você nunca aprenderia de fato... ;)

 

Atenciosamente,

Equipe Clube do Hardware

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites
 

Boa noite, sou iniciante estou tentando fazer mais não estou conseguindo. Segue abaixo como estou tentando segundo algumas pesquisas feitas pela internet.

 Algoritmo "Cadastro_clientes"



Var
   cpf: vetor [1..50] de inteiro
   nome: vetor [1..50] de caractere
   end: vetor [1..50] de caractere
   bai: vetor [1..50] de caractere
   cep: vetor [1..50] de inteiro
   cid: vetor [1..50] de caractere
   est: vetor [1..50] de caractere
   tel: vetor [1..50] de inteiro
   cel: vetor [1..50] de inteiro
   codigo, cpfpesq: inteiro
   encontrado, inserir: logico
procedimento principal()



Inicio
   repita
   escreval ("")
   escreval ("Menu Principal")
   escreval ("--------------")
   escreval ("0 - Sair")
   escreval ("1 - Inserir Novo Cadastro")
   escreval ("2 - Imprimir dados do cliente")
   escreval ("3 - Imprimir dados de todos clientes")
   escreva ("Digite uma Opcao: ")
   leia (codigo)
   limpatela
   ate (codigo=0) ou (codigo=1) ou (codigo=2) ou (codigo=3)
   escolha (codigo)
   caso 0
        interrompa
   caso 1
        cadastro()
   caso 2
        consulta_cpf()
   caso 3
        consulta_todos()
   caso 4
        principal()
   fimescolha
fimprocedimento
//---------------------- CADASTRO ----------------------
procedimento cadastro()
inicio
   limpatela
   escreval("---------------------  CADASTRO ---------------------")
   para i de 1 ate 50 faca
      escreva ("Digite o CPF: ")
      leia (cpf[i])
      escreva ("Digite o Nome: ")
      leia (nome[i])
      escreva ("Digite o Endereço: ")
      leia (end[i])
      escreva ("Digite o Bairro: ")
      leia (bai[i])
      escreva ("Digite o CEP: ")
      leia (cep[i])
      escreva ("Digite a Cidade: ")
      leia (cid[i])
      escreva ("Digite o Estado: ")
      leia (est[i])
      escreva ("Digite o Telefone: ")
      leia (tel[i])
      escreva ("Digite o Celular: ")
      leia (cel[i])
   fimpara
   principal ()
fimprocedimento



//-------------------------- CONSULTA PELO CPF ---------------------
procedimento consulta_cpf()
inicio
      limpatela
      escreval("---------------------  CONSULTA ---------------------")
      escreva ("Digite um CPF para Consulta : ")
      leia (cpfpesq)
      para i de 1 ate 50 faca
      se (cpf) = (cpfpesq) então
         escreval ("---------------------- CONSULTA PELO CPF -------------------")
         escreval ("CPF: ", cpf[i])
         escreval ("Nome: ", nome[i])
         escreval ("Endereço: ", end[i])
         escreval ("Bairro: ", bai[i])
         escreval ("CEP: ", cep[i])
         escreval ("Cidade: ", cid[i])
         escreval ("Estado: ", est[i])
         escreval ("Telefone: ", tel[i])
         escreval ("Celular: ", cel[i])
         encontrado<-verdadeiro
      fimse
      fimpara
             se encontrado=falso então
                escreval ("------------ Nome informado não encontrado! -------------")
             fimse
      principal()
fimprocedimento



//-------------------------- CONSULTA TODOS ---------------------
procedimento consulta_cpf()
inicio
      limpatela
      escreval("---------------------  CONSULTA ---------------------")
      para i de 1 ate 50 faca
         escreval ("---------------------- CONSULTA PELO CPF -------------------")
         escreval ("CPF: ", cpf[i])
         escreval ("Nome: ", nome[i])
         escreval ("Endereço: ", endv)
         escreval ("Bairro: ", bai[i])
         escreval ("CEP: ", cep[i])
         escreval ("Cidade: ", cid[i])
         escreval ("Estado: ", est[i])
         escreval ("Telefone: ", tel[i])
         escreval ("Celular: ", cel[i])
      fimpara



      principal()
fimprocedimento
inicio



      principal()
fimalgoritmo




Fimalgoritmo

 

Editado por Simon Viegas
Inserir tag CODE no código
  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

Olá @Paulo Koreia.

 

1) USO DA TAG CODE

Ao postar um código, favor utilizar a tag CODE (botão <>). Abaixo um pouco sobre:

2) CÓDIGO REPETIDO

Parece que seu código está montado... tem por exemplo duas vezes o consulta_cpf(). Dê uma arrumada nisso.

 

 

 

3) CICLO DO CÓDIGO

 

9 horas atrás, Paulo Koreia disse:

      escreva ("Digite o Celular: ")
      leia (cel[i])
   fimpara
   principal ()
fimprocedimento

 

 

Dentro dos procedimento, como no trecho do cadastro() acima, você está "chamando" procedimento principal() para voltar ao menu principal, mas você não pode fazer isso!!!. Veja, ao entrar em um procedimento, o programa principal ou procedimento continua aberto de onde o novo procedimento foi chamado até que ele (o novo) finalize e o programa volte para o programa anterior.

 

Cada procedimento funciona como um sub-programa, daí, ao chamar um procedimento, o programa fica aguardando o sub-programa terminar e continua do mesmo ponto onde o sub-programa foi iniciado. No seu código, o sub-programa principal() chama, por exemplo, o cadastro()... daí, é aberto um novo sub-programa, certo? mas dentro do cadastro() você chama novamente o principal(), ou seja, formando uma "pilha de sub-programas". Esse recurso tem até nome: recursividade, mas ele não pode ser feito assim... veja:

 

PILHA DE SUB-POGRAMAS

1 PROOGRAMA: "Cadastro_clientes"
2 SUB-PROG.: "principal()"
3 SUB-PROG.: "cadastro()"
4 SUB-PROG.: "principal()"
5 SUB-PROG.: "cadastro()"
6 SUB-PROG.: "principal()"
.
.

 

 

Resumidamente:

Não chame o principal() dentro dos sub-programas, mas sim crie um repita lá no principal() para que o código repita até que informem o "0". Percebe a diferença? assim, o principal() vai chamar um procedimento, ao procedimento finalizar, volta para o principal(), que por sua vez pode chama um novo procedimento ou finalizar... (é um vai e volta)

 

Outra coisa, tire esse interrompa do case 0 e deixe o código finalizar sozinho. (quando a opção for "0", o código não vai mais repetir e vai finalizar)

 

 

***

 

No aguardo.

Editado por Simon Viegas
  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites
 

Bom dia!

Retirei o que você falou, mais ainda não roda o algoritmo.

Algoritmo "Cadastro_clientes"

Var
   cpf: vetor [1..50] de inteiro
   nome: vetor [1..50] de caractere
   end: vetor [1..50] de caractere
   bai: vetor [1..50] de caractere
   cep: vetor [1..50] de inteiro
   cid: vetor [1..50] de caractere
   est: vetor [1..50] de caractere
   tel: vetor [1..50] de inteiro
   cel: vetor [1..50] de inteiro
   codigo, cpfpesq: inteiro
   encontrado, inserir: logico
procedimento principal()

Inicio
   repita
   escreval ("")
   escreval ("Menu Principal")
   escreval ("--------------")
   escreval ("0 - Sair")
   escreval ("1 - Inserir Novo Cadastro")
   escreval ("2 - Imprimir dados do cliente")
   escreval ("3 - Imprimir dados de todos clientes")
   escreva ("Digite uma Opcao: ")
   leia (codigo)
   limpatela
   ate (codigo=1) ou (codigo=2) ou (codigo=3)
   escolha (codigo)
   caso 1
        cadastro()
   caso 2
        consulta_cpf()
   caso 3
        consulta_todos()
   fimescolha
fimprocedimento
//---------------------- CADASTRO ----------------------
procedimento cadastro()
inicio
   limpatela
   escreval("---------------------  CADASTRO ---------------------")
   para i de 1 ate 50 faca
      escreva ("Digite o CPF: ")
      leia (cpf[i])
      escreva ("Digite o Nome: ")
      leia (nome[i])
      escreva ("Digite o Endereço: ")
      leia (end[i])
      escreva ("Digite o Bairro: ")
      leia (bai[i])
      escreva ("Digite o CEP: ")
      leia (cep[i])
      escreva ("Digite a Cidade: ")
      leia (cid[i])
      escreva ("Digite o Estado: ")
      leia (est[i])
      escreva ("Digite o Telefone: ")
      leia (tel[i])
      escreva ("Digite o Celular: ")
      leia (cel[i])
   fimpara
fimprocedimento

//-------------------------- CONSULTA PELO CPF ---------------------
procedimento consulta_cpf()
inicio
      limpatela
      escreval("---------------------  CONSULTA ---------------------")
      escreva ("Digite um CPF para Consulta : ")
      leia (cpfpesq)
      para i de 1 ate 50 faca
      se (cpf[i]) = (cpfpesq) então
         escreval ("---------------------- CONSULTA PELO CPF -------------------")
         escreval ("CPF: ", cpf[i])
         escreval ("Nome: ", nome[i])
         escreval ("Endereço: ", end[i])
         escreval ("Bairro: ", bai[i])
         escreval ("CEP: ", cep[i])
         escreval ("Cidade: ", cid[i])
         escreval ("Estado: ", est[i])
         escreval ("Telefone: ", tel[i])
         escreval ("Celular: ", cel[i])
         encontrado<-verdadeiro
      fimse
      fimpara
             se encontrado=falso então
                escreval ("------------ Nome informado não encontrado! -------------")
             fimse
      principal()
fimprocedimento

//-------------------------- CONSULTA TODOS ---------------------
procedimento consulta_todos()
inicio
      limpatela
      escreval("---------------------  CONSULTA ---------------------")
      para i de 1 ate 50 faca
         escreval ("---------------------- CONSULTA TODOS -------------------")
         escreval ("CPF: ", cpf[i])
         escreval ("Nome: ", nome[i])
         escreval ("Endereço: ", end[i])
         escreval ("Bairro: ", bai[i])
         escreval ("CEP: ", cep[i])
         escreval ("Cidade: ", cid[i])
         escreval ("Estado: ", est[i])
         escreval ("Telefone: ", tel[i])
         escreval ("Celular: ", cel[i])
      fimpara
fimprocedimento
inicio

      principal()
fimalgoritmo


Fimalgoritmo

 

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

Olá @Paulo Koreia.

 

 

O que ocorre ao tentar rodar? tente analisar o erro ou onde o erro está ocorrendo (geralmente o programa para na linha onde deu erro). Se não conseguir, posta aqui as informações.

 

 

ADENDO:

Sobre o que eu citei:

1 hora atrás, Simon Viegas disse:

Outra coisa, tire esse interrompa do case 0 e deixe o código finalizar sozinho. (quando a opção for "0", o código não vai mais repetir e vai finalizar)

 

É apenas para tirar o comando "interrompa" do caso, mas a opção "0" ainda precisa existir... já que a opção está disponível no menu. Então, o programa precisa ser finalizado deixando a execução chegar no "fimProcedimento"..., em vez de executar o comando "interrompa".

 

Veja seu código:

11 minutos atrás, Paulo Koreia disse:

   repita
   escreval ("")
   escreval ("Menu Principal")
   escreval ("--------------")
   escreval ("0 - Sair")
   escreval ("1 - Inserir Novo Cadastro")
   escreval ("2 - Imprimir dados do cliente")
   escreval ("3 - Imprimir dados de todos clientes")
   escreva ("Digite uma Opcao: ")
   leia (codigo)
   limpatela
   ate (codigo=1) ou (codigo=2) ou (codigo=3)

Ao digitar "0", a lista do menu vai apenas repetir, pois só está aceitando o 1, 2 e 3 no "ate". Insira o "0" também.

 

Lá no case, ou você deixa sem o "0" mesmo, ou insere algo, como um texto de despedida.

 


No aguardo.

 

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites
 

Olá.


Achou o local, mas analisou o que pode ser?

 

Para adiantar, provavelmente esqueceu de declarar o "i" que está sendo usado lá. Tente corrigir e dê continuidade.

 

No aguardo.

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites
 

Declarei "i" rodou, porém ele vai pedindo em sequencia os 50 cadastros e era para quando terminar o primeiro cadastro voltar pra tela principal para ver qual o passo seguinte do usuário.

Algoritmo "Cadastro_clientes"

Var
   cpf: vetor [1..50] de inteiro
   nome: vetor [1..50] de caractere
   end: vetor [1..50] de caractere
   bai: vetor [1..50] de caractere
   cep: vetor [1..50] de inteiro
   cid: vetor [1..50] de caractere
   est: vetor [1..50] de caractere
   tel: vetor [1..50] de inteiro
   cel: vetor [1..50] de inteiro
   codigo, cpfpesq: inteiro
   encontrado, inserir: logico
procedimento principal()

Inicio
   repita
   escreval ("")
   escreval ("Menu Principal")
   escreval ("--------------")
   escreval ("0 - Sair")
   escreval ("1 - Inserir Novo Cadastro")
   escreval ("2 - Imprimir dados do cliente")
   escreval ("3 - Imprimir dados de todos clientes")
   escreva ("Digite uma Opcao: ")
   leia (codigo)
   limpatela
   ate (codigo=1) ou (codigo=2) ou (codigo=3)
   escolha (codigo)
   caso 1
        cadastro()
   caso 2
        consulta_cpf()
   caso 3
        consulta_todos()
   fimescolha
fimprocedimento
//---------------------- CADASTRO ----------------------
procedimento cadastro()

var

   i:inteiro
   
inicio
   limpatela
   escreval("---------------------  CADASTRO ---------------------")
   para i de 1 ate 50 faca
      escreva ("Digite o CPF: ")
      leia (cpf[i])
      escreva ("Digite o Nome: ")
      leia (nome[i])
      escreva ("Digite o Endereço: ")
      leia (end[i])
      escreva ("Digite o Bairro: ")
      leia (bai[i])
      escreva ("Digite o CEP: ")
      leia (cep[i])
      escreva ("Digite a Cidade: ")
      leia (cid[i])
      escreva ("Digite o Estado: ")
      leia (est[i])
      escreva ("Digite o Telefone: ")
      leia (tel[i])
      escreva ("Digite o Celular: ")
      leia (cel[i])
   fimpara
fimprocedimento

//-------------------------- CONSULTA PELO CPF ---------------------
procedimento consulta_cpf()
inicio
      limpatela
      escreval("---------------------  CONSULTA ---------------------")
      escreva ("Digite um CPF para Consulta : ")
      leia (cpfpesq)
      para i de 1 ate 50 faca
      se (cpf[i]) = (cpfpesq) então
         escreval ("---------------------- CONSULTA PELO CPF -------------------")
         escreval ("CPF: ", cpf[i])
         escreval ("Nome: ", nome[i])
         escreval ("Endereço: ", end[i])
         escreval ("Bairro: ", bai[i])
         escreval ("CEP: ", cep[i])
         escreval ("Cidade: ", cid[i])
         escreval ("Estado: ", est[i])
         escreval ("Telefone: ", tel[i])
         escreval ("Celular: ", cel[i])
         encontrado<-verdadeiro
      fimse
      fimpara
             se encontrado=falso então
                escreval ("------------ Nome informado não encontrado! -------------")
             fimse
      principal()
fimprocedimento

//-------------------------- CONSULTA TODOS ---------------------
procedimento consulta_todos()
inicio
      limpatela
      escreval("---------------------  CONSULTA ---------------------")
      para i de 1 ate 50 faca
         escreval ("---------------------- CONSULTA TODOS -------------------")
         escreval ("CPF: ", cpf[i])
         escreval ("Nome: ", nome[i])
         escreval ("Endereço: ", end[i])
         escreval ("Bairro: ", bai[i])
         escreval ("CEP: ", cep[i])
         escreval ("Cidade: ", cid[i])
         escreval ("Estado: ", est[i])
         escreval ("Telefone: ", tel[i])
         escreval ("Celular: ", cel[i])
      fimpara
fimprocedimento
inicio

      principal()
fimalgoritmo

 

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

Olá @Paulo Koreia.

 

1) IDENTAÇÃO

Mantenha seu código sempre identado. A dica é já tentar codificar identado... o espaçamento padrão deixei com 3 espaços (eu particularmente prefiro com 2)

 

Abaixo já deixo um código identado...

 

2) QUANTIDADE DE CADASTROS

Para facilitar os testes, recomendam-se utilizar poucos cadastros, como uns 3..., pois conceitualmente não faz diferença nenhuma testar com 2, com 5, 50 ou com 1000... os resultados serão os mesmos, mas com menos trabalho. Ao final, reajusta para 50 novamente.

 

O código abaixo já deixo com 3!

 

3) REAJUSTE DA LÓGICA DO CADASTRO

Nesse código, você está cadastrado todo o limite de cadastros de uma vez só. Faz mais sentido cadastrar de um em um. Ai tem duas opções: ou cadastra um e volta para o menu principal, ou cadastra um e perguntar, no próprio procedimento de cadastro, se deseja cadastrar mais.

 

***

Código identado e com limite de 3:

Spoiler

Algoritmo "Cadastro_clientes"
var
   cpf: vetor [1..50] de inteiro
   nome: vetor [1..50] de caractere
   end: vetor [1..50] de caractere
   bai: vetor [1..50] de caractere
   cep: vetor [1..50] de inteiro
   cid: vetor [1..50] de caractere
   est: vetor [1..50] de caractere
   tel: vetor [1..50] de inteiro
   cel: vetor [1..50] de inteiro
   codigo, cpfpesq: inteiro
   encontrado, inserir: logico

procedimento principal()
   inicio
   repita
      escreval ("")
      escreval ("Menu Principal")
      escreval ("--------------")
      escreval ("0 - Sair")
      escreval ("1 - Inserir Novo Cadastro")
      escreval ("2 - Imprimir dados do cliente")
      escreval ("3 - Imprimir dados de todos clientes")
      escreva ("Digite uma Opcao: ")
      leia (codigo)
      limpatela
      {ate (codigo=1) ou (codigo=2) ou (codigo=3)}
   ate (codigo=1) ou (codigo=2) ou (codigo=3) ou (codigo=0)
   escolha (codigo)
      caso 1
         cadastro()
      caso 2
         consulta_cpf()
      caso 3
         consulta_todos()
   fimescolha
   fimprocedimento

//---------------------- CADASTRO ----------------------
procedimento cadastro()
   var
      i:inteiro
   inicio
   limpatela
   escreval("---------------------  CADASTRO ---------------------")
   {para i de 1 ate 50 faca}
   para i de 1 ate 3 faca
      escreva ("Digite o CPF: ")
      leia (cpf[i])
      escreva ("Digite o Nome: ")
      leia (nome[i])
      escreva ("Digite o Endereço: ")
      leia (end[i])
      escreva ("Digite o Bairro: ")
      leia (bai[i])
      escreva ("Digite o CEP: ")
      leia (cep[i])
      escreva ("Digite a Cidade: ")
      leia (cid[i])
      escreva ("Digite o Estado: ")
      leia (est[i])
      escreva ("Digite o Telefone: ")
      leia (tel[i])
      escreva ("Digite o Celular: ")
      leia (cel[i])
   fimpara
   fimprocedimento

//-------------------------- CONSULTA PELO CPF ---------------------
procedimento consulta_cpf()
   inicio
      limpatela
      escreval("---------------------  CONSULTA ---------------------")
      escreva ("Digite um CPF para Consulta : ")
      leia (cpfpesq)
      {para i de 1 ate 50 faca}
      para i de 1 ate 3 faca
         se (cpf[i]) = (cpfpesq) então
            escreval ("---------------------- CONSULTA PELO CPF -------------------")
            escreval ("CPF: ", cpf[i])
            escreval ("Nome: ", nome[i])
            escreval ("Endereço: ", end[i])
            escreval ("Bairro: ", bai[i])
            escreval ("CEP: ", cep[i])
            escreval ("Cidade: ", cid[i])
            escreval ("Estado: ", est[i])
            escreval ("Telefone: ", tel[i])
            escreval ("Celular: ", cel[i])
            encontrado<-verdadeiro
         fimse
      fimpara
      se encontrado=falso então
         escreval ("------------ Nome informado não encontrado! -------------")
      fimse
      principal()
   fimprocedimento

//-------------------------- CONSULTA TODOS ---------------------
procedimento consulta_todos()
   inicio
   limpatela
   escreval("---------------------  CONSULTA ---------------------")
   {para i de 1 ate 50 faca}
   para i de 1 ate 3 faca
      escreval ("---------------------- CONSULTA TODOS -------------------")
      escreval ("CPF: ", cpf[i])
      escreval ("Nome: ", nome[i])
      escreval ("Endereço: ", end[i])
      escreval ("Bairro: ", bai[i])
      escreval ("CEP: ", cep[i])
      escreval ("Cidade: ", cid[i])
      escreval ("Estado: ", est[i])
      escreval ("Telefone: ", tel[i])
      escreval ("Celular: ", cel[i])
   fimpara
   fimprocedimento
inicio
principal()
fimalgoritmo

 

 

Sugestões:

- Faça alguns testes e entenda o comportamento atual do código;

- Faça testes pressionando F8 (passo a passo). Entenda mais a fundo como funciona o fluxo de execução.

- Coloque um repita/ate no menu principal, de modo que caso não escolha a opção 0, o procedimento continue repetindo. Vá fazendo testes...

 

Qualquer dúvida é só postar.

 

No aguardo;

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

PS: outra coisa. Não é tb necessário ficar cadastrando todas as informações a cada teste... poderia deixar somente o CPF e Nome. Quanto tiver mais ou menos encaminhado, "habilita" os dados restantes e faz novos testes.

 

Para "desabilitar", basta colocar o trecho desejado em comentário. (ou // em cada linha, ou { } no trecho), ex.:

      escreva ("Digite o CPF: ")
      leia (cpf[i])
      escreva ("Digite o Nome: ")
      leia (nome[i])
      {escreva ("Digite o Endereço: ")
      leia (end[i])
      escreva ("Digite o Bairro: ")
      leia (bai[i])
      escreva ("Digite o CEP: ")
      leia (cep[i])
      escreva ("Digite a Cidade: ")
      leia (cid[i])
      escreva ("Digite o Estado: ")
      leia (est[i])
      escreva ("Digite o Telefone: ")
      leia (tel[i])
      escreva ("Digite o Celular: ")
      leia (cel[i])}

 

Faz os mesmo ajustes nas consultas...

Editado por Simon Viegas
  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário






Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×