×
Ir ao conteúdo
  • Cadastre-se

Como instalar GNU/Linux no Positivo Motion Q232A?


ian luis
Ir à solução Resolvido por Arutha,

Posts recomendados

Estou tentando instalar o sistema operacional Linux e estou tendo problema na hora de acessar as configurações de boot,pois sendo assim,reinicio o computador aperto DEL para ir pra bios e caiu na FRONT PAGE, ae aparece o seguinte..

                                                                                                                               FRONTE PAGE 

 

Continue>

BOOT MANAGER>

ADMINISTRADOR SECURE BOOT>

SETUP UTILITY>

 

SETUP UTILITY>

 

Main        Advanced       Security          Boot          Exit

 

Advanced  

 

igd configuration

igd-dvmt pre-al located <64m>

igd-dvmt total 6fx mem <max>

wifi control <enable>

bluetooth control <enable>

 

Enfim  não consigo acessar porque esses malditos bloqueiam ou no meu caso nem disponibilizam essa função de poder configurar a bios preciso que me ajudem se vou ter que baixar alguma atualização,liguei pra autorizada e  disseram que so instalam o windows 10.

Link para o comentário
Compartilhar em outros sites

  • 4 meses depois...

Ei dbarbosam, eu não consegui achar uma solução para essa falta de compatibilidade com distros Linux, e isso realmente me deixou bem aborrecido, pois algumas delas superam de longe o Windows 10 em termos de privacidade e usabilidade.

Depois que aquela empreitada não deu certo, eu baixei a ISO do Windows 10 (usando meu celular), criei um pen-drive "bootavel" com ela e em seguida instalei esse sistema (usando o método que descrevi na postagem ali em cima), deletando todas as partições que já estavam no pc. Mais tarde baixei - usando novamente meu celular porque o wi-fi do notebook ainda não estava funcionando - e instalei todos os drivers fornecidos pela Positivo (o driver de vídeo deve ser instalado por último porque ele depende de alguns outros drivers da Intel, que já vêm no mesmo patch da Positivo). Depois de tudo isso o notebook voltou a funcionar normalmente com W10, inclusive o wi-fi e o som (que também não funciona sem os drivers).

Resumindo: você não estragou seu notebook, é só instalar o Windows 10 e os drivers que fica de boas novamente.

O mais chato de tudo isso, é que esses dias eu descobri um defeito no meu notebook: a tela dele não apaga quando eu fecho a tampa, nem acende sozinha quando eu abro-a. De acordo com o manual, o notebook deveria fazer isso. Mas agora eu não tenho direito a garantia porque já alterei o sistema operacional. :tw_dissapointed_relieved:

Link para o comentário
Compartilhar em outros sites

  • 1 ano depois...

@dbarbosamjá no meu caso o wifi após a instalação deu mais ou menos certo, com baixo sinal, as vezes não reconhecendo a rede e o restante: bluetooth, som, câmera nada. voltei pro win10

adicionado 1 minuto depois
Em 12/05/2018 às 16:34, dbarbosam disse:

oi, estou com o mesmo problema, comprei esse notebook da positivo motion, fui inventar de colocar o linux mint e agora to sem wifi e som, queria saber qual sistema tu ta usando no teu e se ta tudo certo? to desesperado já!! desde já agradeço.

conseguiu achar uma solução?

Link para o comentário
Compartilhar em outros sites

  • 2 meses depois...
  • GusGraf alterou o título para Preciso instalar linux no sistema da positivo motion q 232a
  • mês depois...

Olá, também comprei este notebook e após uma semana testando várias distros e procedimentos, quero compartilhar o que consegui até agora, funciona wifi, bluetooth e o restante do hardware, só não consegui funcionar o audio ainda, mas creio que o mais difícil já foi. Pelo que entendi são duas dificuldades decorrentes do hardware deste notebook, uma é derivada do UEFI (devido ao HD dele, a questão do SSD emmc) que dificulta instalar as distro linux e outra do kernel que dificulta reconhecer o hardware.

 

Vamos por partes

 

Criei um pendrive bootavel com o lubuntu 16.04 e rodei o live-cd. Se durante o processo a tela apagar e nenhuma tecla funcionar, basta apertar uma vez o botão de liga/desliga (não é segurar, só apertar uma vez) que a tela liga novamente.

 

Quando o instalador chegou na parte de partições, criei uma nova tabela de particões para todo o HD no formato GPT (observe que criar uma nova tabela de partições é diferente de criar uma nova partição, se não souber a diferença procure no google). Depois criei quatro partições:

1- /

2-/home

3-swap

4- /boot/efi - ativando os marcadores boot e esp

 

Foi a primeira vez que precisei criar esta partição /boot/efi, ela não precisa ser grande, 100MB já resolve tranquilamente.

 

Conclui a instalação normal do lubuntu 16.04 e ele não reconheceu o wifi, então liguei o notebook no celular pelo cabo USB e ativei a função de vínculo por USB na função roteador wifi do celular. Com isso ele acessa a internet pelo wifi do seu celular.

 

Depois de instalado atualizei o lubuntu 16.04 para o 18.04 pela própria opção que ele oferece (quando tentei instalar diretamente o lubuntu 18.04 e o 19.04 não funcionou, não sei por que). Reiniciei, instalei as atualizações oferecidas, depois instalei o programa Ukuu Kernel Update Linux, é super intuitivo e serve para você atualizar para o kernel mais recente. Atualizei para o kernel mais recente, reiniciei, instalei as atualizações oferecidas e pronto, reconheceu todo o hardware, menos o som.

 

O Lubuntu roda tranquilo considerando o hardware modesto deste notebook, além da versão 18.04 ser LTS, então temos alguns anos a frente de suporte.

 

Agora vou batalhar para reconhecer o audio. A pesquisa neste forum e em outros locais da internet, me ajudaram a chegar nesta solução, por isto quis retribuir.

 

um abraço,

Fabricio

  • Curtir 2
  • Obrigado 1
Link para o comentário
Compartilhar em outros sites

  • Solução

@Fabricio.moreira  parabéns pelo esforço e por lembrar de compartilhar suas descobertas! Achei isto aqui no viva o linux, talvez ajude:

(https://www.vivaolinux.com.br/topico/Notebooks/Notebook-Positivo-Motio-Q232A-sem-audio)

"Enviado em 29/01/2019 - 11:25h

Faça o download desse script:
https://drive.google.com/file/d/1AVXJKZ6nPpQiq4-0p-mNDChNA5f-f3F_/view

No terminal, rode esses comandos:

cd Downloads sudo chmod +x es8316.sh sudo ./es8316.sh


Esse script baixa e instala o driver de áudio."

 

boa sorte!

  • Amei 1
Link para o comentário
Compartilhar em outros sites

  • 3 meses depois...
Em 03/10/2019 às 15:06, Arutha disse:

@Fabricio.moreira  parabéns pelo esforço e por lembrar de compartilhar suas descobertas! Achei isto aqui no viva o linux, talvez ajude:

(https://www.vivaolinux.com.br/topico/Notebooks/Notebook-Positivo-Motio-Q232A-sem-audio)

"Enviado em 29/01/2019 - 11:25h

Faça o download desse script:
https://drive.google.com/file/d/1AVXJKZ6nPpQiq4-0p-mNDChNA5f-f3F_/view

No terminal, rode esses comandos:

cd Downloads sudo chmod +x es8316.sh sudo ./es8316.sh


Esse script baixa e instala o driver de áudio."

 

boa sorte!

Criei essa conta pra responder: Deu certo!

Obrigado por se dar ao trabalho. Essa é a solução final.

Link para o comentário
Compartilhar em outros sites

  • 1 ano depois...

Após muita pesquisa em vários posts, consegui instalar o Xubuntu 20.04 LTS nesse laptop. Vou compartilhar aqui os passos.

1) CRIAR PENDRIVE BOOTÁVEL

Esse laptop só dá boot em pendrives UEFI, que após pesquisar, encontrei solução em
https://askubuntu.com/questions/395879/how-to-create-uefi-only-bootable-usb-live-media

Lá há até solução no windows com Rufus.

Basicamente eu fiz assim:

a) formate um pendrive no Gparted com uma partição fat32
b) no gparted, menu partição > gerenciar sinalizadores, e ative a flag "boot".
c) copie os arquivos com o comando (o 7z é do pacote p7zip)
   7z x xubuntu-20.04.2.0-desktop-amd64.iso -o/media/CAMINHO/PENDRIVE/

(eu tentei montar a imagem e copiar/colar no gerenciador de arquivos gráfico, mas não deu certo)

Isso deve ter criado um pendrive de instalação do xubuntu.

2) BIOS DO LAPTOP

a) espete o pendrive de instalação e inicialize o laptop, apertando F2 para acessar a Bios.
b) ache a opção "Enforce Secure Boot" e DESATIVE; por incrível que pareça, isso vai permitir que o wifi funcionar. Salve a bios e reinicie com F2. Selecione o pendrive.
c) no menu do xubuntu, selecione para "Try without install".

3) COM O XUBUNTU RODANDO

É para o wifi estar funcionando. Verifique.

Está implícito que você salvou todos os arquivos de que precisa e podemos formatar o HD. A instalação só vai funcionar se o "HD" estiver formatado com "tabela de partição GTP".

a) no terminal: sudo gparted
b) selecione o dispositivo do HD, algo como "emms".
c) no menu Dispositivo, selecione "Criar tabela de partição" e escolha o tipo GTP.
d) feito isso, crie 3 parições: no início, uma partição de 100Mb do tipo "boot efi", uma no final com 1Gb do tipo "swap" (ou troca do linux) e no meio uma grande partição do tipo ext4, que será o ponto de montagem /.

4) INSTALANDO O XUBUNTU

a) agora comece a instalação do Xubuntu normalmente até a parte de particionamento
b) na parte de particionamento (escolher o tipo de instalação), escolha "avançado"
c) para a partição ext4, coloque ponto de montagem "/"
d) na partição boot veja se tem boot e na swap, swap 🙂
e) proceda com a instalação até o fim. É para dar certo. No final reinicie para reinicializar com o xubuntu recém instalado.

5) ÁUDIO AINDA NÃO FUNCIONA

Encontramos uma solução no comentário 12 de
https://www.vivaolinux.com.br/topico/Notebooks/Notebook-Positivo-Motio-Q232A-sem-audio

a) Faça o download de um script que baixa e instala o driver de áudio:
https://drive.google.com/file/d/1AVXJKZ6nPpQiq4-0p-mNDChNA5f-f3F_/view
b) No terminal, no diretório onde baixou o script:
  sudo chmod +x es8316.sh
  sudo ./es8316.sh
c) Depois disso, o áudio passa a funcionar, mas parece que as caixas de som continuam como desplugadas, então tem que (periodicamente) abrir o mixer de áudio e selecionar o "alto-falante mono (desconectado)", que o som passa a sair nas caixas.

6) ATUALIZANDO

Por experiência, o wifi fica caindo toda hora. Com muita paciência, fiquei reconectando toda hora e baixei as atualizações com
  sudo apt update
(até baixar todos os repositórios, fui reconectando)
  sudo apt upgrade
(até baixar todos os arquivos, fui reconectando, um saco)

Aparentemente o wifi ficou mais estável com as atualizações, mas não posso garantir.

Parabéns! Você está com um laptop usável. Lembre-se que só tem 2Gb de ram, então evite programas carregados ao mesmo tempo.

  • Obrigado 1
Link para o comentário
Compartilhar em outros sites

  • mês depois...
  • KairanD alterou o título para Como instalar GNU/Linux no Positivo Motion Q232A?

Crie uma conta ou entre para comentar

Você precisa ser um usuário para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar agora

Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas comunidades sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×
×
  • Criar novo...

Curso de Hacker Ético

LANÇAMENTO!

CLIQUE AQUI E CONFIRA!

* Este curso não é ministrado pela equipe do Clube do Hardware.