Ir ao conteúdo
  • Comunicados

    • Gabriel Torres

      Seja um moderador do Clube do Hardware!   12-02-2016

      Prezados membros do Clube do Hardware, Está aberto o processo de seleção de novos moderadores para diversos setores ou áreas do Clube do Hardware. Os requisitos são:   Pelo menos 500 posts e um ano de cadastro; Boa frequência de participação; Ser respeitoso, cordial e educado com os demais membros; Ter bom nível de português; Ter razoável conhecimento da área em que pretende atuar; Saber trabalhar em equipe (com os moderadores, coordenadores e administradores).   Os interessados deverão enviar uma mensagem privada para o usuário @Equipe Clube do Hardware com o título "Candidato a moderador". A mensagem deverá conter respostas às perguntas abaixo:   Qual o seu nome completo? Qual sua data de nascimento? Qual sua formação/profissão? Já atuou como moderador em algo outro fórum, se sim, qual? De forma sucinta, explique o porquê de querer ser moderador do fórum e conte-nos um pouco sobre você.   OBS: Não se trata de função remunerada. Todos que fazem parte do staff são voluntários.
filipeg

Erro ao gravar pic16f628a

Recommended Posts

Ola estou tentando utilizar o pic16f628a  com o mikroC e o pickit 3 ele compila o programa tudo certinho mas não liga o led que é o que estou tentando fazer segue abaixo meu codigo peço desculpas se o erro for ***** sou novo tanto em assembly quanto na gravação de microcontroladores. A ligação esta certa ja revisei varias vezes e testei no proteus

 

void main() {

    TRISB = 0b00000000; //define os registradores da portb como de saida
    PORTB = 0b00000000; // coloca portb em nivel baixo 

    while(1)
    {
     RB1_bit = 1; //acende o led
     delay_ms(1000);
     RB1_bit = 0; //apaga o led
     delay_ms(1000);
    }

}

 

 

 

 

 

 

 

 

Editado por filipeg

Compartilhar este post


Link para o post
Compartilhar em outros sites

Verifique os fuses, vcc, reset e alguma configuração do seu pickit. E acho que, pra uma ajuda + efetiva, você pode/deve relatar deve um pouco mais que isso...

13 horas atrás, filipeg disse:

não liga o led

 

E não cometa mo mesmo errodo amigo @New Nerd que usou led verde

Compartilhar este post


Link para o post
Compartilhar em outros sites
 

Desculpa a falta de informações do outro post testei o programa com outro gravador de pic o K150 e funcionou ja no pickit 3 apresenta este erro na hora de gravar

Capturar.PNG.aac34895a311a8f252c520651e545d73.PNG

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário






Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×