Ir ao conteúdo
  • Cadastre-se
Hmember

Excel Excel - colar valores em tabela com nomes iguais

Recommended Posts

Boa tarde,

 

Tenho uma tabela com uma coluna com listagem de produtos, na coluna seguinte tenho as unidades compradas.

Noutra tabela tenho uma coluna com listagem de produtos, na coluna seguinte tenho as unidades avariadas.

As linhas com os nomes não estão no mesmo lugar.

O que preciso é de colar os valores das unidades avariadas em frente às unidades compradas para confirmar a percentagem de produtos avariados.

 

Tudo o que pesquisei não consegui colar nos locais onde repete o nome.

 

Agradeço ajuda.

 

Obrigado

calcular % produtos.xlsx

Compartilhar este post


Link para o post
Compartilhar em outros sites

Segue em anexo a planilha alterada. Veja se é isso que deseja!

Observação: Considerei seu "Produto Avariado" e "Uni produto avariado" na aba "Folha 2". E caso queira adicionar produtos, é só alterar a seleção de linhas/colunas na fórmula.

 

calcular % produtos.xlsx

Editado por lHenrique_10

Compartilhar este post


Link para o post
Compartilhar em outros sites

Obrigado lHenrique_10 pela ajuda, o resultado final que necessito é esse, mas precisava de saber qual o método para colar os valores da segunda tabela correspondente com as linhas da primeira tabela, pois a base de dados que tenho tem 10k linhas.

 

Obrigado.

Compartilhar este post


Link para o post
Compartilhar em outros sites
1 hora atrás, Hmember disse:

Obrigado lHenrique_10 pela ajuda, o resultado final que necessito é esse, mas precisava de saber qual o método para colar os valores da segunda tabela correspondente com as linhas da primeira tabela, pois a base de dados que tenho tem 10k linhas.

 

Obrigado.

Você pode inserir a quantidade de linhas que desejar, basta alterar a fórmula de busca da coluna C na aba "folha 1".

Vejamos:

A fórmula utilizada foi =SEERRO(PROCV($A2;'Folha 2'!$A$1:$B$9;2;FALSO);0)

Caso insira mais linhas na aba "Folha 2", basta alterar o intervalo de A1:B9 para o novo intervalo criado. Ou seja, se criar mais 20 linhas, o intervalo passa para $A$1:$B$29.

 

 

adicionado 9 minutos depois
18 horas atrás, lHenrique_10 disse:

Segue em anexo a planilha alterada. Veja se é isso que deseja!

Observação: Considerei seu "Produto Avariado" e "Uni produto avariado" na aba "Folha 2". E caso queira adicionar produtos, é só alterar a seleção de linhas/colunas na fórmula.

 

calcular % produtos.xlsx

EDITEI O COMENTÁRIO ACIMA E ALTEREI O ARQUIVO.

FAVOR FAZER O DOWNLOAD NOVAMENTE, POIS O ARQUIVO ANTERIOR ESTAVA COM UM ERRO NA FÓRMULA.

Editado por lHenrique_10
Alteração na Fórmula

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar agora





Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×