Ir ao conteúdo
  • Comunicados

    • Gabriel Torres

      Seja um moderador do Clube do Hardware!   12-02-2016

      Prezados membros do Clube do Hardware, Está aberto o processo de seleção de novos moderadores para diversos setores ou áreas do Clube do Hardware. Os requisitos são:   Pelo menos 500 posts e um ano de cadastro; Boa frequência de participação; Ser respeitoso, cordial e educado com os demais membros; Ter bom nível de português; Ter razoável conhecimento da área em que pretende atuar; Saber trabalhar em equipe (com os moderadores, coordenadores e administradores).   Os interessados deverão enviar uma mensagem privada para o usuário @Equipe Clube do Hardware com o título "Candidato a moderador". A mensagem deverá conter respostas às perguntas abaixo:   Qual o seu nome completo? Qual sua data de nascimento? Qual sua formação/profissão? Já atuou como moderador em algo outro fórum, se sim, qual? De forma sucinta, explique o porquê de querer ser moderador do fórum e conte-nos um pouco sobre você.   OBS: Não se trata de função remunerada. Todos que fazem parte do staff são voluntários.
    • DiF

      Poste seus códigos corretamente!   21-05-2016

      Prezados membros do Fórum do Clube do Hardware, O Fórum oferece um recurso chamado CODE, onde o ícone no painel do editor é  <>     O uso deste recurso é  imprescindível para uma melhor leitura, manter a organização, diferenciar de texto comum e principalmente evitar que os compiladores e IDEs acusem erro ao colar um código copiado daqui. Portanto convido-lhes para ler as instruções de como usar este recurso CODE neste tópico:  
fuzzicosta

Portugol erro de Programação Portugol

Recommended Posts

Olá preciso que vocês me ajudem pois sou iniciante e não sei se isso é para ser feito em Portugol ou Visualg, mas alguem pode resolver para mim em portugol? Por favor me ajudem.

 

3.     Escreva um algoritmo em PORTUGOL que receba 15 números e imprima quantos números maiores que 30 foram digitados. 

Editado por Simon Viegas
DEIXADO APENAS O EXERCÍCIO CORRESPONDENTE AO TÓPICO

Compartilhar este post


Link para o post
Compartilhar em outros sites

Olá @fuzzicosta.

 

7 horas atrás, fuzzicosta disse:

Olá preciso que vocês me ajudem pois sou iniciante e não sei se isso é para ser feito em Portugol ou Visualg, mas alguem pode resolver para mim em portugol? Por favor me ajudem.

 

Escolha UM dos exercício... tente fazer, posta o código aqui e indica onde está com dúvidas.

 

 

PS: se já tivesse postagem a sua tentativa, como foi sugerido, já teríamos respondido.

 

No aguardo.

Compartilhar este post


Link para o post
Compartilhar em outros sites

3°) Esta fazendo o processo normalmente, mas se eu digitar número ex: 48 ele consta como raiz de 7, sendo que que não existe rais de 48 em números inteiro, tem alguma forma de aparecer uma mensagem de erro quando digitar esse valor. E ele disse "quantos números maiores que 30 foram digitados" o que isso quer dizer?

algoritmo "Raiz Quadrada"
var
   numero,c: inteiro
   RAIZ: real
inicio
   escreval("Autor: Rodrigo de Oliveira Costa")
   escreval("                                   ")
   para C de 1 ate 15 faca
      escreval("Digite um número inteiro: ")
      leia(numero)
      raiz <- 0
      repita
         raiz <- raiz + 1
      ate(raiz * raiz) > numero
      raiz <- raiz - 1
      escreval("Raiz quadrada de",numero," é",RAIZ)
      escreval("                                   ")
   fimpara
fimalgoritmo

 

Editado por Simon Viegas
Inserir tag CODE (obs.: indentação feita Visualg, pressionando teclas CTRL+G)

Compartilhar este post


Link para o post
Compartilhar em outros sites

Olá @fuzzicosta.

 

1 hora atrás, fuzzicosta disse:

3°) Esta fazendo o processo normalmente, mas se eu digitar número ex: 48 ele consta como raiz de 7, sendo que que não existe rais de 48 em números inteiro, tem alguma forma de aparecer uma mensagem de erro quando digitar esse valor. E ele disse "quantos números maiores que 30 foram digitados" o que isso quer dizer?

Spoiler


algoritmo "Raiz Quadrada"
var
   numero,c: inteiro
   RAIZ: real
inicio
   escreval("Autor: Rodrigo de Oliveira Costa")
   escreval("                                   ")
   para C de 1 ate 15 faca
      escreval("Digite um número inteiro: ")
      leia(numero)
      raiz <- 0
      repita
         raiz <- raiz + 1
      ate(raiz * raiz) > numero
      raiz <- raiz - 1
      escreval("Raiz quadrada de",numero," é",RAIZ)
      escreval("                                   ")
   fimpara
fimalgoritmo

 

Está tentando fazer qual exercício? o 3º?

 

 

Então, foque no problema!!! Vamos lá:

 

Se for o 3º, segue um exemplo:

algoritmo "Raiz Quadrada"
//ENUNCIADO DA QUESTÃO
//3. Escreva um algoritmo em PORTUGOL que receba 15 números e imprima quantos
// números maiores que 30 foram digitados.
var
   numero,c    :inteiro
   {RAIZ: real} //o problema não tem qualquer relação com raízes
   qtdMaior30 :inteiro
   
inicio
   escreval("Autor: Rodrigo de Oliveira Costa")
   escreval("                                   ")
   qtdMaior30<-0 //inicializa a variável
   para c de 1 ate 15 faca
      escreva ("Digite um número inteiro: ")
      leia(numero)
      //raiz <- 0
      //repita
      //   raiz <- raiz + 1
      //ate(raiz * raiz) > numero
      //raiz <- raiz - 1
      //escreval("Raiz quadrada de",numero," é",RAIZ)
      se (numero>30) ENTÃO
         qtdMaior30<-qtdMaior30+1 //atualiza o quantidade
      fimse
      //escreval("                                   ")
   fimpara
   escreval("Dos 15 números informados",qtdMaior30," são maiores que 30")
fimalgoritmo

 

Pronto. Dê uma revisada nesse código. Caso tenha alguma dúvida sobre ele. Posta aqui.

Caso queira tentar fazer um outro item, abra um novo tópico... lá poste o enunciado completo da item, o código que tentou fazer e onde está com dúvidas.

 

LEMBRANDO: aqui só trate de dúvidas sobre o item 3!!!

 

No aguardo.

 

adicionado 18 minutos depois

ADENDO:


Segue o código resumido:

Algoritmo "Raiz Quadrada"
//ENUNCIADO DA QUESTÃO
//3. Escreva um algoritmo em PORTUGOL que receba 15 números e imprima quantos
// números maiores que 30 foram digitados.
var
   numero,c    :inteiro
   qtdMaior30 :inteiro

inicio
   escreval("Autor: Rodrigo de Oliveira Costa")
   escreval("                                   ")
   qtdMaior30<-0 //inicializa a variável
   para c de 1 ate 15 faca
      escreva ("Digite um número inteiro: ")
      leia(numero)
      se (numero>30) ENTÃO
         qtdMaior30<-qtdMaior30+1 //atualiza o quantidade
      fimse
   fimpara
   escreval("Dos 15 números informados",qtdMaior30," são maiores que 30")
fimalgoritmo

 

 

Para efetuar testes, é possível fazer o Visualg gerar números automaticamente, ex.:

Algoritmo "Raiz Quadrada"
//ENUNCIADO DA QUESTÃO
//3. Escreva um algoritmo em PORTUGOL que receba 15 números e imprima quantos
// números maiores que 30 foram digitados.
var
   numero,c    :inteiro
   qtdMaior30 :inteiro

inicio
   escreval("Autor: Rodrigo de Oliveira Costa")
   escreval("                                   ")
   qtdMaior30<-0 //inicializa a variável
   para c de 1 ate 15 faca
      escreva ("Digite um número inteiro: ")
      ALEATORIO 0,60 //vai gerar números de 0 a 60
      leia(numero) //como está "dentro do ALEATORIO", o número será lido automaticamente 
      ALEATORIO OFF //finaliza o comando de gerar números aleatórios
      se (numero>30) ENTÃO
         qtdMaior30<-qtdMaior30+1 //atualiza o quantidade
      fimse
   fimpara
   escreval("Dos 15 números informados",qtdMaior30," são maiores que 30")
fimalgoritmo

É bem simples... o comando ALEATORIO servirá simplesmente para "digitar números por você". Fica mais prático para testar. Se tiver dúvidas, é só perguntar.

Editado por Simon Viegas

Compartilhar este post


Link para o post
Compartilhar em outros sites
Postado (editado)

Citação:

Spoiler
Em 29/03/2018 às 13:23, Simon Viegas disse:

Olá @fuzzicosta.

 

 

Está tentando fazer qual exercício? o 3º?

 

 

Então, foque no problema!!! Vamos lá:

 

Se for o 3º, segue um exemplo:



algoritmo "Raiz Quadrada"
//ENUNCIADO DA QUESTÃO
//3. Escreva um algoritmo em PORTUGOL que receba 15 números e imprima quantos
// números maiores que 30 foram digitados.
var
   numero,c    :inteiro
   {RAIZ: real} //o problema não tem qualquer relação com raízes
   qtdMaior30 :inteiro
   
inicio
   escreval("Autor: Rodrigo de Oliveira Costa")
   escreval("                                   ")
   qtdMaior30<-0 //inicializa a variável
   para c de 1 ate 15 faca
      escreva ("Digite um número inteiro: ")
      leia(numero)
      //raiz <- 0
      //repita
      //   raiz <- raiz + 1
      //ate(raiz * raiz) > numero
      //raiz <- raiz - 1
      //escreval("Raiz quadrada de",numero," é",RAIZ)
      se (numero>30) ENTÃO
         qtdMaior30<-qtdMaior30+1 //atualiza o quantidade
      fimse
      //escreval("                                   ")
   fimpara
   escreval("Dos 15 números informados",qtdMaior30," são maiores que 30")
fimalgoritmo

 

Pronto. Dê uma revisada nesse código. Caso tenha alguma dúvida sobre ele. Posta aqui.

Caso queira tentar fazer um outro item, abra um novo tópico... lá poste o enunciado completo da item, o código que tentou fazer e onde está com dúvidas.

 

LEMBRANDO: aqui só trate de dúvidas sobre o item 3!!!

 

No aguardo.

 

adicionado 18 minutos depois

ADENDO:


Segue o código resumido:



Algoritmo "Raiz Quadrada"
//ENUNCIADO DA QUESTÃO
//3. Escreva um algoritmo em PORTUGOL que receba 15 números e imprima quantos
// números maiores que 30 foram digitados.
var
   numero,c    :inteiro
   qtdMaior30 :inteiro

inicio
   escreval("Autor: Rodrigo de Oliveira Costa")
   escreval("                                   ")
   qtdMaior30<-0 //inicializa a variável
   para c de 1 ate 15 faca
      escreva ("Digite um número inteiro: ")
      leia(numero)
      se (numero>30) ENTÃO
         qtdMaior30<-qtdMaior30+1 //atualiza o quantidade
      fimse
   fimpara
   escreval("Dos 15 números informados",qtdMaior30," são maiores que 30")
fimalgoritmo

 

 

Para efetuar testes, é possível fazer o Visualg gerar números automaticamente, ex.:



Algoritmo "Raiz Quadrada"
//ENUNCIADO DA QUESTÃO
//3. Escreva um algoritmo em PORTUGOL que receba 15 números e imprima quantos
// números maiores que 30 foram digitados.
var
   numero,c    :inteiro
   qtdMaior30 :inteiro

inicio
   escreval("Autor: Rodrigo de Oliveira Costa")
   escreval("                                   ")
   qtdMaior30<-0 //inicializa a variável
   para c de 1 ate 15 faca
      escreva ("Digite um número inteiro: ")
      ALEATORIO 0,60 //vai gerar números de 0 a 60
      leia(numero) //como está "dentro do ALEATORIO", o número será lido automaticamente 
      ALEATORIO OFF //finaliza o comando de gerar números aleatórios
      se (numero>30) ENTÃO
         qtdMaior30<-qtdMaior30+1 //atualiza o quantidade
      fimse
   fimpara
   escreval("Dos 15 números informados",qtdMaior30," são maiores que 30")
fimalgoritmo

É bem simples... o comando ALEATORIO servirá simplesmente para "digitar números por você". Fica mais prático para testar. Se tiver dúvidas, é só perguntar.

 

Exercício 4°/ esta dando erro quando tento executar o algoritmo poderia resolver para mim por gentileza.

[CÓDIGO REMOVIDO PELA MODERAÇÃO]

 

adicionado 5 minutos depois

Exercício 5°/ erro ao executar no visualg

[CÓDIGO REMOVIDO PELA MODERAÇÃO]

 

Editado por Simon Viegas
Removido conteúdo off-topic
  • Confuso 1

Compartilhar este post


Link para o post
Compartilhar em outros sites
15 minutos atrás, fuzzicosta disse:

Exercício 4°/ esta dando erro quando tento executar o algoritmo poderia resolver para mim por gentileza.

[CÓDIGO REMOVIDO PELA MODERAÇÃO]

 

adicionado 5 minutos depois

Exercício 5°/ erro ao executar no visualg

[CÓDIGO REMOVIDO PELA MODERAÇÃO]

 

 

@fuzzicosta, este tópico deve está voltado apenas para o exercício 3. Para novos exercícios, favor abrir um novo tópico para cada um deles. Desta forma, cada tópico fica voltado apenas para um exercício, caso contrário, pode misturar os temas...

 

Então, em relação ao exercício 3, alguma dúvida?

 

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário






Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×