Ir ao conteúdo
  • Cadastre-se
Natan quilombola

Excel Macro no Excel usando SE

Recommended Posts

Gostaria de criar uma macro que executasse a seguinte formula =SE(D2="D";e2*-1;e2)

Onde D2 é uma letra que indica Debito ou Credito caso fosse encontrado debito a formula tornaria a celula e2 negativa, pois depois eu tomaria esse valor para calculo.

Na planilha a formula funciona. Só que para isso preciso de uma célula extra. 

Quando peço para gravar uma macro, o resultado da zerado. O mesmo acontece quando habilito calculo iterativo. também dá zero.

Obrigado

Compartilhar este post


Link para o post
Compartilhar em outros sites

Amigo, primeiramente boa noite, 

Não sei se entendi bem sua pergunta mas tente fazer usando referências relativas que é uma opção do macro, você vai conseguir visualiza-la se ativar a aba de desenvolvedor

 

Seria ideal que deixasse uma planilha de exemplo, abraços!!

Compartilhar este post


Link para o post
Compartilhar em outros sites
16 horas atrás, Augusto Megres disse:

Amigo, primeiramente boa noite, 

Não sei se entendi bem sua pergunta mas tente fazer usando referências relativas que é uma opção do macro, você vai conseguir visualiza-la se ativar a aba de desenvolvedor

 

Seria ideal que deixasse uma planilha de exemplo, abraços!!

Obrigado pela resposta.
Abaixo um exemplo

exemplo SE.xlsx

adicionado 2 minutos depois

amigos

Estou deixando uma planilha de exemplo do que desejo. 

quero que ao informar em uma coluna que a entrada da coluna posterior é um debito, ele transforme esse numero em negativo.

Se conhece uma forma de fazer isso, por favor auxilie-me.

exemplo SE.xlsx

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar agora





Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×