Ir ao conteúdo
  • Comunicados

    • Gabriel Torres

      Seja um moderador do Clube do Hardware!   12-02-2016

      Prezados membros do Clube do Hardware, Está aberto o processo de seleção de novos moderadores para diversos setores ou áreas do Clube do Hardware. Os requisitos são:   Pelo menos 500 posts e um ano de cadastro; Boa frequência de participação; Ser respeitoso, cordial e educado com os demais membros; Ter bom nível de português; Ter razoável conhecimento da área em que pretende atuar; Saber trabalhar em equipe (com os moderadores, coordenadores e administradores).   Os interessados deverão enviar uma mensagem privada para o usuário @Equipe Clube do Hardware com o título "Candidato a moderador". A mensagem deverá conter respostas às perguntas abaixo:   Qual o seu nome completo? Qual sua data de nascimento? Qual sua formação/profissão? Já atuou como moderador em algo outro fórum, se sim, qual? De forma sucinta, explique o porquê de querer ser moderador do fórum e conte-nos um pouco sobre você.   OBS: Não se trata de função remunerada. Todos que fazem parte do staff são voluntários.
    • DiF

      Poste seus códigos corretamente!   21-05-2016

      Prezados membros do Fórum do Clube do Hardware, O Fórum oferece um recurso chamado CODE, onde o ícone no painel do editor é  <>     O uso deste recurso é  imprescindível para uma melhor leitura, manter a organização, diferenciar de texto comum e principalmente evitar que os compiladores e IDEs acusem erro ao colar um código copiado daqui. Portanto convido-lhes para ler as instruções de como usar este recurso CODE neste tópico:  
LucasOliver123

VisualG Solução para mais digitado

Recommended Posts

Postado (editado)

Bom dia! Bom, eu estou fazendo um algoritmo e travei...

Preciso que a pessoa digite o valor de A, até digitar "0" para finalizar, enquanto isso vai armazenando. No final preciso mostrar qual maior e menor digitado (até aí eu consegui) e mostrar quantas vezes o maior/menor número foi digitado. Por exemplo se o maior/menor número foi 5 e foi digitado 2 vezes. Não consigo essa parte. Vou postar o código pra quem puder me ajudar!!

 

VOU POSTAR FOTOS DO ALGORITMO PRA VOCÊS ENTENDEREM (CASO PRECISE).

var
   vla, vlma, vlme, vlmd, qtcal, vlmd2: inteiro
inicio

   vla  <- 0
   vlma <- 0
   vlme <- 0
   vlmd <- 0
   qtcal <- 0
   vlmd2 <- 0


   escreva ("Digite o valor de A: ")
    leia (vla)

      se (vla = 0) então
         escreval ("Finalizando!")
      senao

   vlma <- vla
   vlme <- vla


   repita
   
      escreva ("Digite o valor de A: ")
      leia (vla)
      qtcal <- qtcal + 1
      
      se (vla > vlma) então
         vlma <- vla
         vlmd <- vlma + 1          aqui seria pra mostrar o maior, está certo?
      fimse
      
      se (vla < vlme ) e (vla <> 0) então
         vlme <- vla
         vlmd2 <- vlme + 1   essa parte para mostrar o menor. Se o menor aparece só 2x ele funciona, mas se ele aparece 1 vez só, não funciona...
      fimse
      

      
   ate (vla = 0)
   fimse

escreval ("O maior é: ", vlma)
escreval ("O menor é: ", vlme)
escreval ("Número de cálculos: ", qtcal)
escreval ("Maior número apareceu", vlmd)
escreval ("Menor número apareceu", vlmd2)

fimalgoritmo

 

 

 

Codigo 2.png

Codigo 3.png

Codigo 1.png

Editado por Simon Viegas
Inserir tag CODE

Compartilhar este post


Link para o post
Compartilhar em outros sites
Postado (editado)

Olá @LucasOliver123.

 

1#
Mantenha sempre o código indentado. Esses espaços entre linhas também são desnecessários... Ex.:

algoritmo "FCdH"
var
   vla, vlma, vlme, vlmd, qtcal, vlmd2: inteiro
inicio
vla  <- 0
vlma <- 0
vlme <- 0
vlmd <- 0
qtcal <- 0
vlmd2 <- 0
escreva ("Digite o valor de A: ")
leia (vla)
se (vla = 0) ENTÃO
   escreval ("Finalizando!")
senao
   vlma <- vla
   vlme <- vla
   repita
      escreva ("Digite o valor de A: ")
      leia (vla)
      qtcal <- qtcal + 1
      se (vla > vlma) ENTÃO
         vlma <- vla
         vlmd <- vlma + 1 //aqui seria pra mostrar o maior, está certo?
      fimse
      se (vla < vlme ) e (vla <> 0) ENTÃO
         vlme <- vla
         vlmd2 <- vlme + 1 //essa parte para mostrar o menor. Se o menor aparece só 2x ele funciona, mas se ele aparece 1 vez só, não funciona...
         fimse
      ate (vla = 0)
   fimse
escreval ("O maior é: ", vlma)
escreval ("O menor é: ", vlme)
escreval ("Número de cálculos: ", qtcal)
escreval ("Maior número apareceu", vlmd)
escreval ("Menor número apareceu", vlmd2)
fimalgoritmo

 

 

 

2#

Sobre:

1 hora atrás, LucasOliver123 disse:

mostrar quantas vezes o maior/menor número foi digitado

 

Então, o segredo para se resolver um problema, é antes entender o problema. É simples!

 

O que é que está sendo pedido? (entenda o problema)

O que foi implementado como solução? (o que você implementou corresponde a uma solução para o quê você entendeu?)

 

 

 

***

 

No aguardo.

Editado por Simon Viegas

Compartilhar este post


Link para o post
Compartilhar em outros sites
3 horas atrás, Simon Viegas disse:

Mantenha sempre o código indentado. Esses espaços entre linhas também são desnecessários... Ex.:

Esses espaços são o meu professor que pede! Que se o código não ficar do jeito que ele ensina/explica não irá aceitar.

 

3 horas atrás, Simon Viegas disse:

O que é que está sendo pedido? (entenda o problema)

O que foi implementado como solução? (o que você implementou corresponde a uma solução para o quê você entendeu?)

E eu entendi sim, porém só não consigo a parte de mostrar o número que mais foi digitado! O restante eu já fiz!

Compartilhar este post


Link para o post
Compartilhar em outros sites

1#

Sobre:

3 horas atrás, LucasOliver123 disse:

Esses espaços são o meu professor que pede! Que se o código não ficar do jeito que ele ensina/explica não irá aceitar.

Que espaços se refere? horizontal ou entre as linhas?

 

A indentação se refere ao espaçamento horizontal. Para facilitar, pressione CTRL+G no Visualg... ele indenta automaticamente.

 

Caso seja necessário espaços entre linhas, creio que também seja necessário algum critério.. a quantidade de espaços parecem está aleatórias...

 

 

 

2#

Sobre:

3 horas atrás, LucasOliver123 disse:

E eu entendi sim, porém só não consigo a parte de mostrar o número que mais foi digitado! O restante eu já fiz!

Estou me referindo a "a parte de mostrar o número que mais foi digitado" mesmo... tanto que eu citei o trecho...

é a isso que estou me reforçando... o que você entendeu dessa parte está correspondendo ao que você implementou?

 

Então, o que você entendeu do que deve ser feito?

 

 

Faça o seguinte... esqueça o Visualg ou qualquer linguagem de programação por enquanto... tente fazer isso no papel.  Usando esses número, 2, 5, 4, 5, 8, 6, 8, 8 e 0, qual seria a resposta correta?

 

Daí entenda o funcionamento da lógica, implemente um algoritmo e passe para o Visualg.

 

No aguardo.

 

 

 

Compartilhar este post


Link para o post
Compartilhar em outros sites
12 horas atrás, Simon Viegas disse:

1#

Sobre:

Que espaços se refere? horizontal ou entre as linhas?

 

A indentação se refere ao espaçamento horizontal. Para facilitar, pressione CTRL+G no Visualg... ele indenta automaticamente.

 

Caso seja necessário espaços entre linhas, creio que também seja necessário algum critério.. a quantidade de espaços parecem está aleatórias...

 

 

 

2#

Sobre:

Estou me referindo a "a parte de mostrar o número que mais foi digitado" mesmo... tanto que eu citei o trecho...

é a isso que estou me reforçando... o que você entendeu dessa parte está correspondendo ao que você implementou?

 

Então, o que você entendeu do que deve ser feito?

 

 

Faça o seguinte... esqueça o Visualg ou qualquer linguagem de programação por enquanto... tente fazer isso no papel.  Usando esses número, 2, 5, 4, 5, 8, 6, 8, 8 e 0, qual seria a resposta correta?

 

Daí entenda o funcionamento da lógica, implemente um algoritmo e passe para o Visualg.

 

No aguardo.

 

 

 

Esquece que eu pedi ajuda e muito obrigado! Eu precisava de ajuda pois eu tinha prova ontem e não estava conseguindo fazer e não achei nada na internet sobre. Mas mesmo assim, obrigado. -.-

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites
16 minutos atrás, LucasOliver123 disse:

Esquece que eu pedi ajuda...

ok

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário






Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×