Ir ao conteúdo
  • Comunicados

    • Gabriel Torres

      Seja um moderador do Clube do Hardware!   12-02-2016

      Prezados membros do Clube do Hardware, Está aberto o processo de seleção de novos moderadores para diversos setores ou áreas do Clube do Hardware. Os requisitos são:   Pelo menos 500 posts e um ano de cadastro; Boa frequência de participação; Ser respeitoso, cordial e educado com os demais membros; Ter bom nível de português; Ter razoável conhecimento da área em que pretende atuar; Saber trabalhar em equipe (com os moderadores, coordenadores e administradores).   Os interessados deverão enviar uma mensagem privada para o usuário @Equipe Clube do Hardware com o título "Candidato a moderador". A mensagem deverá conter respostas às perguntas abaixo:   Qual o seu nome completo? Qual sua data de nascimento? Qual sua formação/profissão? Já atuou como moderador em algo outro fórum, se sim, qual? De forma sucinta, explique o porquê de querer ser moderador do fórum e conte-nos um pouco sobre você.   OBS: Não se trata de função remunerada. Todos que fazem parte do staff são voluntários.
    • DiF

      Poste seus códigos corretamente!   21-05-2016

      Prezados membros do Fórum do Clube do Hardware, O Fórum oferece um recurso chamado CODE, onde o ícone no painel do editor é  <>     O uso deste recurso é  imprescindível para uma melhor leitura, manter a organização, diferenciar de texto comum e principalmente evitar que os compiladores e IDEs acusem erro ao colar um código copiado daqui. Portanto convido-lhes para ler as instruções de como usar este recurso CODE neste tópico:  

Recommended Posts

algoritmo "semnome"
// Função :
// Autor :
// Data : 02/07/2018
// Seção de Declarações 
var
polt: vetor [1..48] de real
polts: vetor [1..48] de inteiro
canc, menu, pol: inteiro
i, j, m, cont, Tot, Totg: inteiro
resp, respc: literal
inicio
Totg <- 870
para i de 1 ate 48 faca
     polt[i] <- i
fimpara
menu <- 0
enquanto menu <> 5 faca
         limpatela
         escreval()
         escreval("  ******* Bem vindo a Lios Ayrline *******  ")
         escreval("  ****************************************  ")
         escreval()
         escreval("      ESCOLHA UMA OPÇÃO PARA INICIAR        ")
         escreval("****[1] - Mostrar o mapa de poltronas*******")
         escreval("****[2] - Comprar passagens*****************")
         escreval("****[3] - Trocar passagens******************")
         escreval("****[4] - Cancelar passagem*****************")
         escreval("****[5] - Finalizar*************************")
         escreval("  ****************************************  ")
         escreval()
         escreva ("DIGITE UMA OPÇÃO PARA CONTINUAR -> ")
         leia(menu)
         limpatela
         
// MENU 1 -> MOSTRAR A TELA
se menu = 1 então
   cont <- 1
// MOLDANDO A TELA DE MOSTRAR MAPAS DE POLTRONAS
   escreval("****  Opção: Mostrar o mapa de poltronas *******")
   escreval("****     ->       Poltronas       <-     *******")
   para j de 1 ate 12 faca
          escreval ("****          ", polt[cont]:3, "  ", polt[cont+1]:3, polt[cont+2]:3,"   ", polt[cont+3]:3,"          *******")
          cont <- cont+4
   fimpara
// MOLD TERMINADO E INICIANDO TELAS DE OBS E OPÇÕES
         escreval()
         escreval("**** ->   OBS:Com numeros estão vazias <-*******")
         escreval("**** ->   OBS:Com zero estão vendidas  <-*******")
//TELA DE OPÇÕES
         escreval()
         escreval("Para escolher a sua poltrona aperte [2]   ")
         escreval("Para voltar ao menu inicial aperte [6]   ")
         escreva("Digite a sua opção - >   ")
         leia(menu)
// MENU 2 LIMPA A PLANILHA E ENTRA NA OPÇÃO 2 LOGO ABAIXO
         se menu = 2 então
         fimse
fimse
Limpatela
Escreval ( )

// MENU 2 -> COMPRAR PASSAGEM//
se menu = 2 então
   cont <- 1
   escreval("****       Opção: Comprar passagem       *******")
   escreval("****     ->       Poltronas       <-     *******")
   para j de 1 ate 12 faca
          escreval ("****          ", polt[cont]:3, "  ", polt[cont+1]:3, polt[cont+2]:3,"   ", polt[cont+3]:3,"          *******")
          cont <- cont+4
   fimpara
// DEPOIS DE APRESENTADO O MAPA DE POLTRONAS, TA NA HORA DE ESCOLHER A DESEJADA //
          escreval(                             )
          escreva ("Qual poltrona você deseja escolher -> ")
   leia (i)
// CASO A POLTRONA ESTEJA DIFERENTE DE 0 (OCUPADA), APARECE A MENSAGEM E A CONFIRMAÇÃO DE RESERVA
   se polt[i] <> 0 então
      escreval (" -> Poltrona livre. Deseja Adquirir? " )
      escreval()
      escreval( "Para Sim -> aperte [s] | Para Não -> aperte [n]")
      escreva( "Digite a opção desejada -> ")
      leia(resp)
      se resp = "s" então
         polt[i] <- 0
         polts[i] <- i
         escreval ("Poltrona", i , " selocionada com sucesso")
         escreval ("--------------------------------------")
// APRESENTA NOVAMENTE O MENU PERGUNTANDO SE DESEJA FINALIZAR TUDO OU SO DESEJA RETORNAR AO MENU PRINCIPAL
         escreval ("Para finalizar a sua compra digite [5}")
         escreval ("Para ir ao menu principal e realizar qualquer outra operação aperte [6]")
         escreval ( )
         escreva ("Digite sua opção -> ")
         leia(menu)
      fimse
// SE A POLTRONA TIVER O '0'(OCUPADA), APARECE A MENSAFEM E DA A OPÇÃO DE VOLTAR PRO MENU PRA REFAZERA A OPERAÇÃO)
   senao
        se polt[i] = 0 então
           escreval ("Desculpe! A poltrona ja esta ocupada. Volte ao menu apertando a tela [6]")
           leia (menu)
        fimse
   fimse
fimse

// MENU 3 -> TROCANDO PASSAGEM
se menu = 3 então
   cont <- 1
   escreval("****       Opção: Trocar passagem        *******")
   escreval("****     ->       Poltronas       <-     *******")
   para j de 1 ate 12 faca
         escreval ("****          ", polt[cont]:3, "  ", polt[cont+1]:3, polt[cont+2]:3,"   ", polt[cont+3]:3,"          *******")
         cont <- cont+4
   fimpara

//se polt[i] <> 0 então
escreval("   Qual a poltrona que você deseja trocar?     ")
escreva ("   Digite o número da sua poltrona -> ")
leia(i)
polt[i] <- i
polts[i] <- 0
escreval()
escreval ("  POLTRONAS COM O NÚMERO 0 JÁ ESTÃO OCUPADAS")
escreva  ("  Qual poltrona você deseja? -> ")
leia(i)
se polt[i] = 0 então
   escreval ("***** Desculpe! Poltrona já ocupada *****")
   timer(4000)
   timer(0)
   limpatela()
senao
     se polt[i] <> 0 então
        polt[i] <-  0
        polts[i] <-  i
      fimse
      escreval()
      escreval(" ***** Troca realizada com sucesso! ***** ")
      escreval()
      escreval()
      timer(1500)
      timer(0)
      limpatela()
      escreval("Para fazer uma nova compra ou retornar ao menu principal digite [6]")
      escreval("Para finalizar a sua compra digite [5]")
      escreva ("Digite a opção desejada -> ")
      leia (menu)
      escreval
     fimse
fimse
//MENU 4 -> cancelar passagem
se menu = 4 então
   cont <- 1
   escreval("****       Opção: Cancelar passagem      *******")
   escreval("****     ->       Poltronas       <-     *******")
   para j de 1 ate 12 faca
         escreval ("****          ", polt[cont]:3, "  ", polt[cont+1]:3, polt[cont+2]:3,"   ", polt[cont+3]:3,"          *******")
         cont <- cont+4
   fimpara
   escreval()
   escreval ("Qual a poltrona que você deseja cancelar?   ")
   escreva  ("Digite o numéro da poltrona -> ")
   leia(i)
   se (i <> 0) então
      polt[i] <- i
      polts [i] <- 0
      escreval ("Passagem cancelada com sucesso!")
      escreva (" Retorne ao menu principal digitando [6] -> ")
      leia (menu)
      
   fimse
fimse

//menu 5 vai finalizar e contar quanto foi gasto
       se menu = 5 então
          escreval()
          escreval ("Deseja finalizar sua compra?")
          escreval ("Para Sim -> aperte [s] | Para Não -> aperte [n]")
          escreva  ("Digite a sua opção -> ")
          leia(respc)
          se (respc = "s") então
             escreva()
             para i de 1 ate 48 faca
               se (polts[i] <> 0 ) então
                  Tot <- Tot + 1
                  timer(1000)
                  timer(0)
                  limpatela()
               fimse
            fimpara
          senao
               se (respc= "n") então
                  menu <- 6
                  timer(1500)
                  timer(0)
                  limpatela()
               fimse
          fimse
       fimse

fimenquanto

// dando o total pago)
escreval("---")
escreval("Total de passagem: ", Tot)
escreval("Valor total das passagens foi:" , " R$ ", Tot * Totg:4:2)
escreval("----")
escreval("Desejamos a você uma otima viagem!")

Eu preciso que nesse código, ao reservar uma cadeira o mapa apareça "--" invés de 0. E preciso que ao trocar essa cadeira por outra, volte a numeração da cadeira na ordem correta e o "--" vá para a outra.

O que acontece agora é que aparece um zero quando reservo, "0", e quando troco o zero realmente vai pra outra poltrona, mas a que estava antes não fia na numeração correta. Na que estava antes fica o número 1

Editado por Simon Viegas
Alterar tipo de code para C Languages

Compartilhar este post


Link para o post
Compartilhar em outros sites

Olá @Luis Fillipe.

 

1#

Sobre:

2 horas atrás, Luis Fillipe disse:

Eu preciso que nesse código, ao reservar uma cadeira o mapa apareça "--" invés de 0.

 

Tem algumas formas, uma delas seria em vez de usar um vetor de inteiro, usar um vetor de caractere (literal). Ai armazenaria "--" em vez de 0. Lembrando números também podem ser representados por caracteres... só que em vez de, por exemplo, 14, seria "14".... como o i é do tipo inteiro, poderá converter de inteiro para caractere e jogar no vetor.

 

 

 

2#

2 horas atrás, Luis Fillipe disse:

E preciso que ao trocar essa cadeira por outra, volte a numeração da cadeira na ordem correta e o "--" vá para a outra.

O que acontece agora é que aparece um zero quando reservo, "0", e quando troco o zero realmente vai pra outra poltrona, mas a que estava antes não fia na numeração correta. Na que estava antes fica o número 1


Então, qual a lógica para posição antiga? se não me engano, é a própria posição do vetor, logo, seria igual a i (ou a variável que está representando a posição). Se for seguir a sugestão 1#, obviamente teria que converter também de inteiro para caractere.

 

 

****

 

No aguardo.

 

 

 

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário






Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×