Ir ao conteúdo
  • Cadastre-se
Guilherme Montelo

Excel Função SOMASE não retorna os valores

Recommended Posts

Prezados,

Possuo uma worksheet de nome Combustível com a seguinte estrutura

 

Hodômetro          Data                        Combustível       Preço (L)     Valor Total

259261         08/09/2018  12:49:56    Gasolina Comum      4,564          R$ 53,07

357598         30/07/2018  07:44:11    Gasolina Comum      4,599          R$ 20,00

454846         11/05/2018  07:09:49    Gasolina Comum      4,202          R$ 10,00

554499         02/05/2018  08:36:00     Gasolina Comum      4,298          R$ 20,03

 

Em uma outra worksheet preciso uma célula receba a soma dos valores da coluna "Valor Total" da worksheet "Combustível" que estejam dentro do intervalo do mês de maio, deste modo estou utilizando a seguinte formula no entanto a soma dos valores não são retornados.

=SOMASE(Combustível!B2:B26;">DATA(2018;5;1)&<DATA(2018;5;31";Combustível!E2:E26)

Acredito que não haja erro de sintaxe pois o excel não apresenta erro na formula, ressalto que a coluna B está formada como data.

SOMASE.xlsx

Compartilhar este post


Link para o post
Compartilhar em outros sites
8 minutos atrás, Guilherme Montelo disse:

Prezados,

Possuo uma worksheet de nome Combustível com a seguinte estrutura

 

Hodômetro          Data                        Combustível       Preço (L)     Valor Total

259261         08/09/2018  12:49:56    Gasolina Comum      4,564          R$ 53,07

357598         30/07/2018  07:44:11    Gasolina Comum      4,599          R$ 20,00

454846         11/05/2018  07:09:49    Gasolina Comum      4,202          R$ 10,00

554499         02/05/2018  08:36:00     Gasolina Comum      4,298          R$ 20,03

 

Em uma outra worksheet preciso uma célula receba a soma dos valores da coluna "Valor Total" da worksheet "Combustível" que estejam dentro do intervalo do mês de maio, deste modo estou utilizando a seguinte formula no entanto a soma dos valores não são retornados.

=SOMASE(Combustível!B2:B26;">DATA(2018;5;1)&<DATA(2018;5;31";Combustível!E2:E26)

Acredito que não haja erro de sintaxe pois o excel não apresenta erro na formula, ressalto que a coluna B está formada como data.

SOMASE.xlsx

@Guilherme Montelo tente dessa forma:

 

=SOMASES(Combustível!$E$2:$E$5;Combustível!$B$2:$B$5;">=01/05/2018";Combustível!$B$2:$B$5;"<=31/05/2018")

SOMASE_diegojanjao.xlsx

  • Obrigado 1

Compartilhar este post


Link para o post
Compartilhar em outros sites
26 minutos atrás, diego_janjao disse:

@Guilherme Montelo tente dessa forma:

 


=SOMASES(Combustível!$E$2:$E$5;Combustível!$B$2:$B$5;">=01/05/2018";Combustível!$B$2:$B$5;"<=31/05/2018")

SOMASE_diegojanjao.xlsx

 

Obrigado Diego funcionou.

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar agora





Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×