Ir ao conteúdo
  • Cadastre-se
lucas s. araujo

VisualG mostre o nome, as notas e a media do melhor aluno

Recommended Posts

por favor me ajudem!

sou iniciante no visualg e consigo fazer isso: 

faça um programa usando uma estrutura de repetição onde será digitado os dados de uma turma  de 10 alunos da escola, como nome, nota 1 e nota 2. No final mostre o nome, as notas e a media do melhor aluno. mostre tambem a media da turma.

 

EU SO FIZ ISSO:

 

algoritmo "semnome"
var
   nome: vetor [1..10] de caracter
   n1,n2: vetor [1..10] de real
   i,t:inteiro
   media:vetor [1..10] de real
   maior: real
inicio
   para i de 1 ate 10 faca
      escreva ("digite o nome", i, "° aluno:")
      leia (nome)
      escreva ("digite a nota1:")
      leia (n1)
      escreva ("digite a nota2:")
      leia (n2)
      escreval ("__________________________________")
      escreval ("__________________________________")
   fimpara

   para i de 1 ate 10 faca
      media <- (n1 + n2) /2
   fimpara


   para i de 1 ate 10 faca
      se (media > maior) entao
         maior <- media
         t <-


      fimse
   fimpara
   escreval("melhor aluno: ",maior)

fimalgoritmo

 

Editado por DiF
Caro usuário, por gentileza use o botão CODE <> para postar seus códigos.
  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

@lucas s. araujo Olá. O que você tem que entender para resolver esse exercício é que está trabalhando com vetores, e não variáveis comuns, logo, você vai precisar trabalhar com os índices dos vetores.

Por exemplo: Você está fazendo isso:

para i de 1 ate 10 faca
    escreva ("digite o nome", i, "° aluno:")
    leia (nome)

Só que aí eu pergunto: Você tem que ler apenas 1 nome ou 10? São 10, logo você vai ter que passar o índice do nome junto, pois nome é um vetor do tipo caracter.

O loop vai de 1 até 10, que é exatamente o tamanho do vetor nome, logo, teria que fazer dessa forma:

leia (nome[i])

Quando for digitado o primeiro nome, esse nome vai ser armazenado na índice 1 do vetor, o segundo nome no índice 2, o terceiro nome no índice 3 e assim por diante e, no final, você vai ter um vetor com 10 nomes. Conseguiu entender essa lógica?

Se ficou com dúvidas nessa parte pergunte! Não fique sem entender isso, ok?

E aí o mesmo você deve fazer com n1, n2 e media, que também são vetores, e não variáveis comuns

Se você conseguir entender essa lógica é mais da metade do caminho andado para resolver esse exercício. Por isso, se ainda ficou com dúvidas fique a vontade para perguntar!  :thumbsup:

adicionado 41 minutos depois

Segue um pequeno código para mostrar melhor o que estou querendo explicar e para ficar mais fácil para você entender:

algoritmo "semnome"

var
   nome: vetor [1..3] de caracter
   i: inteiro
inicio

  para i de 1 ate 3 faca:
       escreva("digite o nome do", i, "° aluno: ")
       leia(nome[i])
  fimpara
  
  para i de 1 ate 3 faca:
       escreval("Nome do", i, "º aluno: ", nome[i])
  fimpara

fimalgoritmo

Caso esteja achando muito complicado não se preocupe, para quem está começando a programar como você trabalhar com vetores no começo vai parecer um tanto quanto "estranho". Mas o importante é não desanimar, pois a boa notícia que tenho para te dar é que com o passar do tempo as coisas vão ficando cada vez mais claras e você vai passar a entender com muito mais facilidade a respeito do que está sendo ensinado

Também para ajudar com seus estudos, vou passar um e-book que é um mini curso de lógica de programação para iniciantes que acredito que pode te ajudar muito: 

ebook-logica-de-programacao-para-iniciantes.pdf

Editado por giu_d
corrigir comentário
  • Curtir 2

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar agora





Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×