Ir ao conteúdo
  • Cadastre-se
FaustoJr

Macro para limpar os valores das células de uma coluna sem apagar as fórmulas

Recommended Posts

Boa noite, preciso de uma macro para apagar os valores das células do intervalo (G5:G64), mas que não apague as fórmulas destas células. Obrigado

Compartilhar este post


Link para o post
Compartilhar em outros sites

Este código somente limpa as células.

Sub DeletaConstantesV1()
 Range("G5:G64").SpecialCells(2).Value = ""
End Sub

 

Como alternativa, este outro exclui as células.

Sub DeletaConstantesV2()
Range("G5:G64").SpecialCells(2).Delete Shift:=xlUp
End Sub

 

Compartilhar este post


Link para o post
Compartilhar em outros sites

As celulas G5:G64 possuem formulas que você preenche.

 

Sendo assim você precisa apagar os dados de onde alimenta essas celulas 

 

Vamos supor que as celula G5 tenha essa formula

 

=A5*F5 

 

Entao em G5  coloque um SE = SE(A5*F5)=0;"";(A5*F5)), repita para as demais celulas da coluna.

 

Ou seja

 

Se o Resultado da formula for 0 você deixa a celula Vazia

 

Pessoalmente prefiro usar a formatação condicional.

Compartilhar este post


Link para o post
Compartilhar em outros sites

Boa noite. Na verdade, nas células da coluna "G" eu tenho a seguinte fórmula "=SOMA(D5:F5)" na célula "G5", "=SOMA(D6:F6)"  na célula "G6" e assim por diante até a célula "G64". Tenho um botão para "Limpar Cotas" que quando acionado apaga os valores das colunas "C" e "E" e copia os valores da coluna "G" e os cola na coluna "F". Até aí tudo bem, mas preciso que ainda neste comando do botão os valores da coluna "G" sejam apagados sem que as fórmulas destas células sejam apagas. Desta forma, assim que eu inserir um valor em ao menos uma célula da coluna "C", todos os valores da coluna "G" voltem a ser calculados conforme a fórmula contida em suas células.

Será que isto é possível?

Obrigado

Compartilhar este post


Link para o post
Compartilhar em outros sites
17 minutos atrás, FaustoJr disse:

... mas preciso que ainda ... os valores da coluna "G" sejam apagados sem que as fórmulas destas células sejam apagas.

 

Me parece que você utiliza o termo "apagadas" para dizer "em branco" ou "vazias".

 

Veja se aproveita:

=SE(E(C5="";E5="");"";SOMA(D5:F5))
=SE(OU(C5="";E5="");"";SOMA(D5:F5))

 

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar agora





Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×