Ir ao conteúdo
  • Cadastre-se
Hiago_h3

Portugol Algoritmo em portugol no visualG.

Posts recomendados

Faça um algoritmo que receba informações de 127 pessoas que serão informadas pelo usuário, que são: idade e o peso. Estas informações devem ser validadas para não aceitar valores inválidos. Após isso, o algoritmo deverá calcular e exibir:

a) A media da idade das pessoas que estão com peso entre 50 e 70kg;

b) O percentual de pessoas cuja idade está entre 10 e 14 anos e cujo peso está acima de 70kg.

Me ajudem, por favor. Não estou conseguindo fazer o codigo para a questão A e nem a B. Também não sei como validar.

Desde já obrigado!

Compartilhar este post


Link para o post
Compartilhar em outros sites

Olá. Poste o que tentou fazer e suas dúvidas. Use o botão <> do editor para postar seu código. Pelas regras do fórum não podemos resolver. Também existem muitas questões semelhantes no fórum, convém dar uma olhada.

Compartilhar este post


Link para o post
Compartilhar em outros sites

Copie o codigo e insira usando o botão <> do editor. Fica melhor.

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

@Ricardov

Var
   // Seção de Declarações das variáveis
   idade, i: inteiro
   peso: real

Inicio
   // Seção de Comandos, procedimento, funções, operadores, etc...
   para i<-1 ate 127 faca
      escreval ("Insira sua idade:")
      leia (idade)
      escreval ("Insira seu peso:")
      leia (peso)
   fimpara

Fimalgoritmo

 

Compartilhar este post


Link para o post
Compartilhar em outros sites

@Hiago_h3, faça antes um programa mais simples, exemplo:

 

Lei 5 idades e exiba a sua média. E poste o código aqui.

Compartilhar este post


Link para o post
Compartilhar em outros sites

@Hiago_h3, um adendo: a sintaxe do para está incorreta.

 

Em vez de:

12 horas atrás, Hiago_h3 disse:

para i<-1 ate 127 faca

 

 

Seria:

12 horas atrás, Hiago_h3 disse:

para i de 1 ate 127 faca


Vide: https://www.apoioinformatica.inf.br/produtos/item/14-comandos-de-repeticao

 

 

 

Em relação ao que propus como base inicial:

 

1 hora atrás, Simon Viegas disse:

Ler* 5 idades e exiba a sua média.

 

Uma base:

algoritmo "FCdH"
var
   idade :inteiro
   i: inteiro
   mediaIdade :real

inicio
   para i de 1 ate 5 faca
      escreval ("Insira sua idade:")
      leia (idade)
   fimPara
   
   
fimAlgoritmo

 

Daí, complete esse algoritmo... depois ficará mais fácil para explicar o que falta.

 

No aguardo.

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

@Simon Viegas

algoritmo "FCdH"
var
   idade :inteiro
   i: inteiro
   mediaIdade :real

inicio
   para i de 1 ate 5 faca
      escreval ("Insira sua idade:")
      leia (idade)
   fimPara
   Escreval ("A media de idades é:", idade/5)


fimAlgoritmo

Só não sei se fiz 100% correto, pois não achei onde usar a variavél "mediaIdade" que você colocou aí.

  • Curtir 2

Compartilhar este post


Link para o post
Compartilhar em outros sites
Var
   // Seção de Declarações das variáveis
   idade, i: inteiro
   peso, acm1, acm2, mediapeso,mediaidade: real

Inicio
   // Seção de Comandos, procedimento, funções, operadores, etc...
   para i de 1 ate 127 faca
      escreval ("Insira sua idade:")
      leia (idade)
      enquanto (idade<=0) faca
         escreval ("Idade Invalida.")
         escreval ("Insira sua idade:")
         leia (idade)
      fimenquanto
      escreval ("Insira seu peso:")
      leia (peso)
      enquanto (peso<=0) faca
         escreval("Peso invalido.")
         escreval ("Insira seu peso:")
         leia (peso)
      fimenquanto
      se (peso>=50) e (peso<=70) entao
         acm1<- (acm1+peso)
      senao
         se (idade>=10) e (idade<=14) e (peso>70) entao
            acm2<-(acm2+1)
         fimse
      fimse
      fimpara
      mediapeso<- (acm1/127)
      mediaidade<- (acm2/127)*100
      escreval ("A média da idade das pessoas que estão com peso entre 50kg e 70kg é:", mediapeso)
      escreval ("Porcentagem de pessoas com idade entre 10 e 14 anos que estão com peso acima de de 70kg é:", mediaidade, "%")

Fimalgoritmo

@Simon Viegas  @Ricardov

Depois de muito pesquisar e quebrar a cabeça consegui fazer esse código. O que acham?

  • Curtir 2

Compartilhar este post


Link para o post
Compartilhar em outros sites
2 horas atrás, Hiago_h3 disse:

@Simon Viegas  @Ricardov

Depois de muito pesquisar e quebrar a cabeça consegui fazer esse código. O que acham?

 

Achei que ficou muito bom. Parabéns!

 

 

Só complementaria alterando essas nomenclaturas das variáveis acm1 e acm2 (Antônio Carlos Magalhães? é o nome do prefeito aqui de Salvador, rs) para algo mais sugestivos, ex.: somaPeso e somaIdade.

 

E para exibir o resultado, "formatar" a quantidade de casas decimais, ex.:

   escreval("A média da idade das pessoas que estão com peso entre 50kg e 70kg é: ", mediaPeso:1:2)
   escreval("Porcentagem de pessoas com idade entre 10 e 14 anos que estão com peso acima de de 70kg é: ", mediaidade:1:2, "%")

 

 

 

Adendo:

Para ajudar nos testes e, a depender, também podendo ser utilizado para apresentar, é possível utilizar o comando aleatorio, ex.:

   aleatorio on
   para i de 1 ate 127 faca
      escreval("Insira sua idade:")
      aleatorio -10, 100
      leia (idade)
      enquanto (idade <= 0) faca
         escreval("Idade Invalida.")
         escreval("Insira sua idade:")
         leia (idade)
      fimenquanto
      escreval ("Insira seu peso:")
      aleatorio 50, 120
      leia(peso)
      enquanto (peso <= 0) faca
         escreval("Peso invalido.")
         escreval("Insira seu peso:")
         leia (peso)
      fimenquanto
      se (peso >= 50) e (peso<=70) entao
         acm1 <- (acm1+peso)
      senao
         se (idade >= 10) e (idade<=14) e (peso>70) entao
            acm2<-(acm2+1)
         fimse
      fimse
   fimpara
   aleatorio off

 

Extra:

  • timer 200 - define em milissegundos quando tempo cada instrução deve aguardar antes de ser executada;
  • x:y - x=número de casas reservadas à esquerda, y=número de casas decimais;
  • aleatorio -10, 80 - define que os leia() serão preenchidos automaticamente por valores aleatórios. O valor a esquerda é o mínimo, o da direita o máximo (é possível também não definir e usar a faixa padrão);
  • esse recurso do aleatorio é bem interessante!!! é um dos recursos que mais gosto do VisualG. Dá até para utilizar listas!!! Se tiver interesse, qualquer coisa dá uma pesquisada no aqui no Fórum e no Google... pode ser útil para esse e futuros projeto no VisualG. Aqui tem por exemplo esse tópico:

 

  • Curtir 2

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar agora





Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×
×
  • Criar novo...