Ir ao conteúdo
  • Cadastre-se
RegilsonF

Excel RESOLVIDO Preencher uma celula com base em outra

Posts recomendados

Bom dia, 


Então... Estou com um pequeno problema em uma planilha que estou trabalhando. Queria uma forma de preencher uma célula com base no que tem em outra célula. 


Ex.  Célula (A1) e (B1)... 

Queria que a B1 preenchesse automaticamente dependendo do que tem na A1.


~Quando A1 estiver vazia - B1 fica vazia também.

~Quando A1 estiver um "x" - B1 fica com um "x" também.

~Quando A1 estiver com (uma data) - B1 calcule a data em questão e calcule 5 dias corridos de acordo com a data de A1.
 (Ex... A1 "14/01", então B1 esteja "19/01" (5 Dias depois) ... ou A1 "28/01" - A2 "02/02"

 


Espero que tenham entendido. 
Obrigado desde já!!

Compartilhar este post


Link para o post
Compartilhar em outros sites

Bom dia!

 

Usando a fórmula =SE(A3="";"";SE(A3="x";"x";A3+5)) você consegue esse resultado. Em anexo arquivo de exemplo. 

Pasta1.xlsx

  • Obrigado 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

@P. Sousa

25 minutos atrás, P. Sousa disse:

Bom dia!

 

Usando a fórmula =SE(A3="";"";SE(A3="x";"x";A3+5)) você consegue esse resultado. Em anexo arquivo de exemplo. 

Pasta1.xlsx 8 kB · 0 downloads


Funcionou perfeitamente.  Muito obrigado amigo!!! Abraço.

Compartilhar este post


Link para o post
Compartilhar em outros sites

@P. Sousa Estou com outra duvida amigo, poderia me ajudar novamente?

 

Então... Creio que é com a formula "SE" novamente (Juro que irei estuda-lá mais depois kkkkk) ...


Na planilha controlo [Capacidade de estoque fixo; Estoque atual; Espaço de recebimento] digamos que estão nas células A2, B2, C2.

 

Na célula "A2" sempre terá um numero fixo (10...20...30...)


Queria que ao preencher manualmente a célula  "B2" a célula "C2" automaticamente seja preenchida.


EX. A célula A2 tem o estoque de (200) ... Queria que:
Se "B2" estiver vazia = "C2" continue vazia também.

SE "B2" estiver preenchida = "C2" calcule (A2 - B2) 
[A2=200 ... B2=100 ...  C2 Calcule 200-100... ou A2=200 ... B2=50 ...  C2 Calcule 200-50...]

 

Consegue me ajudar?

adicionado 7 minutos depois

@P. Sousa .... Ref. a outra pergunta acima... 
Usando sua logica na primeira resposta usei está para utilizar com a nova duvida. 

=SE(G9="";"";SE(G9="";"";F9-G9))

 

Acabou servindo para o que eu precisava.. Muito obrigado adiantado kkkk Abç

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites
5 horas atrás, RegilsonF disse:

@P. Sousa Estou com outra duvida amigo, poderia me ajudar novamente?

 

Então... Creio que é com a formula "SE" novamente (Juro que irei estuda-lá mais depois kkkkk) ...


Na planilha controlo [Capacidade de estoque fixo; Estoque atual; Espaço de recebimento] digamos que estão nas células A2, B2, C2.

 

Na célula "A2" sempre terá um numero fixo (10...20...30...)


Queria que ao preencher manualmente a célula  "B2" a célula "C2" automaticamente seja preenchida.


EX. A célula A2 tem o estoque de (200) ... Queria que:
Se "B2" estiver vazia = "C2" continue vazia também.

SE "B2" estiver preenchida = "C2" calcule (A2 - B2) 
[A2=200 ... B2=100 ...  C2 Calcule 200-100... ou A2=200 ... B2=50 ...  C2 Calcule 200-50...]

 

Consegue me ajudar?

adicionado 7 minutos depois

@P. Sousa .... Ref. a outra pergunta acima... 
Usando sua logica na primeira resposta usei está para utilizar com a nova duvida. 

=SE(G9="";"";SE(G9="";"";F9-G9))

 

Acabou servindo para o que eu precisava.. Muito obrigado adiantado kkkk Abç

Que bom que conseguiu resolver sozinho! A fórmula SE é bem interessante. Se bem utilizada tem aplicações diversas. Parabéns aí pela auto-resolução!


Não sei bem se você escreveu duplicado mas achei que tem sintaxes demais na sua fórmula. A maneira mais simples seria colocar na célula C2 a seguinte expressão: =SE(B1="";"";A1-B1)

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar agora





Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×
×
  • Criar novo...

Aprenda_a_Ler_Resistores_e_Capacitores-capa-3d-newsletter.jpg

EBOOK GRÁTIS!

CLIQUE AQUI E BAIXE AGORA MESMO!