Ir ao conteúdo
  • Cadastre-se
JuliorSoares

RESOLVIDO Erro "Serial port not selected" no windows 10, no Arduíno IDE.

Posts recomendados

Estou começando a mexer no Arduino Uno para a realização de um projeto.

Estou começando fazendo uns testes simples, para aprender a mexer com a programação e tudo mais. So que, toda vez que tento fazer o upload do codigo no IDE para o arduino, aparece um erro de "Serial port not selected". Tentei então selecionar a placa e a porta, porém, a opção de selecionar a porta nao esta disponivel, como vocês poderam vez nas imagens que enviarei.

Além disso, sempre que conecto o Arduino ao computador, aparece uma mensagem de "Dispositivo USB não reconhecido". Achei que seria problema nos drivers, então segui alguns metodos do youtube para tentar solucionar o problema, mas o windows sem diz que os Drivers instalados ja são os mais atualizados.

Ja testei em outro computador mas acontece o mesmo... Vocês teriam alguma ideia de como resolver esse problema? Segue as imagens aqui à baixo:

 

 

1381732894_Anotao2020-02-23124753.thumb.png.20f23f54923f9c4c710425461ba5e60c.png1714140096_Capturararduino.thumb.PNG.48014d6b42a1eb65fc531c30a02eb275.PNG1695039671_Semttulo.thumb.png.a4b3cf452c12f2a047e243301c5c3aad.png

 

Compartilhar este post


Link para o post
Compartilhar em outros sites

@JuliorSoares ,

 

Provávelmente seu Arduino Xing-Ling usa o CH340 ... se for, tem de instalar o driver para ele....

 

Paulo

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

Instalei esse CH340 mas continuou do mesmo jeito.

Esse Arduino que estou utilizando é de um professor meu, mas acho que ele seja original. Ta aqui um foto dele:

 

1673561180_WhatsAppImage2020-02-26at10_57_04AM.thumb.jpeg.61a5c75b170c075ae9664d5c6d81882d.jpeg303881015_WhatsAppImage2020-02-26at10_57_05AM.thumb.jpeg.348dff312a4a7b599e6f72a7df5a0dfc.jpeg

Compartilhar este post


Link para o post
Compartilhar em outros sites

Esse é igualzinho ao original !

Usa o driver que é instalado quando você baixa e instala a IDE do site do Arduino.

Deveria estar funcionando ....

 

Paulo

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

... e é igualzinho ao que tá comigo! No meu ubuntu roda de boa sem frescuras de drivers e afins.

Um norte... acho que o mc não pode ser zerado. Tem que ter um bootloader pregravado.

De novo, rode como administrador.. Também pode tentar modo compatibilidade com sistema anterior ou algo do gênero. E por último, teste em outra máquina...

Compartilhar este post


Link para o post
Compartilhar em outros sites
2 horas atrás, Isadora Ferraz disse:

... e é igualzinho ao que tá comigo! No meu ubuntu roda de boa sem frescuras de drivers e afins.

Um norte... acho que o mc não pode ser zerado. Tem que ter um bootloader pregravado.

De novo, rode como administrador.. Também pode tentar modo compatibilidade com sistema anterior ou algo do gênero. E por último, teste em outra máquina...


Nesse Arduino, quem faz a porta serial é o outro Atmega, em cima do lado esquerdo... a porta deveria ser reconhecida independente do Atmega328 ter o Bootloader ou não ...

 

Acho que alguma coisa está baleada... talvez o regulador de tensão, ou o Atmega que serve de porta USB-serial ...

 

Paulo

  • Curtir 2

Compartilhar este post


Link para o post
Compartilhar em outros sites
1 hora atrás, aphawk disse:

outro Atmega

Né! É um mega16xxx. Vi agora com uma lupa. Achei que era ftdi usb serial ou algo do gênero...

Compartilhar este post


Link para o post
Compartilhar em outros sites
38 minutos atrás, Isadora Ferraz disse:

Né! É um mega16xxx. Vi agora com uma lupa. Achei que era ftdi usb serial ou algo do gênero...

 

Sim, alguns fabricantes usam também um Atmega324U que já tem a porta USB no hardware... chinês não perde tempo !

 

Tem um projeto fantástico na Web, onde o cara emula um APPLE ][ com um Arduino Uno e 6 resistores ...... o Atmega328 faz todo o processamento do 6502, e o cara carrega um novo firmware para o Atmega16 e ele faz toda a parte de vídeo colorido .... E roda o Apple Basic em 40 colunas , colorido, na velocidade aproximada de 50% da real do Apple ....

 

É um baita truque legal esse de reprogramar o Atmega16 , ele pode fazer um monte de coisa e se comunicar via serial com o Atmega328 em alta velocidade, assim temos 2 CPUs no mesmo hardware.

 

Paulo

Compartilhar este post


Link para o post
Compartilhar em outros sites

Seria esse o driver? porque ja instalei pelo arquivo .exe. E tambem, quando utilizo o gerenciador de dispositivos, ele diz que todos os drivers mais recentes ja estão instalados...20660076_Capturardriver.thumb.PNG.430bcad60c3d782aa8c5755b3ea1dd28.PNG

Compartilhar este post


Link para o post
Compartilhar em outros sites

Opa, descobri o problema. Era simplesmente o cabo de alimentação que estava com defeito, fiz a troca do mesmo e o arduíno foi identificado de boa.

 

Mas obrigado pelas respostas mesmo assim!!

  • Haha 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar agora





Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×
×
  • Criar novo...

Eletrônica

PROMOÇÃO DE QUARENTENA

Aproveite o isolamento social para aprender eletrônica!
De R$ 39,90 por apenas R$ 19,90
Só até as 23h59min desta sexta-feira 10/04/2020

CLIQUE AQUI E COMPRE AGORA MESMO!