Ir ao conteúdo
  • Cadastre-se
Fonsequinha Junior

Como fazer esse vetor rodar em aleatório?

Posts recomendados


algoritmo "quis"

var

pergunta:vetor[0..9] de caracter

resposta:vetor[0..9] de caracter

inicio

 

pergunta[0]<- "Primeira pergunta?"

pergunta[1]<- "Segunda pergunta?"

pergunta[2]<- "Terceira pergunta?"

pergunta[3]<- "Quarta pergunta?"

pergunta[4]<- "Quinta pergunta?"

pergunta[5]<- "Sexta pergunta?"

pergunta[6]<- "Sétima pergunta?"

pergunta[7]<- "Oitava pergunta?"

pergunta[8]<- "Nona pergunta?"

pergunta[9]<- "Décima pergunta?"

 

escreval("1.",pergunta[0])

escreval("Letra A, B ou C?")

leia(resposta[0])

se (resposta[0]="C") então

   escreval("A resposta está certa!")

senao

   escreval("Resposta errada!")

fimse

escreval("2.",pergunta[1])

escreval("Letra A, B ou C: ")

leia(resposta[1])

se (resposta[1]="C") então

   escreval("A resposta está certa!")

senao

   escreval("Resposta errada!")

fimse

escreval("3.",pergunta[2])

escreval("Letra A, B ou C: ")

leia(resposta[2])

se (resposta[2]="C") então

   escreval("A resposta está certa!")

senao

   escreval("Resposta errada!")

fimse

escreval("4.",pergunta[3])

escreval("Letra A, B ou C: ")

leia(resposta[3])

se (resposta[3]="C") então

   escreval("A resposta está certa!")

senao

   escreval("Resposta errada!")

fimse

escreval("5.",pergunta[4])

escreval("Letra A, B ou C: ")

leia(resposta[4])

se (resposta[4]="C") então

   escreval("A resposta está certa!")

senao

   escreval("Resposta errada!")

fimse

escreval("6.",pergunta[5])

escreval("Letra A, B ou C: ")

leia(resposta[5])

se (resposta[5]="C") então

   escreval("A resposta está certa!")

senao

   escreval("Resposta errada!")

fimse

escreval("7.",pergunta[6])

escreval("Letra A, B ou C: ")

leia(resposta[6])

se (resposta[6]="C") então

   escreval("A resposta está certa!")

senao

   escreval("Resposta errada!")

fimse

escreval("8.",pergunta[7])

escreval("Letra A, B ou C: ")

leia(resposta[7])

se (resposta[7]="C") então

   escreval("A resposta está certa!")

senao

   escreval("Resposta errada!")

fimse

escreval("9.",pergunta[8])

escreval("Letra A, B ou C: ")

leia(resposta[8])

se (resposta[8]="C") então

   escreval("A resposta está certa!")

senao

   escreval("Resposta errada!")

fimse

escreval("10.",pergunta[9])

escreval("Letra A, B ou C: ")

leia(resposta[9])

se (resposta[9]="C") então

   escreval("A resposta está certa!")

senao

   escreval("Resposta errada!")

fimse

fimalgoritmo

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar agora





Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas comunidades sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×
×
  • Criar novo...

Aprenda a ler resistores e capacitores

EBOOK GRÁTIS!

CLIQUE AQUI E BAIXE AGORA MESMO!