×
×
Ir ao conteúdo
  • Cadastre-se

Excel Controle de horas extras (Validação de dados + Fórmula + Formatação condicional)


Ir à solução Resolvido por Patropi,

Posts recomendados

Bom dia, tenho uma planilha de controle de horas extras que estou precisando de ajuda para concluir em três tópicos (planilha em anexo).

 

Na célula E11 fiz uma formatação condicional que está funcionando alterando a cor da fonte de acordo com os limites, mas gostaria de alterar isso que ao invés de mudar a cor da fonte aparecesse ícones da seguinte forma:

 

Até 32 horas - ícone Verde

>32 e <40 horas - ícone Amarelo

> 40 horas - ícone Vermelho

 

Nessa mesma célula E11 entrar com uma validação de dados com uma mensagem de alerta informando que quando a pessoa ultrapassar de 40:59:00 venha uma mensagem para comunicar o Coordenador!

 

E por último na célula E12 gostaria que fosse mostrado um saldo de horas para a pessoa acompanhar, onde iria subtrair 40:59:00 menos o valor de E11.

 

 

Desde já agradeço a ajuda!!!

Soma de horas extras.xls

Link para o comentário
Compartilhar em outros sites

@Patropi

 

Bom dia, obrigado pela ajuda, mas se for possível gostaria que fosse feito um ajuste. Na célula E12 você colocou para fazer o cálculo subtraindo 40:59:00 da célula E11 e quando atingisse um valor maior ela ficasse em branco. Poderia ser dela mostrar o valor que passou desse limite de 40:59:00 e quando ultrapassasse já que não é possível fazer uma validação de dados, mostrar na célula B14 a mensagem Limite ultrapassado, comunique o Coordenador.

 

Obrigado!

Link para o comentário
Compartilhar em outros sites

  • Moderador
  • Solução

@sergioolisi

 

Substitua a formula da célula E12 pela formula abaixo:

=SE(E11>VALOR("40:59:00");E11-VALOR("40:59:00");VALOR("40:59:00")-E11)

 

Na célula B14 copie e cole a formula abaixo:

=SE(E11>VALOR("40:59:00");"Limite ultrapassado, comunique o Coordenador";"")

 

O problema da validação é que o resultado não é digitado, mas sim resultado de fórmula.

 

[]s

  • Curtir 1
Link para o comentário
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisa ser um usuário para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar agora

Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas comunidades sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×
×
  • Criar novo...

Aprenda a ler resistores e capacitores

EBOOK GRÁTIS!

CLIQUE AQUI E BAIXE AGORA MESMO!