Ir ao conteúdo
  • Cadastre-se
Entre para seguir isso  
adriano macedo

[Resolvido] Leia 40 números inteiros (maiores que zero - fazer consistência)

Recommended Posts

Me ajudem aí pessoal :

Leia 40 números inteiros (maiores que zero - fazer consistência),

calcule e apresente

a quantidade de pares e a quantidade de ímpares.

consegui fazer a metade tá dando um erro :

var
cont:inteiro
par,impar:real
inicio
para cont de 1 ate 40 faca
se cont mod 2 = 0 então
par <- cont + 1
senao
impar <- cont +1
fimse
fimpara
escreval(par)
escreval(impar)

fimalgoritmo

Compartilhar este post


Link para o post
Compartilhar em outros sites

Tenta:


var
cont:inteiro
par,impar:real
inicio
para cont de 1 ate 40 faca
se cont mod 2 = 0 então
par <-par+1
senao
impar <-impar+1
fimse
fimpara
escreval(par)
escreval(impar)
fimalgoritmo

Compartilhar este post


Link para o post
Compartilhar em outros sites

Valeu ! o seu jeito deu certo ,,,, olha o jeito que eu fiz deu certo mais é bem mais complicado

var
cont,cont2:inteiro
par,impar:real
inicio
cont <- 1
para cont de 1 ate 40 faca
se cont mod 2 = 0 então

cont2 <- cont + 1
par <- int(cont2 / 2)

senao
cont2 <- cont + 1
impar <- cont2 /2
fimse
fimpara
escreval(" O Total de par é :",par)
escreval(" O Total de impar é :",impar)

fimalgoritmo

Compartilhar este post


Link para o post
Compartilhar em outros sites

Pelo o enunciado, dá o entender que a leitura dos números é para ser feita pelo teclado; tanto que ele pede consistência (considerar sempre números > 0).

[]'s

LNW

Compartilhar este post


Link para o post
Compartilhar em outros sites

Caso o autor do tópico necessite, o mesmo será reaberto, para isso deverá entrar em contato com a moderação solicitando o desbloqueio.

Compartilhar este post


Link para o post
Compartilhar em outros sites
Visitante
Este tópico está impedido de receber novos posts.
Entre para seguir isso  





Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×