Ir ao conteúdo
  • Cadastre-se
Macunaíma

RESOLVIDO Iniciando no PHP

Recommended Posts

 Olá galera, estou iniciando em programação com foco na linguagem PHP, mas estou com um problema. Tenho dois IDE's aqui, um serve para C/C++(CodeBlocks) e outro para HTML/PHP(PHPstorm da JetBrain's). Fiz um curso em html5 pelo youtube e usei o PHPstorm para escrever os códigos, mas ele também serve para PHP, porém não estou conseguindo visualizar o código que deveria aparecer escrito no localhost do meu navegador, como acontecia quando fazia em html. Depois de pesquisar um pouco mais, vi que precisava de um servidor, daí baixei e instalei o Apache 2.2, mas ainda não aparece nada no localhost. No PHPstorm aparece a seguinte mensagem quando tento escrever em PHP  899v.jpg.

 

 Daí fui no site da JetBrain's e encontrei essa explicação https://www.jetbrains.com/phpstorm/webhelp/interpreters.html, mas meso assim não estou conseguindo resolver o problema!

Compartilhar este post


Link para o post
Compartilhar em outros sites

Olá, Se você não tem conhecimentos para configurar o apache,  pode baixar um pacote já configurado.

 

Faz assim:

Desinstala o apache q você instalou. 

Baixa o EasyPHP Devserver 14.1 RC11 do site do EasyPHP.

Instala ele e execute.   assim que o servidor apache estiver com o icone verde.. você já poderá interpretar seus scripts php na pasta projects 

Compartilhar este post


Link para o post
Compartilhar em outros sites

Olá, Se você não tem conhecimentos para configurar o apache,  pode baixar um pacote já configurado.

 

Faz assim:

Desinstala o apache q você instalou. 

Baixa o EasyPHP Devserver 14.1 RC11 do site do EasyPHP.

Instala ele e execute.   assim que o servidor apache estiver com o icone verde.. você já poderá interpretar seus scripts php na pasta projects 

 

Eu já instalei corretamente o apache, já tem o ícone dele na barra de tarefas. Depois que eu instalar o EasyPhp, para que irei usar o PHPStorm ?

Compartilhar este post


Link para o post
Compartilhar em outros sites

Então,

 

O servidor apache instalado por fora  é desnecessário, pois o easyphp, quando instala... ele  já instala junto o servidor apache e o servidor mysql.

Tendo os dois, fica redundante e pode dar problema.

O PHPStorm é apenas mais uma das IDE (ambiente de desenvolvimento).

 

Ele é opcional. Particularmente prefiro utilizar o Eclipse Versão Kepler  com o plugin PDT( toda a biblioteca do php para eclipse)

https://www.eclipse.org/downloads/

Compartilhar este post


Link para o post
Compartilhar em outros sites

Ah, eu tive esse problema. mas eu resolvi,  vou procurar a solução e posto aqui.

 

Edit:

 

Esse erro, acusa porque o visual studio instalado no seu pc está com uma versão que o easyphp nao reconhece.

 

tenta reinstalar por aqui: http://www.microsoft.com/en-us/download/details.aspx?id=30679

 

foi assim que eu resolvi.. o erro da " dll  " não encontrada

 

abraço

Compartilhar este post


Link para o post
Compartilhar em outros sites

De acordo com seu SO.  se for 64bits é o primeiro, se for 32 bits é o segundo.  o terceiro eu não sei.

 

No meu caso usei o x64.

Compartilhar este post


Link para o post
Compartilhar em outros sites

Cara o negocio ta complicado aqui. Baixei e instalei o arquivo como você pode ver

 

rcdq.jpg

 

mas ainda continua dando o problema da dll, será que tenho que desinstalar a versao antiga de 2010 o visual(seta preta) e deixar só a baixada agora de 2012( seta vermelha)?

Compartilhar este post


Link para o post
Compartilhar em outros sites

Acho que o melhor seria você desinstalar todos,e reinstalar só o ultimo

tenta passar o Ccleaner para limpar o registro

Compartilhar este post


Link para o post
Compartilhar em outros sites

você tem certeza que eu posso desinstalar todos os outros e deixar apenas o mais recente sem risco algum ao meu pc? Mesmo se der certo eu ainda acho que terei que configurar meu PHPstorm para escrever em php, não é? 

Compartilhar este post


Link para o post
Compartilhar em outros sites

Depois que eu instalei o Easyphp apareceu essa janela 

 

fui3.jpg

 

 

Eu sempre tive esse problema. vai aqui http://pt.dll-files.com/msvcr110.dll.html e baixa a dll e coloca no C:\Windows\System32 depois vai no Pasta do visual Express e cola ela também. vai resolver!

Compartilhar este post


Link para o post
Compartilhar em outros sites

Eu sempre tive esse problema. vai aqui http://pt.dll-files.com/msvcr110.dll.html e baixa a dll e coloca no C:\Windows\System32 depois vai no Pasta do visual Express e cola ela também. vai resolver!

 

Existe uma pasta do Visual Express ? Onde fica, não to achando ?

Compartilhar este post


Link para o post
Compartilhar em outros sites

Eu não havia conseguido resolver no notebook que eu tinha com w7 home basic, porém agora estou com um novo not. com w8.1 e o EASYPHP ta rodando certinho.

Compartilhar este post


Link para o post
Compartilhar em outros sites
Visitante
Este tópico está impedido de receber novos posts.





Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×