Ir ao conteúdo
  • Cadastre-se
BernardorValle

RESOLVIDO Erro em PROCV

Recommended Posts

Bom dia,

estou tentando atualizar uma planilha de custos, mas quando vou pesquisar o valor utilizando a função procv, o excel reconhece como erro e não efetua a pesquisa.

 

Gostaria de saber porque isso ocorre e o que posso fazer para realizar a minha pesquisa (uma vez que essa atualização é mensal e são mais de 2000 itens para serem atualizados).

 

 

Por favor se alguém tiver ideia do que possa ser.

 

Posto uma planilha em anexo.

Erro PROCV.xlsx

Compartilhar este post


Link para o post
Compartilhar em outros sites

Boa tarde Bernador

 

Existe espaços em branco no final de alguns código da coluna B e em todos da coluna F, sendo que  o Excel considera como caracteres, portanto, não considera iguais.

 

Para testar clique na célula F64 --> clique na frente do código que aparece na barra de fórmulas e veja o espaço existente.

Agora clique na célula B4 e clique na frente do código na barra de fórmulas --> você irá contatar que tem espaço na frente da célula F64 e não tem na frente de B4.

 

Outro problema que detetei, é  que a montagem da fórmula, que está incompleta, você não definiu se a procura será exata ou aproximada.

 

copie e cole na célula D3 a fórmula abaixo e arraste para as demais linhas:

=PROCV(B3;Tabela1;2;0)

 

O zero em vermelho. indica que a procura será exata, se colocar 1 a procura será aproximada.

 

Dê retorno.

 

[]s

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites
Visitante
Este tópico está impedido de receber novos posts.





Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×