Ir ao conteúdo
  • Comunicados

    • Gabriel Torres

      Seja um moderador do Clube do Hardware!   12-02-2016

      Prezados membros do Clube do Hardware, Está aberto o processo de seleção de novos moderadores para diversos setores ou áreas do Clube do Hardware. Os requisitos são:   Pelo menos 500 posts e um ano de cadastro; Boa frequência de participação; Ser respeitoso, cordial e educado com os demais membros; Ter bom nível de português; Ter razoável conhecimento da área em que pretende atuar; Saber trabalhar em equipe (com os moderadores, coordenadores e administradores).   Os interessados deverão enviar uma mensagem privada para o usuário @Equipe Clube do Hardware com o título "Candidato a moderador". A mensagem deverá conter respostas às perguntas abaixo:   Qual o seu nome completo? Qual sua data de nascimento? Qual sua formação/profissão? Já atuou como moderador em algo outro fórum, se sim, qual? De forma sucinta, explique o porquê de querer ser moderador do fórum e conte-nos um pouco sobre você.   OBS: Não se trata de função remunerada. Todos que fazem parte do staff são voluntários.
    • DiF

      Poste seus códigos corretamente!   21-05-2016

      Prezados membros do Fórum do Clube do Hardware, O Fórum oferece um recurso chamado CODE, onde o ícone no painel do editor é  <>     O uso deste recurso é  imprescindível para uma melhor leitura, manter a organização, diferenciar de texto comum e principalmente evitar que os compiladores e IDEs acusem erro ao colar um código copiado daqui. Portanto convido-lhes para ler as instruções de como usar este recurso CODE neste tópico:  
Victor Hugo Silva

Alguem pode me ajudar a converter esse código do visualg para devc ++

Recommended Posts

var
cod,qtd,preco_total,desconto,preco_final:real
inicio
escreval
("Digite o código do produto comprado: ")
leia(cod)
escreval("Digite a quantidade: ")
leia(qtd)
se (cod >= 1) e (cod <= 10) então
preco_total
<- qtd * 10
escreval("O preco total é = R$",preco_total)
se (preco_total <= 250) então
desconto
<- ((preco_total*5)/100)
preco_final <- preco_total - desconto
escreval
("O valor do desconto é = R$",desconto)
escreval("O preço final do produto é = R$",preco_final)
fimse
se
(preco_total > 250) e (preco_total <= 500)então
desconto
<- ((preco_total*10)/100)
preco_final <- preco_total - desconto
escreval
("O valor do desconto é = R$",desconto)
escreval("O preço final do produto é = R$",preco_final)
fimse
se
(preco_total > 500) então
desconto
<- ((preco_total * 15)/100)
preco_final <- preco_total - desconto
escreval
("O valor do desconto é = R$",desconto)
escreval("O preço final do produto é = R$",preco_final)
fimse
fimse
se
(cod >= 11) e (cod <= 20) então
preco_total
<- qtd * 15
escreval("O preco total é = R$",preco_total)
se (preco_total <= 250) então
desconto
<- ((preco_total*5)/100)
preco_final <- preco_total - desconto
escreval
("O valor do desconto é = R$",desconto)
escreval("O preço final do produto é = R$",preco_final)
fimse
se
(preco_total > 250) e (preco_total <= 500)então
desconto
<- ((preco_total*10)/100)
preco_final <- preco_total - desconto
escreval
("O valor do desconto é = R$",desconto)
escreval("O preço final do produto é = R$",preco_final)
fimse
se
(preco_total > 500) então
desconto
<- ((preco_total * 15)/100)
preco_final <- preco_total - desconto
escreval
("O valor do desconto é = R$",desconto)
escreval("O preço final do produto é = R$",preco_final)
fimse
fimse
se
(cod >= 21) e (cod <= 30) então
preco_total
<- qtd * 20
escreval("O preco total é = R$",preco_total)
se (preco_total <= 250) então
desconto
<- ((preco_total*5)/100)
preco_final <- preco_total - desconto
escreval
("O valor do desconto é = R$",desconto)
escreval("O preço final do produto é = R$",preco_final)
fimse
se
(preco_total > 250) e (preco_total <= 500)então
desconto
<- ((preco_total*10)/100)
preco_final <- preco_total - desconto
escreval
("O valor do desconto é = R$",desconto)
escreval("O preço final do produto é = R$",preco_final)
fimse
se
(preco_total > 500) então
desconto
<- ((preco_total * 15)/100)
preco_final <- preco_total - desconto
escreval
("O valor do desconto é = R$",desconto)
escreval("O preço final do produto é = R$",preco_final)
fimse
fimse
se
(cod >= 31) e (cod <= 40) então
preco_total
<- qtd*30
escreval("O preco total é = R$",preco_total)
se (preco_total <= 250) então
desconto
<- ((preco_total*5)/100)
preco_final <- preco_total - desconto
escreval
("O valor do desconto é = R$",desconto)
escreval("O preço final do produto é = R$",preco_final)
fimse
se
(preco_total > 250) e (preco_total <= 500)então
desconto
<- ((preco_total*10)/100)
preco_final <- preco_total - desconto
escreval
("O valor do desconto é = R$",desconto)
escreval("O preço final do produto é = R$",preco_final)
fimse
se
(preco_total > 500) então
desconto
<- ((preco_total * 15)/100)
preco_final <- preco_total - desconto
escreval
("O valor do desconto é = R$",desconto)
escreval("O preço final do produto é = R$",preco_final)
fimse
fimse
se
(cod >= 31) e (cod <= 40) então
preco_total
<- qtd * 30
escreval("O preco total é = R$",preco_total)
se (preco_total <= 250) então
desconto
<- ((preco_total*5)/100)
preco_final <- preco_total - desconto
escreval
("O valor do desconto é = R$",desconto)
escreval("O preço final do produto é = R$",preco_final)
fimse
se
(preco_total > 250) e (preco_total <= 500)então
desconto
<- ((preco_total*10)/100)
preco_final <- preco_total - desconto
escreval
("O valor do desconto é = R$",desconto)
escreval("O preço final do produto é = R$",preco_final)
fimse
se
(preco_total > 500) então
desconto
<- ((preco_total * 15)/100)
preco_final <- preco_total - desconto
escreval
("O valor do desconto é = R$",desconto)
escreval("O preço final do produto é = R$",preco_final)
fimse
fimse
fimalgoritmo

 

 

 

 

 

 

 

 

eu iniciei mais me perdi '-' 

 

 

#include <stdio.h>

#include <stdlib.h>
 
int main(){
 
  int cod,qtd,preco_total,desconto,preco_final;
  
  printf("Digite o código do produto comprado: ");
  cin(cod)
  printf<<"Digite a quantidade: ";
  cin(qtd)
  if (cod >= 1) e (cod <= 10) 
  {
  
      preco_total <- qtd * 10
      count("O preco total é = R$",preco_total)
}
  if (preco_total <= 250) 
      desconto <- ((preco_total*5)/100)
      preco_final <- preco_total - desconto
      count("O valor do desconto é = R$",desconto)
      count("O preço final do produto é = R$",preco_final)
}
  if (preco_total > 250) e (preco_total <= 500)
      desconto <- ((preco_total*10)/100)
      preco_final <- preco_total - desconto
      escreval("O valor do desconto é = R$",desconto)
      escreval("O preço final do produto é = R$",preco_final)
  }
  if (preco_total > 500) então
      desconto <- ((preco_total * 15)/100)
      preco_final <- preco_total - desconto
      escreval("O valor do desconto é = R$",desconto)
      escreval("O preço final do produto é = R$",preco_final)
}
}
  if (cod >= 11) e (cod <= 20) 
      preco_total <- qtd * 15
      escreval("O preco total é = R$",preco_total)
  if (preco_total <= 250) então
      desconto <- ((preco_total*5)/100)
      preco_final <- preco_total - desconto
      escreval("O valor do desconto é = R$",desconto)
      escreval("O preço final do produto é = R$",preco_final)
}
  if (preco_total > 250) e (preco_total <= 500)
      desconto <- ((preco_total*10)/100)
      preco_final <- preco_total - desconto
      escreval("O valor do desconto é = R$",desconto)
      escreval("O preço final do produto é = R$",preco_final)
  }
  if (preco_total > 500) 
      desconto <- ((preco_total * 15)/100)
      preco_final <- preco_total - desconto
      escreval("O valor do desconto é = R$",desconto)
      escreval("O preço final do produto é = R$",preco_final)
}
}
  if (cod >= 21) e (cod <= 30) 
      preco_total <- qtd * 20
      escreval("O preco total é = R$",preco_total)
  if (preco_total <= 250) então
      desconto <- ((preco_total*5)/100)
      preco_final <- preco_total - desconto
      escreval("O valor do desconto é = R$",desconto)
      escreval("O preço final do produto é = R$",preco_final)
}
  if (preco_total > 250) e (preco_total <= 500)
      desconto <- ((preco_total*10)/100)
      preco_final <- preco_total - desconto
      escreval("O valor do desconto é = R$",desconto)
      escreval("O preço final do produto é = R$",preco_final)
}
  if (preco_total > 500) 
      desconto <- ((preco_total * 15)/100)
      preco_final <- preco_total - desconto
      escreval("O valor do desconto é = R$",desconto)
      escreval("O preço final do produto é = R$",preco_final)
}
}
  if (cod >= 31) e (cod <= 40) 
      preco_total <- qtd*30
      escreval("O preco total é = R$",preco_total)
  if (preco_total <= 250) então
      desconto <- ((preco_total*5)/100)
      preco_final <- preco_total - desconto
      escreval("O valor do desconto é = R$",desconto)
      escreval("O preço final do produto é = R$",preco_final)
}
  if (preco_total > 250) e (preco_total <= 500)
      desconto <- ((preco_total*10)/100)
      preco_final <- preco_total - desconto
      escreval("O valor do desconto é = R$",desconto)
      escreval("O preço final do produto é = R$",preco_final)
}
  if (preco_total > 500) 
      desconto <- ((preco_total * 15)/100)
      preco_final <- preco_total - desconto
      escreval("O valor do desconto é = R$",desconto)
      escreval("O preço final do produto é = R$",preco_final)
}
}
  if (cod >= 31) e (cod <= 40) 
      preco_total <- qtd * 30
      escreval("O preco total é = R$",preco_total)
  if (preco_total <= 250) então
      desconto <- ((preco_total*5)/100)
      preco_final <- preco_total - desconto
      escreval("O valor do desconto é = R$",desconto)
      escreval("O preço final do produto é = R$",preco_final)
}
  if (preco_total > 250) e (preco_total <= 500)
      desconto <- ((preco_total*10)/100)
      preco_final <- preco_total - desconto
      escreval("O valor do desconto é = R$",desconto)
      escreval("O preço final do produto é = R$",preco_final)
}
  if (preco_total > 500)
      desconto <- ((preco_total * 15)/100)
      preco_final <- preco_total - desconto
      escreval("O valor do desconto é = R$",desconto)
      escreval("O preço final do produto é = R$",preco_final)
}
}
}

Compartilhar este post


Link para o post
Compartilhar em outros sites

Quando você diz "devc++" quer dizer C ou C++? O compilador aceita os dois, apesar de que seu código tá em C....Se for C++ posso te ajudar, senão...


se for c++

coloca o #include <iostream> no topo

using namespace std; depois da bilbioteca

 

imprima é: cout << "texto" << endl; (ou "\n")

leia é cin >> variavel;

 

atribuição de variável é = e sempre termina com " ; "

 

aonde tem essas operações com e fica:

if(cod >= 11 && cod <= 20) 
 
um exemplo (não vou fazer todos...)
 
if (cod >= 21 && cod <= 30)
      preco_total = qtd * 20;
      cout << "\nO preco total é = R$" << preco_total << endl;
}

OBS: isso aí que eu disse é c++, não c

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário






Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×