Ir ao conteúdo
  • Cadastre-se
Henrique Venceslau

Algoritmo VISUALG - VETOR

Recommended Posts

Boa noite galera. Alguem pode me ajudar nesse exercicio: um algoritmo que leia a nota de 15 alunos, mas tambem o nome dele, a turma e o professor. porém que mostre no final uma espécie de ranking de quem tirou as melhores notas, e quais professores que os alunos tem as melhores notas. Comecei a fazer só que emperrei numa parte, pois quando termino de digitar as 15 vezes a lista sai incorreta, e não sei como colocar o nome dos professores com que os alunos vão melhores. Segue aqui o que eu ja tenho, tentei usar vetor, mas não tenho muito dominio ainda nessa variavel. grato.

 

var 

 

i: inteiro
turma: caractere
nomealuno: vetor [1..15] de caractere
nomeprofessor: vetor [1..15] de caractere
nota: vetor [1..15] de inteiro
 
inicio
 

para i de 1 ate 15 faca
escreval (" Nome do Aluno ")
leia (nomealuno)
escreval (" Turma ")
leia (turma)
escreval (" Nota da prova ")
leia (nota)
escreval (" Nome do professor")
leia (nomeprofessor)
limpatela
fimpara
escreval (" Melhores alunos ")
para i de 1 ate 5 faca
se (nota)>=1 então
escreval (nomealuno," ",nota)
fimse
fimpara

 

Compartilhar este post


Link para o post
Compartilhar em outros sites

Já que a turma não é vetor, você não vai precisar digitar ela 15x, só vai precisar digitar 1x.

escreval (" Turma ")leia (turma)

você já inseriu os nomes e as notas dos 15 alunos, o que você vai fazer agora é percorrer o vetor e procurar as 5 maiores notas.

para i de 1 até 15 faça..codigo que procura a maior nota..fimpara

Compartilhar este post


Link para o post
Compartilhar em outros sites

Poderia me ajudar mais detalhadamente? Esse algoritmo tem alguma coisa de errada quando termino de digitar as 15 vezes as notas não aparecem corretamente, como as melhores. como teria que fazer para aparecer o top 5 das notas? e mostrar o nome dos professores com quem os alunos tiram as melhores notas?

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar agora





Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×