Ir ao conteúdo
  • Comunicados

    • Gabriel Torres

      Seja um moderador do Clube do Hardware!   12-02-2016

      Prezados membros do Clube do Hardware, Está aberto o processo de seleção de novos moderadores para diversos setores ou áreas do Clube do Hardware. Os requisitos são:   Pelo menos 500 posts e um ano de cadastro; Boa frequência de participação; Ser respeitoso, cordial e educado com os demais membros; Ter bom nível de português; Ter razoável conhecimento da área em que pretende atuar; Saber trabalhar em equipe (com os moderadores, coordenadores e administradores).   Os interessados deverão enviar uma mensagem privada para o usuário @Equipe Clube do Hardware com o título "Candidato a moderador". A mensagem deverá conter respostas às perguntas abaixo:   Qual o seu nome completo? Qual sua data de nascimento? Qual sua formação/profissão? Já atuou como moderador em algo outro fórum, se sim, qual? De forma sucinta, explique o porquê de querer ser moderador do fórum e conte-nos um pouco sobre você.   OBS: Não se trata de função remunerada. Todos que fazem parte do staff são voluntários.
    • DiF

      Poste seus códigos corretamente!   21-05-2016

      Prezados membros do Fórum do Clube do Hardware, O Fórum oferece um recurso chamado CODE, onde o ícone no painel do editor é  <>     O uso deste recurso é  imprescindível para uma melhor leitura, manter a organização, diferenciar de texto comum e principalmente evitar que os compiladores e IDEs acusem erro ao colar um código copiado daqui. Portanto convido-lhes para ler as instruções de como usar este recurso CODE neste tópico:  
Aesthesys

Excel - cálculo de horas

Recommended Posts

Olá tudo bem?

 

Estou em dúvida com relação a uma fórmula no Excel. Em uma coluna eu preciso somar as horas de valores positivos e negativos separadamente, para em seguida, subtrair um de outro (com uma resposta positiva ou negativa). Como ficaria esta função?

 

  1. Identificar se o valor é positivo.
  2. Se for, ele pegará esse valor e somará.
  3. Partir para a célula de baixo e verificar se o valor é positivo novamente.
  4. Se for, ele pegará esse valor e somará ao anterior (sempre incrementando o valor).
  5. Repetir o processo.

 

O mesmo ocorreria com valores negativos. Mas ele geraria uma soma diferente para os positivos e negativos. Isso é possível no Excel?

 

Link do arquivo: https://drive.google.com/open?id=0BxPljsz4RmNyTVBQVWYtNi1xeGM

 

Desde já agradeço vocês.

 

Compartilhar este post


Link para o post
Compartilhar em outros sites

Boa tarde

 

É possível sim, basta utilizar a função SOMASE.

 

Na célula H7 --> copie e cole a formula ==> =SOMASE(F6:F17;">"&0)

Na célula I7  --> copie e cole a formula ==> =SOMASE(F6:F17;"<"&0)

 

Se foi útil, clique m Curtir.

 

Dê retorno.

 

[]s

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites
37 minutos atrás, Patropi disse:

Boa tarde

 

É possível sim, basta utilizar a função SOMASE.

 

Na célula H7 --> copie e cole a formula ==> =SOMASE(F6:F17;">"&0)

Na célula I7  --> copie e cole a formula ==> =SOMASE(F6:F17;"<"&0)

 

Se foi útil, clique m Curtir.

 

Dê retorno.

 

[]s

 

Obrigado!

 

Poderia me ajudar numa ultima coisinha?

 

Eu preciso verificar duas condições numa mesma célula.

 

Por exemplo:

 

Se H7 > I7, eu faço SOMA(H7+I7)

 

Se H7 < I7, eu faço SOMA(I7+H7)

 

É possível fazer isso? Estou quebrando a cabeça e ainda não consegui.

Compartilhar este post


Link para o post
Compartilhar em outros sites

Experimente usar:

 

=SE(H7>I7;H7+I7;I7+H7)

 

Se foi útil, clique em Curtir.

 

[]s

Compartilhar este post


Link para o post
Compartilhar em outros sites
24 minutos atrás, Patropi disse:

Experimente usar:

 

=SE(H7>I7;H7+I7;I7+H7)

 

Se foi útil, clique em Curtir.

 

[]s

 

Mas, neste caso, olha o que acontece se as horas á dever são maiores que as horas que você tem no banco: pW6tRHZ.png

 

 

Compartilhar este post


Link para o post
Compartilhar em outros sites

Boa noite

 

Eu já fiz vários bancos de horas, mas nunca utilizei horas negativas e nem o sistema de horas 1904, pois sei que não funciona.

Sempre utilizo duas colunas,  uma com horas extras e outra com as horas devedoras.

 

[]s

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário






Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×