Ir ao conteúdo
  • Cadastre-se
Aesthesys

Excel - cálculo de horas

Recommended Posts

Olá tudo bem?

 

Estou em dúvida com relação a uma fórmula no Excel. Em uma coluna eu preciso somar as horas de valores positivos e negativos separadamente, para em seguida, subtrair um de outro (com uma resposta positiva ou negativa). Como ficaria esta função?

 

  1. Identificar se o valor é positivo.
  2. Se for, ele pegará esse valor e somará.
  3. Partir para a célula de baixo e verificar se o valor é positivo novamente.
  4. Se for, ele pegará esse valor e somará ao anterior (sempre incrementando o valor).
  5. Repetir o processo.

 

O mesmo ocorreria com valores negativos. Mas ele geraria uma soma diferente para os positivos e negativos. Isso é possível no Excel?

 

Link do arquivo: https://drive.google.com/open?id=0BxPljsz4RmNyTVBQVWYtNi1xeGM

 

Desde já agradeço vocês.

 

Compartilhar este post


Link para o post
Compartilhar em outros sites

Boa tarde

 

É possível sim, basta utilizar a função SOMASE.

 

Na célula H7 --> copie e cole a formula ==> =SOMASE(F6:F17;">"&0)

Na célula I7  --> copie e cole a formula ==> =SOMASE(F6:F17;"<"&0)

 

Se foi útil, clique m Curtir.

 

Dê retorno.

 

[]s

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites
37 minutos atrás, Patropi disse:

Boa tarde

 

É possível sim, basta utilizar a função SOMASE.

 

Na célula H7 --> copie e cole a formula ==> =SOMASE(F6:F17;">"&0)

Na célula I7  --> copie e cole a formula ==> =SOMASE(F6:F17;"<"&0)

 

Se foi útil, clique m Curtir.

 

Dê retorno.

 

[]s

 

Obrigado!

 

Poderia me ajudar numa ultima coisinha?

 

Eu preciso verificar duas condições numa mesma célula.

 

Por exemplo:

 

Se H7 > I7, eu faço SOMA(H7+I7)

 

Se H7 < I7, eu faço SOMA(I7+H7)

 

É possível fazer isso? Estou quebrando a cabeça e ainda não consegui.

Compartilhar este post


Link para o post
Compartilhar em outros sites
24 minutos atrás, Patropi disse:

Experimente usar:

 

=SE(H7>I7;H7+I7;I7+H7)

 

Se foi útil, clique em Curtir.

 

[]s

 

Mas, neste caso, olha o que acontece se as horas á dever são maiores que as horas que você tem no banco: pW6tRHZ.png

 

 

Compartilhar este post


Link para o post
Compartilhar em outros sites

Boa noite

 

Eu já fiz vários bancos de horas, mas nunca utilizei horas negativas e nem o sistema de horas 1904, pois sei que não funciona.

Sempre utilizo duas colunas,  uma com horas extras e outra com as horas devedoras.

 

[]s

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar agora





Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×