Ir ao conteúdo
  • Comunicados

    • Gabriel Torres

      Seja um moderador do Clube do Hardware!   12-02-2016

      Prezados membros do Clube do Hardware, Está aberto o processo de seleção de novos moderadores para diversos setores ou áreas do Clube do Hardware. Os requisitos são:   Pelo menos 500 posts e um ano de cadastro; Boa frequência de participação; Ser respeitoso, cordial e educado com os demais membros; Ter bom nível de português; Ter razoável conhecimento da área em que pretende atuar; Saber trabalhar em equipe (com os moderadores, coordenadores e administradores).   Os interessados deverão enviar uma mensagem privada para o usuário @Equipe Clube do Hardware com o título "Candidato a moderador". A mensagem deverá conter respostas às perguntas abaixo:   Qual o seu nome completo? Qual sua data de nascimento? Qual sua formação/profissão? Já atuou como moderador em algo outro fórum, se sim, qual? De forma sucinta, explique o porquê de querer ser moderador do fórum e conte-nos um pouco sobre você.   OBS: Não se trata de função remunerada. Todos que fazem parte do staff são voluntários.
    • DiF

      Poste seus códigos corretamente!   21-05-2016

      Prezados membros do Fórum do Clube do Hardware, O Fórum oferece um recurso chamado CODE, onde o ícone no painel do editor é  <>     O uso deste recurso é  imprescindível para uma melhor leitura, manter a organização, diferenciar de texto comum e principalmente evitar que os compiladores e IDEs acusem erro ao colar um código copiado daqui. Portanto convido-lhes para ler as instruções de como usar este recurso CODE neste tópico:  
Renan MB

Portugol - Visualg como usar repetição com se e vetores?

Recommended Posts

Olá bom dia, meu professor da faculdade me pediu pra fazer um programa matemático contendo o conteúdo que ele passou, com se, repetição e vetores. Alguém poderia me da uma ajuda, estou perdido.

adicionado 12 minutos depois

Queria implementar um função para valores das passagens, alguém me ajuda?

 

 

algoritmo "vendpass"
// Função :
// Autor :
// Data :
// Seção de Declarações
var
polt : vetor [1..48] de real
menu : inteiro
i, j, cont : inteiro
inicio
   para i de 1 ate 48 faca
      polt <- i
   fimpara
   menu <- 0
   enquanto menu <> 3 faca
      escreval ("Escolha: 1 - Mapa de Poltronas")
      escreval ("         2 - Venda de Passagens")
      escreval ("         3 - Sair")
      leia (menu)
      limpatela
      se menu = 1 então
         cont <- 1
         para j de 1 ate 12 faca
            escreval (polt[cont]:3, " ", polt[cont+1]:3, "            ", polt[cont+2]:3, "   ", polt[cont+3]:3)
            cont <- cont+4
         fimpara
      senao
         se menu = 2 então
            escreva ("Qual a poltrona? ")
            leia (i)
            se polt = 0 então
               escreval ("Desculpe. Poltrona ocupada. Verifique as disponiveis abaixo:")
               cont <- 1
               para j de 1 ate 12 faca
                  escreval (polt[cont]:3, " ", polt[cont+1]:3, "            ", polt[cont+2]:3, "   ", polt[cont+3]:3)
                  cont <- cont+4
               fimpara
            senao
               polt <- 0
               escreval ("Poltrona ", i, " vendida")
            fimse
         senao
            escreval ("Escolha uma opcao valida!!! ")
         fimse
      fimse
   fimenquanto
fimalgoritmo

 

Editado por DiF
Botão CODE <>
  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

Olá @Renan MB.

 

1) COMO POSTAR UM CÓDIGO

Por favor, ao postar um código, favor utilizar a tag CODE (botão <>).

 

Seu código foi postagem inicialmente sem essa tag, por favor, edite sua postagem apagando o código atual e insira novamente usando a tag.

 

 

 

2) VALOR DA PASSAGEM

Em 20/05/2017 às 09:43, Renan MB disse:

Queria implementar um função para valores das passagens, alguém me ajuda?

 

Ai vai depender de como você quer implementar esse recurso. Por exemplo, assim como tem uma tabela de poltronas, você também poderia inserir uma tabela de preço por cidades, ai cobrava o valor desejado.... A depender do requisito também, "receber" o valor pago e calcular o troco... tudo inicialmente depende de como quer fazer...

 

 

 

3) POLTRONAS EM ÔNIBUS

Posso está enganado, mas existe meio que um padrão de numeração que indica que os números ímpares ficam na janela, e os pares no corredor. Talvez não seja "sempre", mas é bem comum seguirem essa padrão.. :)

 

Poderia também exibir a poltrona na horizontal (talvez não precise se preocupar em tentar fazer isso agora, só é um sugestão mesmo), ex.:

 

onibus_poltronas.jpg

 

 

Outro ponto que acharia interessante é SEMPRE exibir o "desenho" das poltronas ocupadas e disponíveis..   Dando um efeito de como sempre ficasse disponível (após limpar a tela, teria logo que reimprimir). Mas ai depende do requisito também, se é solicitado como um menu, deixe como está...

 

 

 

4) OUTROS CONTROLES

Assim como é verificado se a poltrona está disponível, seria interessante também verificar se a poltrona informada é válida, ou seja, está entre 1 a 48 (inclusos). Quando o valor estiver fora dessa faixa, deveria ser ignorado.

 

 

***

 

Por ai vai.

 

No aguardo.

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

@Renan MB    ali no primeiro loop você esqueceu de colocar em que posição de polt vai receber o valor de i  e lá embaixo no se menu=2  não colocou também .

esse loop aqui :

para i de 1 ate 48 faca
  polt[i] <- i
fimpara

e aqui no final :

senao
  polt[i] <- 0
  escreval ("Poltrona ", i, " vendida")
fimse

 

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

@devair1010, essa falta do [i ] ocorre justamente por quê o código não foi inserido na tag CODE. A página entende esse comando como "itálico".  Por isso solicitei que repostasse o código já no item 1 do meu comentário anterior.

 

@Renan MB, estamos no aguardo.

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário






Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×