Ir ao conteúdo
  • Cadastre-se
Entre para seguir isso  
Glausilvavel

VisualG Onde foi que eu errei

Recommended Posts

var  n: inteiro
Inicio

   //Inicializando Soma
   S0MA <- 0
   //Aplicando o comoando de repetição
   para n de 0 a 90 faca
      escreva ("Digite o numero:")
      leia (F1=f2)
      //Acumulado o numero lido
Funcao: = F1 + F2;

//calculando a media
media <-soma /3
//Escrevendo a media calculada
escreva ( "A media é:"",MEDIA)
fimalgoritmo

 

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

@Glausilvavel         alguns erros, você não declarou as variáveis soma e F1 e F2 e media, você não não clocou o fimpara do loop n, e não colocou o ate, você colocou uma função para fazer o calculo das variáveis F1 + F2 sem ter criado essa função, pois primeiro você precisa criar a função e coloca-la lá no inicio , junto com as variáveis .

e você está querendo pegar a media da soma sem ter atribuído qualquer valor a essa variável e assim dividindo por tres será sempre zero,   e o comando leia não funciona desse jeito ele até pega dois dados de uma vez, assim

leia(F1,F2)

ele pega primeiro o F1 e depois de clicar enter ele pega o F2, mas para atribuir esse valor a outra variável não funciona, use uma outra linha para isso, assim :

F1 := F2

 

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar agora
Entre para seguir isso  





Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×