Ir ao conteúdo
  • Cadastre-se
Anonn

CSS Problemas com o CSS!

Recommended Posts

Estou com um problema estranho... Meu CSS não responde corretamente, não sei exatamente como dizer, mas a página consegue chamar ele, faz alterações, mas não consigo mais alterar a página pelo CSS, ela continua com suas alterações antigas. Já conferi, e está chamando o CSS corretamente, se eu mudar o nome ou o link que chama ela da erro.

 

O código está assim. 

Esse é a página "register-public".

<?php require_once 'templates/header.php';?>


	<div class="content">
     	<div class="container">
     		<div class="row">
				<?php require_once 'templates/message.php';?>
	     		<div class="col-xs-12 col-sm-5 col-md-5 col-lg-5">
	     			<div id="registro-publico" class="row btn-c well">  <!-- DIV QUE ESTÁ SENDO ALTERADO PELO CSS !-->
	     				
						<form class="form-horizontal" role="form">
						
						  <!-- Conteúdo Aqui !-->
                          
						</form>
	     			</div>
	     		</div>
     		
     		</div>
     	</div>
    </div> <!-- /container -->
<?php require_once 'templates/footer.php';?>
	

Esse é o página CSS, "div-style".


#registro-publico{
	background: skyblue; 	    
	width: 800px;   /* largura */
	height: 500px;   /* altura */
}

E no "header.php" ele está sendo chamado da seguinte forma.

	<link href="css/div-style.css" rel="stylesheet">

O CSS que está sendo aplicado na página é esse, e não deveria estar sendo:


#registro-publico{
	background: skyblue; 	 
    color: blue;
	width: 800px;   /* largura */
	height: 500px;   /* altura */
}

Tirei a linha "color: blue", porém ela continua sendo aplicada na página(fonte/letras). Já mudei o nome do arquivo, o nome no link no "header.php" e o CSS não é chamado pra página, mas se eu mover o arquivo "div-style.css" para a área de trabalho, o CSS continua sendo aplicado(que no caso é o que tem a linha "color: blue").

 

Não consigo encontrar o problema.

Compartilhar este post


Link para o post
Compartilhar em outros sites

Tem certeza que está editando o css correto? Por desencargo, altere a cor da fonte para o elemento e veja se aplica, tipo: color: red !important;

Compartilhar este post


Link para o post
Compartilhar em outros sites

@Public2004

 

Alterei e não mudou nada, a cor da fonte continua azul, mesmo apagando ou colocando, coloquei da seguinte forma:

 


#registro-publico{
	background: skyblue; 	    
	color: red !important;
	width: 800px;   /* largura */
	height: 500px;   /* altura */
}

 

Compartilhar este post


Link para o post
Compartilhar em outros sites

@Anonimmo Só para conhecimento o !important é um meio de sobrescrever uma regra já definida. Se não funcionou, só tenho duas possibilidades.

 

1) Está editando no lugar errado, arquivo errado e/ou tem mais algum outro lugar que você tem esta regra e está conflitando.

2) As vezes mesmo fechando o arquivo e abrindo de novo, o navegador mantém no cache.  Geralmente é indicado zerar o cache apertando CTRL + F5, onde você dá um 'refresh" (atualizar) na página apagando o cache. 

PS: eu tenho mania de apertar várias vezes o CTRL + F5, para ter certeza de que zerou. ( é só uma mania)

  • Curtir 2

Compartilhar este post


Link para o post
Compartilhar em outros sites
2 horas atrás, Anonimmo disse:

... mas se eu mover o arquivo "div-style.css" para a área de trabalho, o CSS continua sendo aplicado...

 

Então você não está editando o arquivo css correto. Verifique a estrutura de suas pastas/arquivos e encontre o css correto para editar.

Att.

 

Edit: Sugestões do @DiF mais completas.

Compartilhar este post


Link para o post
Compartilhar em outros sites

Obrigado @DiF

 

Era esse mesmo o problema, eu havia notado que o erro era no navegador quando abri o Firefox e rodava certinho, dei uma procurada e vi que era algo no cache mas não encontrei uma solução, a sua resposta do "Ctrl + F5" ajudou bastante. 

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

@Anonn

 

Alternativamente, para evitar ficar apertando essas duas teclas, tu pode usar o navegador anônimo ou desativar o cache no seu documento.

 

Navegador anônimo

  • Abrir navegador anônimo do Chrome é tão simples quanto apertar Ctrl + Shift + N;
  • O Firefox pede que pressione Ctrl + Shift + P;
  • No Opera, basta pressionar Ctrl + Shift + N, também;
  • Em comum, todos os navegadores também ajudam ativar o modo anônimo, pressionando o botão direito do mouse sobre o ícone da janela.

Desativar cache no documento local

  1. Clique com o botão direito do mouse, sobre o site local;
  2. Depois, tens que clicar em "Inspecionar";
    1. Também podes pressionar Ctrl + Shift + I, opcionalmente.
  3. Localize e clique na aba "Network";
  4. Clica em "Disable Cache".

 

1.png.ebb5304d541f4ed754ad39c965bd3dc6.png

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar agora





Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×