Ir ao conteúdo
  • Cadastre-se
VampMichaelis

Excel Excel não calcula horas corretamente

Recommended Posts

Estou fazendo um calculo de horas que preciso pagar para zerar meu banco de horas negativo onde eu trabalho.

 

Então criei uma planilha onde coloco a hora de entrada, a hora de saída, então ele calcula quantas horas trabalhei a mais para suprir o banco de horas negativo; por exemplo:

 

C39: 7:10 (horário de entrada)

D39: 18:21 (horário de saída)

B6: 9:00 (carga horária + almoço que totalizam 9h de trabalho)

 

Então eu faço =D39-C39-$B$6, o resultado sai pra mim como 2:11 (na celula E39).

Até ai esta tranquilo, fiz duas colunas com um período de 15 dias cada.

Ao final da primeira coluna, fiz =SOMA(E39:E53), o excel soma certinho, totalizando por exemplo 22hr 08m extra de trabalho

Na segunda coluna, teve um dia que entrei às 7h e sai às 16:20 (J39: 7:00) (K39: 16:20), totalizando apenas 00:20 (20 minutos) (na celula L39) (=K39-J39-$B$6) de extra, e no dia seguinte entrei as 7:26 e sai as 18:07, totalizando 1:41 (1h 41m) de extra. (J40: 7:26) (K40: 18:07) (L40: 1:41) (=K40-J40-$B$6)

 

Quando eu mando o excel calcular, =soma(E39:E53;L39:L53), ele faz a soma, porém mostra no total apenas 00:09, como seu tivesse apenas 9 mins trabalhados no total, ele apaga completamente os valores já somados na celula E39 até a E53. Não importa os valores que eu coloque na L40, o valor nunca soma com o restante já calculado, já tentei configurar de várias formas, porém não adianta.

 

Se eu somar individualmente as celulas L39 até as L53, ela soma corretamente, mostrando um total de 2:01, mas quando mando somar o resultado todo da e39 até a e53, e l39 até l53, ele me da o resultado de 9, e não 24hrs q seria o correto.

Nem se eu somar e39 até a e53, e depois querer incluir apenas o 2:01 ele soma corretamente, volta a mostrar 00:09

 

 

Não sei mais o que fazer... Já estou até triste...

Segue prints para explicar melhor o problema

soma 4 ok.png

soma 1 ok.png

soma 2 erro.png

soma 3 erro.png

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar agora





Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×