Ir ao conteúdo
  • Cadastre-se
Amilton Cândido

VisualG Calcular a soma dos números ímpares de 101 a 109

Recommended Posts

Caro usuário,

 

Seja bem-vindo ao Fórum do Clube do Hardware.

 

No intuito de servir como fonte de pesquisa no caso de instituições de ensino, informamos que incorrer no resolvimento por completo de questões relacionadas a disciplinas escolares de cursos técnicos e faculdades podem ser revistas e removidas pela Equipe de Moderação do Clube do Hardware.

 

Para sanar dúvidas sobre esse tipo de problema, por gentileza, publique o passo a passo do desenvolvimento da questão, projeto, monografia ou conteúdo em dúvida para que possamos analisar se a resposta está correta ou não, ou para que possa ser auxiliado com a dúvida no desenvolvimento do exercício.

 

Infelizmente, não há como resolver os trabalhos pelos usuários. O objetivo do Fórum do Clube do Hardware é auxiliar seus usuários a encontrar soluções para que possam sanar suas dúvidas, e não de trazer soluções prontas para seus usuários.. Além disso, copiar e colar respostas que não são de autoria própria do qualquer usuário é considerado plágio, o que é ilegal.

 

Esperamos que compreenda.

 

Atenciosamente,

Equipe Clube do Hardware

Compartilhar este post


Link para o post
Compartilhar em outros sites

Olá @Amilton Cândido.

 

Uma resposta seria assim:

algoritmo "FCdH"
//Escreva um programa que calcule a soma dos números ímpares de 101 a 109,
//utilizando a estrutura de repetição ENQUANTO ou REPITA.
//No visualg e em portugol
var
  i         :inteiro
  somaImpar :inteiro
Inicio
somaImpar<-0 //inicializa a variável
para i de 101 ate 109 faca //do valor inicial até o valor final (incluindo-os)
   se (i mod 2 = 1) ENTÃO //se dividir por 2 e tem resto 1, então é ímpar
      somaImpar<-somaImpar+i //vai adicionando os ímpares
   fimSe
fimPara
escreval("A soma dos ímpares entre 101 e 109 é",somaImpar)
fimalgoritmo

 

 

 

Uma outra forma, exibindo os dados:

algoritmo "FCdH"
//Escreva um programa que calcule a soma dos números ímpares de 101 a 109,
//utilizando a estrutura de repetição ENQUANTO ou REPITA.
//No visualg e em portugol
var
  i         :inteiro
  somaImpar :inteiro
Inicio
para i de 101 ate 109 faca
   se (i mod 2 = 1) ENTÃO //se dividir por 2 e tem resto 1, então é ímpar
      escreval("+",i)
      somaImpar<-somaImpar+i //vai adicionando os ímpares
   fimSe
fimPara
escreval("-----")
escreval(somaImpar)
fimalgoritmo

 

Etc

 

Qualquer dúvida é só postar.

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar agora





Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×