Ir ao conteúdo
  • Cadastre-se

Recommended Posts

Boa noite, olha eu aqui dnv... Bom, estava fazendo um algoritmo para reservar poltronas no cinema, ocorreu tudo certinho, maaaas ocorreu algo inusitado, quando eu reservo uma cadeira, a linha --Escreva("Cadeira B",[N]," Reservada") --não aparece na tela, alguem pode me dizer porque acontece isso? conflito de comandos ou sla....

algoritmo "semnome"
var
   Cadeira:Vetor[1..10] de Caractere
   C, N:Inteiro
   R :Caractere
inicio
     Para C <- 1 ate 10 faca
          Cadeira[C] <- "OK"
     Fimpara
     Repita
           Para C <- 1 ate 10 faca
                Se Cadeira[C]="OK" então
                   Escreva("[B",C,"]")
                Senao
                   Escreva("[--]")
                Fimse
           Fimpara
           Escreval("")
           Escreva("Reservar Cadeira: B")
           Leia(N)
           Se (Cadeira[N]="OK") então
               Cadeira[N] <- "X"
               Escreva("Cadeira B",[N]," Reservada")
           Senao
               Escreval("ERROR Cadeira já reservada, Tente novamente")
           Fimse
           Escreva("Deseja Reservar outra cadeira?[S/N] ")
           Leia(R)
           Limpatela
     ate(R="N")


fimalgoritmo

 

Compartilhar este post


Link para o post
Compartilhar em outros sites
58 minutos atrás, Luide Vqs disse:

Escreva("Cadeira B",[N]," Reservada") 

 

Já sabe onde está o erro... comparando com outras linhas, verás que não tem esses "[]". Basta tirá-los.

  • Obrigado 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar agora





Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×