Ir ao conteúdo
  • Comunicados

    • Gabriel Torres

      Seja um moderador do Clube do Hardware!   12-02-2016

      Prezados membros do Clube do Hardware, Está aberto o processo de seleção de novos moderadores para diversos setores ou áreas do Clube do Hardware. Os requisitos são:   Pelo menos 500 posts e um ano de cadastro; Boa frequência de participação; Ser respeitoso, cordial e educado com os demais membros; Ter bom nível de português; Ter razoável conhecimento da área em que pretende atuar; Saber trabalhar em equipe (com os moderadores, coordenadores e administradores).   Os interessados deverão enviar uma mensagem privada para o usuário @Equipe Clube do Hardware com o título "Candidato a moderador". A mensagem deverá conter respostas às perguntas abaixo:   Qual o seu nome completo? Qual sua data de nascimento? Qual sua formação/profissão? Já atuou como moderador em algo outro fórum, se sim, qual? De forma sucinta, explique o porquê de querer ser moderador do fórum e conte-nos um pouco sobre você.   OBS: Não se trata de função remunerada. Todos que fazem parte do staff são voluntários.
    • DiF

      Poste seus códigos corretamente!   21-05-2016

      Prezados membros do Fórum do Clube do Hardware, O Fórum oferece um recurso chamado CODE, onde o ícone no painel do editor é  <>     O uso deste recurso é  imprescindível para uma melhor leitura, manter a organização, diferenciar de texto comum e principalmente evitar que os compiladores e IDEs acusem erro ao colar um código copiado daqui. Portanto convido-lhes para ler as instruções de como usar este recurso CODE neste tópico:  

Recommended Posts

Boa noite, olha eu aqui dnv... Bom, estava fazendo um algoritmo para reservar poltronas no cinema, ocorreu tudo certinho, maaaas ocorreu algo inusitado, quando eu reservo uma cadeira, a linha --Escreva("Cadeira B",[N]," Reservada") --não aparece na tela, alguem pode me dizer porque acontece isso? conflito de comandos ou sla....

algoritmo "semnome"
var
   Cadeira:Vetor[1..10] de Caractere
   C, N:Inteiro
   R :Caractere
inicio
     Para C <- 1 ate 10 faca
          Cadeira[C] <- "OK"
     Fimpara
     Repita
           Para C <- 1 ate 10 faca
                Se Cadeira[C]="OK" então
                   Escreva("[B",C,"]")
                Senao
                   Escreva("[--]")
                Fimse
           Fimpara
           Escreval("")
           Escreva("Reservar Cadeira: B")
           Leia(N)
           Se (Cadeira[N]="OK") então
               Cadeira[N] <- "X"
               Escreva("Cadeira B",[N]," Reservada")
           Senao
               Escreval("ERROR Cadeira já reservada, Tente novamente")
           Fimse
           Escreva("Deseja Reservar outra cadeira?[S/N] ")
           Leia(R)
           Limpatela
     ate(R="N")


fimalgoritmo

 

Editado por Simon Viegas

Compartilhar este post


Link para o post
Compartilhar em outros sites
58 minutos atrás, Luide Vqs disse:

Escreva("Cadeira B",[N]," Reservada") 

 

Já sabe onde está o erro... comparando com outras linhas, verás que não tem esses "[]". Basta tirá-los.

  • Obrigado 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário






Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×