Ir ao conteúdo
  • Cadastre-se
amandapeico

Excel alinhar valores correspondentes entre duas colunas

Recommended Posts

Pessoal,

Tenho que conciliar diversos valores, alguns repetidos inclusive entre duas colunas: na coluna A tenho os valores pagos e na B os a pagar. Venho pesquisando alguma fórmula que alinhasse os valores iguais entre as colunas e caso exista um valor em uma coluna que não tenha na outra que esse valor fosse colocado no final da coluna, pois eu saberia que aquele não teve seu pagamento correspondente ou outra solução seria que um valor por exemplo, que tenho em B mas não tenho em A ficasse com a linha correspondente em branco. Já tentei algumas soluções de posts anteriores mas sem sucesso. Anexei a planilha com as colunas de valores.

Obrigada desde já!

fórum do hardware.xlsx

Compartilhar este post


Link para o post
Compartilhar em outros sites

Essa fórmula te serve?

=SE(CONT.SE(A:A;B1)=1;B1;"")

Considerando que A:A é o intervalo que ele irá buscar e B1 é a célula que você deseja encontrar.

 

Compartilhar este post


Link para o post
Compartilhar em outros sites

Você já tentou usar =SE(PROCV(B2;A:A;1;FALSO);B2;" ") e depois inserir filtro e classificar do menor para o maior? Ou você não pode usar a opção filtro por motivo de perca da ordem númerica?

Esse finalzinho da fórmula que não consigo inserir algo do tipo "se não encontrar o número, tornar célula em branco", mas fica como #N/D. 

Compartilhar este post


Link para o post
Compartilhar em outros sites

@lHenrique_10 Olá bom dia!

Mais uma vez obrigada, acho que agora quase deu certo.

Não preciso manter a ordem, só que acho que quando existem valores repetidos a fórmula não critica, por exemplo, tinha dois valores de 6,97 em uma coluna mas só um foi pago, a fórmula não coloca um dos 6,97 como N/D. Acredito que o único problema foi esse, estou vendo se consigo adaptar de alguma forma :)

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar agora





Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×