Ir ao conteúdo
  • Cadastre-se
Iking1

VisualG Bug no VisualG, Erro "entao"

Recommended Posts

Galera tem algo errado no algorítimo? Não sei por que o VisualG insiste em declarar esse erro, sendo que coloquei corretamente o entao, já mudei para ENTAO, ENTÃO e o erro persiste.

Captura de Tela (113).png

  • Curtir 2

Compartilhar este post


Link para o post
Compartilhar em outros sites

Boa tarde, @Iking1

 

O erro está sendo causado, pois você deve completar com parenteses as expressões que estão validadas com o e, ficando assim:

 

se (n1 >= 2) e (n2 <= 4) entao
   // Resto da lógica
fimse

De resto, me parece funcional. Porém, podemos melhorar o algoritmo utilizando o se/senao, onde evitaria validações desnecessárias, no seu caso. Supondo que a média digitada seja >= 9, não seria necessário executar todos os outros se, pois já encontramos qual o conceito em que a média se encaixa, portanto, seria interessante utilizar o senao com um se, onde os outros se seriam executados apenas se as condições dos anteriores não forem atingidas. A ideia é mais ou menos essa:

 

se num >= 9.0 entao
    escreval("Conceito A", nome, " aprovado!")
senao se (num >= 7.5) e (num < 9.0) entao
    escreval("Conceito B", nome, " aprovado!")
fimse

 

Da forma que você está fazendo, mesmo que uma das condições do se seja atingida, ele irá verificar todos os outros se de forma desnecessária. Com o exemplo acima, evitaríamos essas validações desnecessárias.

 

Se tiver alguma dúvida em relação ao se, dá uma olhadinha nesse link aqui. Caso as dúvidas persistirem, é só postar.

 

Bons estudos.

  • Curtir 2
  • Amei 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar agora





Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×