Ir ao conteúdo
  • Cadastre-se
paulonigro

Excel RESOLVIDO Reagrupar células que não sejam vazias

Posts recomendados

Boa noite!
Por favor, gostaria de saber se existe alguma maneira de reagrupar valores "espalhados" em uma linha, de maneira que eles fiquem
em ordem crescente, e sem células vazias entre eles, como segue a figura anexa.

A princípio tentei usar as funções do Excel, mas creio que somente uma função VBA, com um array,...enfim..

Desde já eu agradeço.

Att,

Nigro

Eliminar Células Vazias.png

Compartilhar este post


Link para o post
Compartilhar em outros sites

1. selecione o intervalo azul

2. menu Dados / Classificar / Opções / marque Da esquerda para a direita / OK / Classificar por ~~~> Linhas x / OK

 

Se essa for uma tarefa repetitiva grave uma macro.

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

@osvaldomp Entendi, mas o problema é que eu não posso mexer na primeira linha. Ela deve ficar onde com os valores onde estão. Acho que vou fazer uma função em VB que lê a primeira linha e grava na segunda... 

De qualquer modo obrigado!

Compartilhar este post


Link para o post
Compartilhar em outros sites

solução manual - copie a linha 1 e cole na linha 2, em seguida aplique na linha 2 o procedimento que comentei antes

 

 

solução por fórmula - cole uma cópia da fórmula abaixo em A2 e arraste para a direita (se a fórmula retornar #NOME então substitua as duas ococrrências de COLUNA por COL)

=SE(COLUNA(A1)>CONT.NÚM(1:1);"";ÍNDICE(1:1;CORRESP(MENOR(1:1;COLUNA(A1));1:1;0)))

 

solução por macro

Sub ReplicaOrdena()
 Range("A1", Cells(1, Columns.Count).End(1)).Copy [A2]
 Range("A2", Cells(2, Columns.Count).End(1)).Sort Key1:=[A2], Order1:=xlAscending, Orientation:=xlLeftToRight
End Sub

 

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar agora





Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×
×
  • Criar novo...

GRÁTIS: minicurso “Como ganhar dinheiro montando computadores”

Gabriel TorresGabriel Torres, fundador e editor executivo do Clube do Hardware, acaba de lançar um minicurso totalmente gratuito: "Como ganhar dinheiro montando computadores".

Você aprenderá sobre o quanto pode ganhar, como cobrar, como lidar com a concorrência, como se tornar um profissional altamente qualificado e muito mais!

Inscreva-se agora!