Ir ao conteúdo
  • Cadastre-se
Gabriel Aquino

VisualG VisualG (Iniciante) - questão sobre comando CASO

Posts recomendados

Olá, preciso de ajuda.

 

Fiz um algoritmo onde de multipla escolha e no final uma somatória. 

 

algoritmo "feira"

var

preco1,preco2,preco3 : real
fruta1,fruta2,fruta3 : literal
resultado: inteiro
resposta: literal
quantidade: real

inicio

preco1 <- 5
preco2 <- 2
preco3 <- 4



escreval ("Bem vindo, gostaria de comprar frutas? S/N")
leia (resposta)
se resposta = "Sim" e "sim" e "S" e "s" entao

    Escreval ("Qual das frutas? Fruta 1, Fruta 2, Fruta 3?")
senao
    Escreval ("Obrigado, até a proxima!")
fimse
    leia (resposta)
caso ("Fruta 1")
    escreval ("Quantos quilos? (Maximo 3kg)")
    leia (resposta)

caso ("1") entao
     escreva ("R$ ")
     escreva (preco1 * 1)
fimescolha

caso ("2") entao
      escreva ("R$ ")
      escreva (preco1 * 2)

caso ("3") entao
       escreva ("R$ ")
       escreva (preco1 * 3)
fimescolha
    

fimalgoritmo

porém quando eu rodo o final fica 

Bem vindo, gostaria de comprar frutas? S/N
S
Qual das frutas? Fruta 1, Fruta 2, Fruta 3?
Fruta 1
Quantos quilos? (Maximo 3kg)
1
R$  5R$  10R$  15
*** Fim da execução.
*** Feche esta janela para retornar ao Visualg.

 

Com as três opções distintas sendo que era pra ser induvidual

 

Quantos quilos? 1 = R$5;

Quantos quilos? 2 = R$10

 

e não sair tudo junto.

 

Por favor, me ajudem.

  • Amei 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

@Gabriel Aquino, poste o enunciado completo da questão. A estrutura do código vai depender do que está sendo pedido.

 

Abaixo fiz um código meio que aleatório:

algoritmo "feira"
var
   fruta1, fruta2, fruta3 : caractere
   preco1, preco2, preco3 : real
   cdFruta        : caractere
   quantidade     : inteiro
   frutaEscolhida : caractere
   total      :real
   resposta   : caractere
inicio
   fruta1 <- "Maça"
   preco1 <- 5
   fruta2 <- "Tomate"
   preco2 <- 2
   fruta3 <- "Banana"
   preco3 <- 4

   escreval("Bem vindo, gostaria de comprar frutas? S/N")
   leia (resposta)
   se ((resposta = "SIM") ou (resposta = "S")) entao
      escreval("Qual das frutas? ESCOLHA UM CÓDIGO: 1 ", fruta1,", 2 ", fruta2, ", 3 ", fruta3)
      leia(cdFruta)
      escreval("Quantos quilos? (Maximo 3kg)")
      leia(quantidade)

      escolha cdFruta
      caso "1"
         frutaEscolhida <- fruta1
         total <- preco1 * quantidade
      caso "2"
         frutaEscolhida <- fruta2
         total <- preco2 * quantidade
      caso "3"
         frutaEscolhida <- fruta3
         total <- preco2 * quantidade
      fimEscolha

      escreval("Você comprou", quantidade," ", frutaEscolhida, "(s) por R$",total)

   senao
      escreval ("Ué!? E o que você veio fazer aqui?")
   fimSe

fimAlgoritmo

 

 

Mas se atente que O SEU CÓDIGO vai depender do enunciado do problema, ou seja, daquilo que está sendo pedido para ser feito.

 

Obs.: esse código acima seria apenas um esboço. Tem alguns probleminhas básicos de lógica que precisariam ser resolvidos.

 

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

@Gabriel Aquino     na hora de imprimir o resultado na tela você pode usar o comando escreval  , que escreve e em seguida pula para a linha de baixo .

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar agora





Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×
×
  • Criar novo...

GRÁTIS: minicurso “Como ganhar dinheiro montando computadores”

Gabriel TorresGabriel Torres, fundador e editor executivo do Clube do Hardware, acaba de lançar um minicurso totalmente gratuito: "Como ganhar dinheiro montando computadores".

Você aprenderá sobre o quanto pode ganhar, como cobrar, como lidar com a concorrência, como se tornar um profissional altamente qualificado e muito mais!

Inscreva-se agora!